smark
Posts: 6
Joined: Thu Jul 23, 2015 11:21 am

Will not detect my IP

Mon Jul 27, 2015 3:48 am

http://www.circuitbasics.com/raspberry- ... less-mode/


I am following every word of these directions and for some reason everytime I use Advanced IP scanner the Raspberry doesn't show up. I even plugged it into my router and access it and also couldnt find it listed. I am using a Ethernet cord. Any suggestions?

User avatar
B.Goode
Posts: 9019
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Will not detect my IP

Mon Jul 27, 2015 6:48 am

Following the instructions in that link literally seems to suggest that you can scan the network to find the IP address of your RPi before you have installed an Operating System. That is not correct.

Nor is it correct that downloading and installing Win32DiskImager will write the Raspbian Operating System to your microSDcard.


The steps are:
install Win32DiskImager
ignore the advice about formatting as exFAT
use Win32DiskImager to write the Raspbian .img file to your SD card
put the SD card in your RPi and apply power
scan your network - or examine your router admin page - to find the IP address assigned to your RPi
use that address to make a connection from PuTTy

The first comment at the foot of the instructions appears to correctly summarise this.

smark
Posts: 6
Joined: Thu Jul 23, 2015 11:21 am

Re: Will not detect my IP

Mon Jul 27, 2015 8:42 pm

The step that I am stuck on is finding the Raspberry on my network. At the moment I can not access the Raspberry pi with a monitor, keyboard, or mouse. I only have my laptop. I correctly installed the Raspbian os on the sim card. Powered it and used advanced IP scanner and even went into ipconfig on CMD prompt.

I do not know why my Raspberry is not showing up when it is connected with an ethernet cord directly to my laptop. Advanced IP scanner isn't showing any manufactures.

User avatar
B.Goode
Posts: 9019
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Will not detect my IP

Mon Jul 27, 2015 9:48 pm

smark wrote:I do not know why my Raspberry is not showing up when it is connected with an ethernet cord directly to my laptop.
There seem to be 2 general possibilities:

1] You may not have correctly installed the Raspbian os on the sim card. In that case Raspbian will not boot and the system will not show up.

2] You have correctly installed the Raspbian os on the sim card and the system has booted correctly. At that point it should request a valid IP address from the dhcp server on the network to which it is connected, but an address has not been assigned. If you are connecting the RPi directly to your laptop, are you running a dhcp server on it to assign an address?


Using ipconfig from the CMD prompt on your Windows machine gives information about the network configuration of that machine only - it will not help you find the address of another networked machine.

FigNewton
Posts: 28
Joined: Mon Jun 29, 2015 4:41 pm

Re: Will not detect my IP

Tue Jul 28, 2015 2:18 am

smark wrote:The step that I am stuck on is finding the Raspberry on my network. At the moment I can not access the Raspberry pi with a monitor, keyboard, or mouse. I only have my laptop. I correctly installed the Raspbian os on the sim card. Powered it and used advanced IP scanner and even went into ipconfig on CMD prompt.

I do not know why my Raspberry is not showing up when it is connected with an ethernet cord directly to my laptop. Advanced IP scanner isn't showing any manufactures.
Unless your laptop is set up as/with a dhcp server, it will not hand an ip address to the RPi that you are connecting directly. How about connecting your RPi to your router, connecting your laptop to your router, and then going into the admin console of the router via the laptop browser and see if it has a table of ip addresses that it has handed out. I have two different type routers that will both list the dhcp leases they have handed out. One of them should be the RPi.

airiddha
Posts: 1
Joined: Mon Sep 28, 2015 2:22 pm

Re: Will not detect my IP

Mon Sep 28, 2015 2:26 pm

I have also connect it to my router..But this time also not showing any ip or manufacturer related with the Raspberry Pi. :roll:

Return to “Troubleshooting”