Posts: 5
Joined: Sat Apr 18, 2015 12:04 am

init uart0

Sat Apr 18, 2015 12:18 am

Hi everyone!
I'm trying to use the UART0 but I can not start it.
The base address provided in the datasheet is 0x7E20100. I'm not using Linux, I'm working on a custom kernel ... my question is how to translate the address above to use without Linux? I've tried 0x2020100, 0x20201000, 0x7E20100, 0x7E201000 ... but nothing to make the PL011 work. My board is a RaspberryPi B+ version 1.2. Thanks for any help :)

User avatar
Posts: 1820
Joined: Mon Mar 23, 2015 7:39 am
Location: Rochester, MN
Contact: Website

Re: init uart0

Sat Apr 18, 2015 6:09 am

You're in the wrong sub forum. This sub forum is clearly marker 'beginners' and your topic is clearly not 'beginning'.

Please read this doc thoroughly: http://infocenter.arm.com/help/topic/co ... DI0183.pdf

Also, on the advanced users page, you might want to explain what you're doing with the 'custom' kernel you're talking about, and why that makes any difference, and what you have tried so far... or, do you think anyone will take this question seriously if you just through it out there?

Posts: 5
Joined: Sat Apr 18, 2015 12:04 am

Re: init uart0

Sat Apr 18, 2015 5:50 pm

Believe I'm begginner. :lol:
I became a member of this work a few weeks ago in the college. And it is my first contact with the RPI board. I used to work in another board that is fully functional including the part of serial communications. My task is to make portability for RPI card that is cheaper than the other. If do you think this is interesting, when I have success I'll post my experience about portabily for rPI

Return to “Beginners”