Kaon
Posts: 14
Joined: Fri Apr 24, 2015 12:20 am

libEGL warning: DRI2: failed to authenticate

Wed Jan 20, 2016 2:12 am

I'm trying to install a QT based application onto a raspberry Pi2. I'm using this Ubuntu operating system:
https://wiki.ubuntu.com/ARM/RaspberryPi

After installing the software I attempt to run it using ./ and get the following error:

libEGL warning: DRI2: failed to authenticate

The top menubar of the application GUI is visible but nothing else.

Any advice on how to proceed is appreciated!

User avatar
diereinegier
Posts: 166
Joined: Sun Dec 30, 2012 5:45 pm
Location: Bonn, Germany
Contact: Website

Re: libEGL warning: DRI2: failed to authenticate

Tue Feb 16, 2016 11:44 am

You may try to add your user to the "video" group.
Download my repositories at https://github.com/GeorgBisseling

bl0ggy
Posts: 1
Joined: Tue May 10, 2016 7:57 am

Re: libEGL warning: DRI2: failed to authenticate

Tue May 10, 2016 8:07 am

Hello,
I encounter the same problem, and I already am in the 'video' group :

Code: Select all

[email protected] ~ $ groups pi
pi : pi adm dialout cdrom sudo audio video plugdev games users input netdev spi i2c gpio
I launch qtcreator like this :

Code: Select all

[email protected] ~ $ sudo qtcreator
libEGL warning: DRI2: failed to authenticate
Did I do something wrong ?

Thanks for you help.

User avatar
topguy
Posts: 5466
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: libEGL warning: DRI2: failed to authenticate

Wed May 11, 2016 9:16 am

For the qtcreator problem you can try

Code: Select all

qtcreator -noload Welcome
Which disable the welcome splash screen that tries to use OpenGL, this works on Jessie at least. I have never tested Qt on the Ubuntu image for RPi.

Return to “Graphics programming”