Posts: 9
Joined: Sat Apr 09, 2016 7:55 pm


Mon May 02, 2016 3:31 pm

I would like to create a concise thread on this wifi adapter.
There are quite a few threads, even some that say it works right out of the box.
For me it doesn't and I suspect that thread title is very misleading.

I'm concerned that the bottom line on this device is that the device driver must be made from source code for each kernel version.
I was pointed to a thread that has many links to the driver, each for the different versions of raspian.
(UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.1.xx+
As of the writing of this posting I am on Rasperry PI 2 running raspian 4.4.8-v7+

Code: Select all

uname -a
Linux raspberrypi 4.4.8-v7+ #881 SMP Sat Apr 30 12:16:50 BST 2016 armv7l GNU/Linux
This posting mentions USB ID that I'm not sure how to obtain for this device.

lsusb? Does this make sense to test if the driver for the device isn't found?

Code: Select all

ID 2001:3310
ID 2001:330F
ID 07B8:8179
ID 0BDA:0179
ID 0BDA:8179

and for 3.12.28+ and newer the additional devices:

ID 056E:4008
ID 2001:3311
ID 0DF6:0076
It would also seem that the latest driver is for 4.1.21-v7, so I'm not sure I can actually use these files.

Code: Select all

4.1.20-v7+ #867       - 8188eu-v7-20160319.tar.gz
4.1.21-v7+ #872, #873 - 8188eu-v7-20160406.tar.gz
I opted for the latest driver for the V2 and attempted to follow the instructions given:

Code: Select all

--2016-05-02 15:24:24--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 401869 (392K) [application/octet-stream]
Saving to: ‘8188eu-v7-20160406.tar.gz’

8188eu-v7-20160406.tar.gz      100%[=====================================================>] 392.45K  2.26MB/s   in 0.2s   

2016-05-02 15:24:25 (2.26 MB/s) - ‘8188eu-v7-20160406.tar.gz’ saved [401869/401869]

pi@raspberrypi:~/Downloads/TP-LINK $ tar xzf 8188eu-v7-20160406.tar.gz 
pi@raspberrypi:~/Downloads/TP-LINK $ ./
sudo cp 8188eu.conf /etc/modprobe.d/.
sudo install -p -m 644 8188eu.ko /lib/modules/4.1.21-v7+/kernel/drivers/net/wireless
install: cannot create regular file ‘/lib/modules/4.1.21-v7+/kernel/drivers/net/wireless’: No such file or directory
sudo depmod 4.1.21-v7+
depmod: ERROR: could not open directory /lib/modules/4.1.21-v7+: No such file or directory
depmod: FATAL: could not search modules: No such file or directory

Reboot to run the driver.

If you have already configured your wifi it should start up and connect to your
wireless network.

If you have not configured your wifi you will need to do that to enable the wifi.
Seems that running just deletes itself and all the files.

Code: Select all

ls /lib/modules
3.6.11+  4.1.19+  4.1.19-v7+  4.4.8+  4.4.8-v7+
So what about the source code? Maybe I can build it from scratch?
Any instructions on the prerequisites for building kernel drivers?

Posts: 4032
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK


Mon May 02, 2016 5:35 pm

These are the drivers I've been compiling for several years, first because there wasn't a working driver included in the image, and although a driver (r8188eu) is now included in most images for the Pi, there are folks who prefer to use the driver I compile, as well as me, and so I've continued to compile it.

The driver supports all wifi modules using the USB IDs you point too. To determine the USB ID for your wifi module plug it in to the Pi and use command lsusb. This should list all connected USB devices and their USB IDs, although with the driver that is included in the image if it did not have it's firmware installed, which was the case when it was first include, it would disable the wifi module and then it's USB ID would not be listed with lsusb. A rather stupid thing as it confused many folks when they tried initially installing their wifi.

As for "running out of the box" as far as I'm concerned this just means the driver is included in the image. The wifi still needs setting up to connect to your wifi network.

If you use a driver that is not built into the image then whenever you update the kernel you need to recompile the driver separately or reinstall an updated driver. The drivers included in the image are automatically re-compiled whenever the kernel is re-compiled/updated, but as they are included in the image you do not need to worry about them.

For my wifi drivers I now use a different filename format which should be easier to use as you do not need to look it up to see which kernel it is for. The drivers for Raspbian kernels 3.18, 4.0 and 4.1 are also available using this new filename format.

I forget how many times I have posted the following info in various different posts but the filename format I now use is now 8188eu-kernel-build.tar.gz, which uses the values from the command uname -a. Run command uname -a and take the kernel and build values and substitute them in the filename, removing the + sign from the kernel version and the # from the build.

So for kernel 4.4.8-v7+ #881 the filename to download is 8188eu-4.4.8-v7-881.tar.gz. To download and install use commands

Code: Select all

tar xzf 8188eu-4.4.8-v7-881.tar.gz
The ./ command will install the wifi driver and a config file, /etc/modprobe.d/8188eu.conf, to disable power management and also disable the built in r8188eu driver. After it has installed the driver it will delete the downloaded file and itself to save space.

If you try to download and install the driver for a different version, like you did, then you will get a variety of errors and it will not work.

There is now also a script available that will automatically search for and install the driver you need for the kernel version you are using, or to check for or install an updated driver if you want to run or run rpi-update or rpi-update commit-id. The script is available at ... ifi.tar.gz. Download it using

Code: Select all

tar xzf install-wifi.tar.gz
Run command ./install-wifi -h for details on how you can use it. It will handle several different drivers that I compile, 8188eu, 8192eu, 8812au, mt7610 and mt7612.

The source I use is available at ... rce.tar.gz and includes the source for the 8188eu and also the 8192eu, 8812au, mt7610 and mt7612 drivers.

Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Posts: 226
Joined: Mon Jul 21, 2014 9:41 am


Tue May 03, 2016 7:36 am

Got 2x of these, and am grateful to Mr. Engman for his drivers, they work very well for me. His effort is much appreciated.

Tho at this stage, I am puzzled as to why these have not been added to the mainstream Raspbian as he has been doing this more than long enough, for this to have happened.

Posts: 9
Joined: Sat Apr 09, 2016 7:55 pm


Wed May 04, 2016 2:09 am

After reformatting my sd card and reloading the latest raspian all I had to do was to modify the WPA SSID and password and my USB worked. I'm not sure what all the fuss was about.

but thanks for everyone who contributed.

Return to “Advanced users”