scollins15
Posts: 15
Joined: Fri Aug 30, 2013 3:12 pm

Pi 3 Networking Problems

Fri Apr 08, 2016 9:12 pm

I have had no luck with networking with my new Pi 3's (5 total). Problems I am experiencing is dropped wifi connections and inability to connect via a wired connection.

Pi details:
Official Raspbian Jessie Lite image from the foundations site.
Initially installed wicd-curses, which I thought was causing all kinds of issues as my connection kept dropping. This has now been removed.

uname -a:

Code: Select all

Linux trusign-e7b7 4.1.21-v7+ #872 SMP Wed Apr 6 17:34:14 BST 2016 armv7l GNU/Linux
/etc/network/interface:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)
 
# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'
 
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
 
auto lo
iface lo inet loopback
 
iface eth0 inet dhcp 
 
allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
 
allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
/etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
/etc/dhcpcd.conf

Code: Select all

# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.
 
# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel
 
# Inform the DHCP server of our hostname for DDNS.
hostname
 
# Use the hardware address of the interface for the Client ID.
clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
#duid
 
# Persist interface configuration when dhcpcd exits.
persistent
 
# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit
 
# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu
 
# A ServerID is required by RFC2131.
require dhcp_server_identifier
 
# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private
 
# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname
In the files above you will see that there is not a wireless network setup in the wpa_supplicant.conf file as I have aborted that in an effort to try and get networking to work on the eth0 interface.

Any help or explanation would be greatly appreciated.

Scot

dchao99
Posts: 45
Joined: Fri Jan 15, 2016 9:26 pm

Re: Pi 3 Networking Problems

Fri Apr 08, 2016 9:38 pm

Are you using the official Pi3 power supply?

And what WiFi channel are you using?

Code: Select all

iwlist wlan0 freq
I found my Ri3 doesn't work on channel 11,12,13... And just about working on 1 and 6

scollins15
Posts: 15
Joined: Fri Aug 30, 2013 3:12 pm

Re: Pi 3 Networking Problems

Sat Apr 09, 2016 1:26 am

dchao99 wrote:Are you using the official Pi3 power supply?
No I am using a 3A power supply. I do not have any peripherals attached to the USB slots and have this same power supply on serveral other Pi's (although not Pi3's) with no issue. I can test the supply with my oscilloscope and see just how much power the PI is using if anyone is interested.
And what WiFi channel are you using?

Code: Select all

iwlist wlan0 freq


I found my Ri3 doesn't work on channel 11,12,13... And just about working on 1 and 6

Code: Select all

sudo iwlist wlan0 freq
wlan0     11 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Current Frequency:2.412 GHz (Channel 1)
However I am not currently connecting to the wifi only trying to connect via ethernet cable. Initially when I did temporarily connect to the wireless network I was using Channel 1, however it would drop shortly after connecting.

dgordon42
Posts: 760
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Pi 3 Networking Problems

Sat Apr 09, 2016 2:35 am

There's a line in your /etc/network/interfaces file
scollins15 wrote:iface eth0 inet dhcp
Change it back to

Code: Select all

iface eth0 inet manual
This is the default value, and will allow dhcpcd to get a DHCP address from your ethernet router.

Hope this helps,
Dave.

scollins15
Posts: 15
Joined: Fri Aug 30, 2013 3:12 pm

Re: Pi 3 Networking Problems

Sat Apr 09, 2016 11:59 pm

change to

Code: Select all

iface eth0 inet manual
I made this change and the first reboot I got a 169.*.*.* address. I then removed the /etc/dhcpcd.duid file and rebooted again and did not get an IP address.

Are there other files to look at or modify with the new raspberrypi-net-mods package and Jessie that need to be setup for this to work?

Are there manual commands I can run on the command line to see output and determine the issue? How about system logs that would give guidance or indications? Thanks again for the help.

dgordon42
Posts: 760
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Pi 3 Networking Problems

Sun Apr 10, 2016 6:30 am

The wired ethernet should just work on the Pi without changing any configuration files, which is why I suggested changing back to "iface eth0 inet manual". That is the default setting.
Your Pi should, by default, get a DHCP IP address from the DHCP server in your router. If your Pi is getting an address in the 169.255.*.* range, then this is not happening. I would start by checking that you have a good connection & cable between your Pi and your router, and that your router has DHCP enabled.

Dave.

scarf
Posts: 12
Joined: Sun Apr 10, 2016 6:46 pm

Re: Pi 3 Networking Problems

Tue Apr 12, 2016 6:18 am

im also having similar issues with a fresh Raspbian installation. when i connect to either a wifi or wired network, the Pi will get a local IP address, and i can access local computers for example, but unable to resolve hostnames or connect to internet sites (even by IP address). all config files are default and my /etc/network/interfaces has "iface eth0 inet manual"

dgordon42
Posts: 760
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Pi 3 Networking Problems

Tue Apr 12, 2016 8:49 am

@scarf,
What make and model of router are you using?
Can you post the output of:

Code: Select all

cat /etc/resolv.conf
route -n
Thanks,
Dave.

scarf
Posts: 12
Joined: Sun Apr 10, 2016 6:46 pm

Re: Pi 3 Networking Problems

Tue Apr 12, 2016 7:17 pm

i have the model 3... what i had to do was edit /etc/resolvconf.conf and set "name_servers=192.168.1.1" (my router) then i had to edit /etc/network/interfaces and change the eth0 setup to:

Code: Select all

auto eth0
iface eth0 inet dhcp
seems to be working consistently now

krazykyran
Posts: 2
Joined: Tue Jul 26, 2016 2:55 pm

Re: Pi 3 Networking Problems

Tue Aug 23, 2016 2:50 am

scarf wrote:i have the model 3... what i had to do was edit /etc/resolvconf.conf and set "name_servers=192.168.1.1" (my router) then i had to edit /etc/network/interfaces and change the eth0 setup to:

Code: Select all

auto eth0
iface eth0 inet dhcp
seems to be working consistently now
This worked for me too.
Question: what if you wanted 2 "name_servers" to be in your resolv.conf list permanently?
I tried putting both name_servers=x.x.x.x in /etc/resolvconf.conf, but it only recognises the second one (seems like it overwrites the first entry). Then i changed the second entry to be "name_servers_append=y.y.y.y" and now i have 2, but is this the right way?

Cheers, K.

Return to “Troubleshooting”