fagus
Posts: 24
Joined: Sat Nov 08, 2014 8:08 pm

geen internet headless met ssh

Wed Mar 16, 2016 9:19 pm

hallo
ik heb mijn RPi en mijn laptop (ubuntu) elk met een kabel aan mijn router verbonden en gebruik mijn RPi headless met mijn laptop met ssh.
alles werkt prima, behalve dat ik mijn RPi niet met het internet kan verbinden. Ik kan geen sites pingen met mijn RPi-terminal (en ook niet via de GUI). Op mijn laptop werkt internet wel.
heeft iemand een hint?
fagus

board en OS info RPi:
pi@raspberrypi ~ $ cat /proc/cpuinfo
processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 2.00
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7
Hardware : BCM2708
Revision : 0010
Serial : 000000002bc2ce42
pi@raspberrypi ~ $ cat /proc/version
Linux version 3.18.9+ (dc4@dc4-XPS13-9333) (gcc version 4.8.3 20140303 (prerelease) (crosstool-NG linaro-1.13.1+bzr2650 - Linaro GCC 2014.03) ) #767 PREEMPT Sat Mar 7 21:41:13 GMT 2015

DirkS
Posts: 10347
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: geen internet headless met ssh

Wed Mar 16, 2016 11:29 pm

Heb je alleen problemen met het pingen van URLs of ook met IP adressen?
Werkt

Code: Select all

ping 8.8.8.8
Krijgt je Pi een IP adres via DHCP of is het static?
Als het een static adres is: wat staat er in /etc/network/interfaces?
Wat is de uitvoer van

Code: Select all

route
cat /etc/resolv.conf

fagus
Posts: 24
Joined: Sat Nov 08, 2014 8:08 pm

Re: geen internet headless met ssh

Thu Mar 17, 2016 6:46 am

ook met ip-adressen
het ip adres is static denk ik. hij krijgt altijd hetzelfde van mijn router. ik heb 192.168.10.22 toegekend aan de RPi.
/etc/network/interfaces en uitvoer route - cat /etc/resolv.conf: zal ik morgen doorsturen ik moet nu werken tot morgenavond.
veel dank
fagus

Dutch_Master
Posts: 362
Joined: Sat Jul 27, 2013 11:36 am

Re: geen internet headless met ssh

Thu Mar 17, 2016 11:28 am

Post de inhoud van /etc/resolv.conf en /etc/network/interfaces:

Code: Select all

cat /etcresolv.conf
cat /etc/network/interfaces
Ik neem aan dat je router ook het modem heeft waarmee je het internet op gaat, zoals de Fritzbox bv. Je kunt IP adressen niet zomaar vrij vergeven, het adres moet wel binnen de opgegeven range v/d DHCP server (in de router) vallen. Eenvoudige manier om te kijken welke range de router uitgeeft is kijken wat de laptop voor IP adres krijgt:

Code: Select all

ifconfig -a | grep 192
Bovenstaand uitvoeren op de laptop :P Dit geeft je een IP adres in de vorm 192.168.x.y waarbij vooral x belangrijk is: voor de RPi moet dit dezelfde waarde hebben als voor de laptop, y kan/zal/moet wel verschillend zijn.

DirkS
Posts: 10347
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: geen internet headless met ssh

Thu Mar 17, 2016 11:45 am

Dutch_Master wrote:Post de inhoud van /etc/resolv.conf en /etc/network/interfaces:

Code: Select all

cat /etcresolv.conf
cat /etc/network/interfaces
Hmmm... is there an echo in here :roll:

Dutch_Master
Posts: 362
Joined: Sat Jul 27, 2013 11:36 am

Re: geen internet headless met ssh

Thu Mar 17, 2016 6:50 pm

Blijkbaar :P

fagus
Posts: 24
Joined: Sat Nov 08, 2014 8:08 pm

Re: geen internet headless met ssh

Fri Mar 18, 2016 10:12 am

oké als bijlage de uitvoer van de gevraagde commando's en ook van enkele andere die misschien nuttig zijn.

Ik heb dus een LAN netwerk: modem/router met laptops, vaste pc's, tablet, telefoons en RPi. Internet werkt bij allemaal behalve bij RPi headless met ssh (Bij RPi standalone werkt internet wel).
Instellingen router: dhcp enabled in LAN maar IP-adressen gereserveerd voor computers, telefoons en RPi: range 192.168.10.15-192.168.10.26

fagus
Posts: 24
Joined: Sat Nov 08, 2014 8:08 pm

geen internet headless met ssh - uitvoer commandoos

Fri Mar 18, 2016 10:16 am

hieronder de uitvoer van de volgende commando's:
veel dank!
fagus

ping 8.8.8.8
route
cat /etc/resolv.conf
ping naar router
ping naar laptop ubuntu (wifi)
ping naar laptop ubuntu (eth)
ifconfig laptop
ifconfig RPi
cat /etcresolv.conf
cat /etc/network/interfaces
ifconfig -a | grep 192
ping google.com

ping 8.8.8.8

pi@raspberrypi ~ $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=1 ttl=45 time=26.9 ms
64 bytes from 8.8.8.8: icmp_req=2 ttl=45 time=27.7 ms
64 bytes from 8.8.8.8: icmp_req=3 ttl=45 time=25.9 ms
64 bytes from 8.8.8.8: icmp_req=4 ttl=45 time=25.6 ms
64 bytes from 8.8.8.8: icmp_req=5 ttl=45 time=24.8 ms
64 bytes from 8.8.8.8: icmp_req=6 ttl=45 time=26.9 ms
64 bytes from 8.8.8.8: icmp_req=7 ttl=45 time=26.7 ms
64 bytes from 8.8.8.8: icmp_req=8 ttl=45 time=25.0 ms
^C
--- 8.8.8.8 ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 7013ms
rtt min/avg/max/mdev = 24.844/26.232/27.703/0.956 ms


route

pi@raspberrypi ~ $ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.10.1 0.0.0.0 UG 0 0 0 eth0
192.168.10.0 * 255.255.255.0 U 0 0 0 eth0


cat /etc/resolv.conf

pi@raspberrypi ~ $ cat /etc/resolv.conf
nameserver 192.168.10.1


ping naar router

pi@raspberrypi ~ $ ping 192.168.10.1
PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
64 bytes from 192.168.10.1: icmp_req=1 ttl=255 time=1.12 ms
64 bytes from 192.168.10.1: icmp_req=2 ttl=255 time=1.04 ms
64 bytes from 192.168.10.1: icmp_req=3 ttl=255 time=1.07 ms
64 bytes from 192.168.10.1: icmp_req=4 ttl=255 time=1.02 ms
64 bytes from 192.168.10.1: icmp_req=5 ttl=255 time=0.983 ms
^C
--- 192.168.10.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 0.983/1.049/1.122/0.047 ms


ping naar laptop ubuntu (wifi)

PING 192.168.10.15 (192.168.10.15) 56(84) bytes of data.
64 bytes from 192.168.10.15: icmp_req=1 ttl=64 time=1.18 ms
64 bytes from 192.168.10.15: icmp_req=2 ttl=64 time=0.797 ms
64 bytes from 192.168.10.15: icmp_req=3 ttl=64 time=0.807 ms
64 bytes from 192.168.10.15: icmp_req=4 ttl=64 time=0.824 ms
64 bytes from 192.168.10.15: icmp_req=5 ttl=64 time=0.688 ms
64 bytes from 192.168.10.15: icmp_req=6 ttl=64 time=0.696 ms
64 bytes from 192.168.10.15: icmp_req=7 ttl=64 time=0.705 ms
^C
--- 192.168.10.15 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6010ms
rtt min/avg/max/mdev = 0.688/0.814/1.181/0.158 ms


ping naar laptop ubuntu (eth)

pi@raspberrypi ~ $ ping 192.168.10.20
PING 192.168.10.20 (192.168.10.20) 56(84) bytes of data.
64 bytes from 192.168.10.20: icmp_req=1 ttl=64 time=0.774 ms
64 bytes from 192.168.10.20: icmp_req=2 ttl=64 time=0.703 ms
64 bytes from 192.168.10.20: icmp_req=3 ttl=64 time=0.797 ms
64 bytes from 192.168.10.20: icmp_req=4 ttl=64 time=0.706 ms
64 bytes from 192.168.10.20: icmp_req=5 ttl=64 time=0.708 ms
64 bytes from 192.168.10.20: icmp_req=6 ttl=64 time=0.806 ms
^C
--- 192.168.10.20 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5009ms
rtt min/avg/max/mdev = 0.703/0.749/0.806/0.044 ms



ifconfig laptop

eth0 Link encap:Ethernet HWaddr 00:21:70:7d:79:17
inet addr:192.168.10.20 Bcast:192.168.10.255 Mask:255.255.255.0
inet6 addr: fe80::221:70ff:fe7d:7917/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1525 errors:0 dropped:0 overruns:0 frame:0
TX packets:1409 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1158194 (1.1 MB) TX bytes:176313 (176.3 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:393 errors:0 dropped:0 overruns:0 frame:0
TX packets:393 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:74250 (74.2 KB) TX bytes:74250 (74.2 KB)

wlan0 Link encap:Ethernet HWaddr 00:22:5f:16:bf:5e
inet addr:192.168.10.15 Bcast:192.168.10.255 Mask:255.255.255.0
inet6 addr: fe80::222:5fff:fe16:bf5e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:74 errors:0 dropped:0 overruns:0 frame:31057
TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12054 (12.0 KB) TX bytes:12337 (12.3 KB)
Interrupt:17 Base address:0xc000


ifconfig RPi

eth0 Link encap:Ethernet HWaddr b8:27:eb:c2:ce:42
inet addr:192.168.10.22 Bcast:192.168.10.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:417 errors:0 dropped:1 overruns:0 frame:0
TX packets:321 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:35563 (34.7 KiB) TX bytes:39655 (38.7 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


cat /etcresolv.conf

pi@raspberrypi ~ $ cat /etcresolv.conf
cat: /etcresolv.conf: No such file or directory


cat /etc/network/interfaces

pi@raspberrypi ~ $ cat /etc/network/interfaces
auto lo

iface lo inet loopback
#iface eth0 inet dhcp
iface eth0 inet static
address 192.168.10.22
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.10.255
gateway 192.168.10.1

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp
iface wlan0 inet static
address 192.168.10.19
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.1.255
gateway 192.168.10.1


ifconfig -a | grep 192

pi@raspberrypi ~ $ ifconfig -a | grep 192
inet addr:192.168.10.22 Bcast:192.168.10.255 Mask:255.255.255.0


ping google.com

pi@raspberrypi ~ $ ping google.com
ping: unknown host google.com


*******************

DirkS
Posts: 10347
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: geen internet headless met ssh

Fri Mar 18, 2016 1:02 pm

Ok. De kern van het probleem is dat DNS niet werkt; je kunt IP adressen pingen, maar geen URL's. Blijkbaar doet je router dat niet zelf.
Het zou interessant zijn om te zien wat er in de /etc/resolv.conf van je ubuntu laptop staat.

Je kunt hetzelfde in de /etc/resolv.conf van je Pi zetten. Of je kunt de Google dns gebruiken:
Voeg deze regel toe aan /etc/resoolv.conf:

Code: Select all

nameserver 8.8.8.8
Nog even een ander punt over je configuratie:
Instellingen router: dhcp enabled in LAN maar IP-adressen gereserveerd voor computers, telefoons en RPi: range 192.168.10.15-192.168.10.26
Zijn die addressen uitgesloten van dhe DHCP range in je router? Of heb je specifieke adressen toegkend aan b.v. de Pi.
Ik vraag dit omdat je static adressen gebruikt in /etc/network/interfaces.
Als je specifieke adressen toekent moet je in /etc/network/interfaces gewoon 'dhcp' instellen.
Dit lost dan waarschijnlijk ook het probleem met de DNS resolutie op.

Dutch_Master
Posts: 362
Joined: Sat Jul 27, 2013 11:36 am

Re: geen internet headless met ssh

Fri Mar 18, 2016 2:31 pm

En er is een typfout gemaakt:

Code: Select all

pi@raspberrypi ~ $ cat /etcresolv.conf
cat: /etcresolv.conf: No such file or directory
Logisch dattie dat niet kent, er moet nog een / tussen! :P

Code: Select all

pi@raspberrypi ~ $ cat /etc/resolv.conf
Zoals Dirk al zegt, je router kan IP addressen aan bepaalde machines koppelen, via het MAC adres v/d internet poort.

fagus
Posts: 24
Joined: Sat Nov 08, 2014 8:08 pm

Re: geen internet headless met ssh

Sat Mar 19, 2016 1:46 pm

ok opgelost!!!
een paar jaar geleden las ik in een boek over projecten met RPi dat ik static lease of static IP moest configureren. per ongeluk stelde ik static lease en static IP in. door jullie reacties zocht ik dit weer op (RPi tijdje niet gebruikt wegens 2 jaar vreemd gegaan met arduino ...) en ontdekte ik mijn fout ...
ik heb de instelling voor static IP verwijderd maar de IP reservatie behouden. Nu werkt het dus weeer en heb ik mijn RPi kunnen updaten. Veel dank!
fagus
PS hieronder de uitvoer van de configuratie toen internet niet werkte en van nu, nu het wel werkt. ook de uitvoer van cat /etc/resolv.conf.
PS heeft iemand een hint voor een goed boek over internet, configuratie hiervan, dns, dhcp, kortom het probleem waarmee ik te maken had? Ik ben nl. een newbie en snap er niet te veel van. Ik heb wel TCP/IP for dummies maar dat is echt een enorme turf.
Dank voor de hulp!
fagus



beuk@beukubuntu:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1


sudo nano /etc/network/interfaces

voor aanpassing:
auto lo

iface lo inet loopback
#iface eth0 inet dhcp
iface eth0 inet static
address 192.168.10.22
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.10.255
gateway 192.168.10.1

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp
iface wlan0 inet static
address 192.168.10.19
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.1.255
gateway 192.168.10.1

na aanpassing:
auto lo

iface lo inet loopback
iface eth0 inet dhcp
#iface eth0 inet static
# address 192.168.10.22
# netmask 255.255.255.0
# network 192.168.10.0
# broadcast 192.168.10.255
# gateway 192.168.10.1

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
#iface wlan0 inet static
# address 192.168.10.19
# netmask 255.255.255.0
# network 192.168.10.0
# broadcast 192.168.1.255
# gateway 192.168.10.1


cat /etc/resolv.conf

voor aanpassing:
pi@raspberrypi ~ $ cat /etc/resolv.conf
nameserver 192.168.10.1

na aanpassing:
pi@raspberrypi ~ $ cat /etc/resolv.conf
nameserver 195.130.130.2
nameserver 195.130.131.2

Return to “Nederlands”