dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

[RESOLVED] Pi3 WiFi stopped working

Thu Mar 03, 2016 8:27 pm

OK, was playing with my Pi3 yesterday and got wifi up fine, first selected country in (gui) raspi-config, followed by reboot, seelct SSID etc.

Last night did a reboot and no more wlan0. Have been trying to debug but could use some help, please!

ifconfig -a shows no wlan

sudo iw reg set GB works fine but doesn't stick with a reboot. Similarly now when select country in (gui) Raspi Config it goes for the reboot then dmesg has no country, viz

Code: Select all

...
[    6.828982] bcm2835-rng 3f104000.rng: hwrng registered
[    6.830207] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[    6.884335] systemd-journald[106]: Received request to flush runtime journal from PID 1
[    8.085524] uart-pl011 3f201000.uart: no DMA platform data
[    8.242791] cfg80211: Calling CRDA to update world regulatory domain
[    8.339212] Adding 102396k swap on /var/swap.  Priority:-1 extents:3 across:184320k SSFS
[    8.442305] cfg80211: World regulatory domain updated:
[    8.442320] cfg80211:  DFS Master region: unset
[    8.442325] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[    8.442333] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    8.442339] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    8.442345] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[    8.442358] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[    8.442365] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[    8.442372] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[    8.442378] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[    8.442384] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[    8.561838] random: nonblocking pool is initialized
...
Can I set the country manually somewhere? It seems to me that quite a few options I select in the gui config don't stick.

TIA
Last edited by dukla2000 on Mon Mar 07, 2016 10:44 pm, edited 1 time in total.
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: Pi3 WiFi stopped working

Fri Mar 04, 2016 10:03 am

Well still struggling, but discovered
1) It is not hardware. Using another SDcard wlan0 is there.
2) It is not the country, or at least country=GB is persistent in /etc/wpa_supplicant/wpa_supplicant.conf

I suspect it is related to the "error" message when booting about wlan0: on my card which builds wlan0 I GET the message (can't remember precisely, can't delete or similar, mentioned in the other thread about wifi problems on Pi3). On my card that doesn't build wlan0 I don't get the message (as per dmesg extract in my OP).

Can't do too much playing for 24 hours, if no other thoughts/suggestions then plan B is to start my build again from scratch.
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

dchao99
Posts: 50
Joined: Fri Jan 15, 2016 9:26 pm

Re: Pi3 WiFi stopped working

Fri Mar 04, 2016 4:05 pm

Make sure you have the reccessary brcmfmac43430-sdio.* driver installed in /lib/firmware/brcm

capricorn_fati
Posts: 6
Joined: Fri Mar 04, 2016 11:01 pm

Re: Pi3 WiFi stopped working

Fri Mar 04, 2016 11:37 pm

dukla2000 wrote:Well still struggling, but discovered
1) It is not hardware. Using another SDcard wlan0 is there.
2) It is not the country, or at least country=GB is persistent in /etc/wpa_supplicant/wpa_supplicant.conf

I suspect it is related to the "error" message when booting about wlan0: on my card which builds wlan0 I GET the message (can't remember precisely, can't delete or similar, mentioned in the other thread about wifi problems on Pi3). On my card that doesn't build wlan0 I don't get the message (as per dmesg extract in my OP).

Can't do too much playing for 24 hours, if no other thoughts/suggestions then plan B is to start my build again from scratch.

Hello dukla2000

I have the same problem. Yesterday I setup raspbian jessie problem-free on RPI3 and connected to internet via built in wifi. But today I cannot connect to the internet via built in wifi, just via RJ45 jack. It is very annoying. I erased the microsd card and write the jessie image again and trid to start at the beginning but no way. dchao99 has a suggestion. Did you apply this solution and fixed the problem? If yes, can you share these files here and tell how to add them to the related directory. Sorry for silly question.

Thank you.

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: Pi3 WiFi stopped working

Sat Mar 05, 2016 5:08 pm

my /lib/firmware/brcm directory had the same contents on both SDcards (the one that would boot with wlan0 and the 1 that had lost it).

Never worked out what I did to 'break' the 1 SDcard, but am just busy rebuilding it from scratch (as it is UHS-1 64GB) and so far so good. Typing this on it via wifi!

@capricorn_fati - good luck.
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

capricorn_fati
Posts: 6
Joined: Fri Mar 04, 2016 11:01 pm

Re: Pi3 WiFi stopped working

Sat Mar 05, 2016 8:14 pm

dukla2000 wrote:my /lib/firmware/brcm directory had the same contents on both SDcards (the one that would boot with wlan0 and the 1 that had lost it).

Never worked out what I did to 'break' the 1 SDcard, but am just busy rebuilding it from scratch (as it is UHS-1 64GB) and so far so good. Typing this on it via wifi!

@capricorn_fati - good luck.
dukla2000 Hello again,

thank you for wish of good luck.

Are your micro sd cards same brand and model? (UHS-1 64GB) If they are not the same, what brand is the working one?

My micro sd card is Samsung Evo UHS-1 16GB.

AceSG1
Posts: 4
Joined: Mon Feb 22, 2016 3:26 am

Re: Pi3 WiFi stopped working

Sun Mar 06, 2016 5:40 am

nope, I have a SanDisk Ultra microSD 16gb... I have give or take the same issue... where the wifi is there but stops then works again. it comes and goes.

User avatar
DougieLawson
Posts: 36548
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Pi3 WiFi stopped working

Sun Mar 06, 2016 8:01 am

Have you added

Code: Select all

wireless-power off
to /etc/network/interfaces or run sudo iw dev wlan0 set power_save off to disable it?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: Pi3 WiFi stopped working

Sun Mar 06, 2016 5:57 pm

Well, I have discovered what caused my problem:

Increasing the sdhost overclock_50 speed on my Toshiba Exceria SDXC UHS-1 64GB card gives impressive performance gains. However it also stops the wlan0 initialisation/creation :) May be some kind of disk corruption but I am not sure. Having rebuilt the card I got to the stage where I inserted an overclock line in my config.txt. On reboot no wlan0. Took out overclock line and wlan0 back. Card has been running fine since including fsck.

So for now sticking with stock sdhost speed.
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2487
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: Pi3 WiFi stopped working

Sun Mar 06, 2016 8:14 pm

I'm guessing that you are using the sdhost overlay? That's probably not what you want on a Pi3 because it will also disable the mmc interface which is now used for SDIO. Instead, the new base DTBs have an sd_overclock parameter which does the same thing as the overclock_50 parameter of the sdhost overlay. Delete the dtoverlay=sdhost and replace it with this:

Code: Select all

dtparam=sd_overclock=<whatever>

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: Pi3 WiFi stopped working

Sun Mar 06, 2016 11:45 pm

PhilE wrote:I'm guessing that you are using the sdhost overlay?
Yup (or was!)
PhilE wrote:That's probably not what you want on a Pi3 because it will also disable the mmc interface which is now used for SDIO. Instead, the new base DTBs have an sd_overclock parameter which does the same thing as the overclock_50 parameter of the sdhost overlay.
That figures what happened.
PhilE wrote:Delete the dtoverlay=sdhost and replace it with this:

Code: Select all

dtparam=sd_overclock=<whatever>
I've tried both dtparam=sd_overclock=64 and dtparam=sd_overclock=100, neither have any obvious change in dmesg and certainly sdbench shows CLOCK=50MHz in both cases and no performance change.
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2487
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: Pi3 WiFi stopped working

Mon Mar 07, 2016 2:52 pm

Ah, I see. Although present in the Pi1 and Pi2 DTBs, those options were missed out of the Pi3 DTB. I've pushed patches to add them, and both rpi-update and apt-get upgrade releases will be made today. In the meantime you can use the sdtweak overlay here. Use it like the old sdhost overlay:

Code: Select all

dtoverlay=sdtweak,overclock_50=80
Note that only integer divisors of the core clock (which defaults to 400MHz on Pi3) are available.

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: Pi3 WiFi stopped working

Mon Mar 07, 2016 7:55 pm

Perfect - many thanks for your help. Running like the proverbial off a shovel using sdtweak method and wifi humming perfectly
sdbench

Code: Select all

CONFIG: 
CLOCK : 100.000 MHz
CORE  : 400 MHz, turbo=1
DATA  : 512 MB, /root/test.dat

HDPARM:
======
 Timing O_DIRECT disk reads: 122 MB in  3.03 seconds =  40.31 MB/sec
 Timing O_DIRECT disk reads: 122 MB in  3.01 seconds =  40.51 MB/sec
 Timing O_DIRECT disk reads: 122 MB in  3.01 seconds =  40.51 MB/sec

WRITE:
=====
536870912 bytes (537 MB) copied, 39.8642 s, 13.5 MB/s
536870912 bytes (537 MB) copied, 41.8904 s, 12.8 MB/s
536870912 bytes (537 MB) copied, 40.3852 s, 13.3 MB/s

READ:
====
536870912 bytes (537 MB) copied, 14.965 s, 35.9 MB/s
536870912 bytes (537 MB) copied, 14.9401 s, 35.9 MB/s
536870912 bytes (537 MB) copied, 14.9466 s, 35.9 MB/s

RESULT (AVG):
============
Overlay config                      core_freq   turbo   overclock_50    WRITE        READ        HDPARM
                                       400        1     100.000 MHz   12.58 MB/s   34.25 MB/s   40.44 MB/s
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

Nickcn
Posts: 200
Joined: Sat Mar 05, 2016 8:18 pm
Location: USA

Re: [RESOLVED] Pi3 WiFi stopped working

Tue Mar 08, 2016 2:36 am

deleted
Last edited by Nickcn on Mon May 16, 2016 3:18 am, edited 1 time in total.

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: [RESOLVED] Pi3 WiFi stopped working

Tue Mar 08, 2016 8:52 am

Nickcn wrote:So, should it be working now? or has it not been pushed through yet?
Dunnoh, I downloaded sdtweak-overlay.dtb and put it in /boot/overlays. If it is working you should have a line in your system log

Code: Select all

[email protected]:~ $ dmesg | grep "mmc0"
[    2.478596] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[    2.559551] mmc0: host does not support reading read-only switch, assuming write-enable
[    2.579785] mmc0: overclocking to 100000000Hz
[    2.750746] mmc0: new high speed SDXC card at address 1234
[    2.828699] mmcblk0: mmc0:1234 SA64G 57.7 GiB 
[email protected]:~ $
Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2487
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: [RESOLVED] Pi3 WiFi stopped working

Tue Mar 08, 2016 8:56 am

We observed a potential, intermittent problem with the firmware release, only on one Pi so far, but we're taking the time to understand it before pushing out the full Raspbian release.

Nickcn
Posts: 200
Joined: Sat Mar 05, 2016 8:18 pm
Location: USA

Re: [RESOLVED] Pi3 WiFi stopped working

Tue Mar 08, 2016 2:21 pm

deleted
Last edited by Nickcn on Mon May 16, 2016 3:17 am, edited 1 time in total.

dchao99
Posts: 50
Joined: Fri Jan 15, 2016 9:26 pm

Re: [RESOLVED] Pi3 WiFi stopped working

Tue Mar 08, 2016 3:01 pm

PhilE wrote:We observed a potential, intermittent problem with the firmware release, only on one Pi so far, but we're taking the time to understand it before pushing out the full Raspbian release.
Thanks for the update.
I am seeing this intermttent WiFi problem on my Pi3 as well. In my case, the problem is worse when there is an USB SSD attached. If there is nothing attached to the USB port, the WiFi seems to stay up longer.

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2487
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: [RESOLVED] Pi3 WiFi stopped working

Tue Mar 08, 2016 3:04 pm

This is the wrong thread for an intermittent WiFi problem - this one was permanent.

ziddey
Posts: 19
Joined: Thu Mar 10, 2016 7:42 am

Re: [RESOLVED] Pi3 WiFi stopped working

Thu Mar 10, 2016 7:51 am

Thanks! Looks like sd_overclock is now supported on the rpi3.

With dtparam=sd_overclock=100, I'm seeing 40mb/s read, 20mb/s write :)

FWIW: looks like the samsung evo can handle 107 (core 425). 1:1 seq read gain with clock increase

Nickcn
Posts: 200
Joined: Sat Mar 05, 2016 8:18 pm
Location: USA

Re: [RESOLVED] Pi3 WiFi stopped working

Sat Mar 12, 2016 4:07 pm

deleted
Last edited by Nickcn on Mon May 16, 2016 3:26 am, edited 1 time in total.

Nickcn
Posts: 200
Joined: Sat Mar 05, 2016 8:18 pm
Location: USA

Re: [RESOLVED] Pi3 WiFi stopped working

Sat Mar 12, 2016 10:32 pm

deleted
Last edited by Nickcn on Mon May 16, 2016 3:25 am, edited 1 time in total.

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2487
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: [RESOLVED] Pi3 WiFi stopped working

Mon Mar 14, 2016 11:07 am

It's in the very latest firmware (sudo rpi-update) but may not have been built into a Raspbian update yet.

Return to “Troubleshooting”