geekman92
Posts: 14
Joined: Wed Sep 12, 2012 10:18 am

LIRC: mode2 continuously receiving pulses from TSOP85

Sun Oct 26, 2014 10:16 am

I have bought an IR Receiver board based on the TSOP85 from here: http://proto-pic.co.uk/ir-receiver-breakout/

I've connected the VCC to the 3.3V pin, the OUT to pin 15 (GPIO22) and GND to the ground pin.

I've install lirc, edited the /etc/modules file and that seems to be working properly, I have got an LED to flash with irsend and a remote config file I found online.

When I stop lirc and run mode2 -d /dev/lirc0 I get a continuous output of pulses and spaces like this:

Code: Select all

pulse 94779
space 438
pulse 299
space 586
pulse 27263
space 301
pulse 321931
space 220
pulse 8594
space 238
pulse 100533
space 453
pulse 119747
space 221
pulse 9710
space 252
pulse 59776
space 215
pulse 19717
space 213
pulse 49389
space 590
pulse 49708
space 269
pulse 29599
space 326
pulse 19410
space 665
I believe it is recognising a remote because when I press a button the continuous output speeds up. But lirc/iirecord doesn't work as it can't read the signal properly with all the other info cluttering it.

Am I missing something here? Is my circuit wrong? Do I need to put a pull-up resistor or something in there? Sorry for all the questions I'm not too good with all the electronic side of things.

Thanks in advance

csa2a
Posts: 2
Joined: Mon Oct 27, 2014 6:52 pm

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Mon Oct 27, 2014 6:56 pm

I have the same problem. but it's working if I have the network cable plugged in...I use the remote control for internet radio, and it's working only in wired net mode.
I have an unidentified IR receiver, from an old TV:)), the ground is pin2.
Any updates on this?

User avatar
joan
Posts: 14186
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Mon Oct 27, 2014 7:02 pm

The normal explanation will surely be stray light which happens to have the correct modulation.

Do the pulses stop if the sensor is covered by a light proof material?

csa2a
Posts: 2
Joined: Mon Oct 27, 2014 6:52 pm

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Tue Oct 28, 2014 9:03 pm

The sensor transmits continuously after approx 10 seconds after power-on, saw this on oscilloscope, even if covered.
The sensor is pullup, lirc recognizes it with active-low, it's OK.
Maybe it's not the best sensor... but what's the relation between sensor and network cable plugged in or not?

geekman92
Posts: 14
Joined: Wed Sep 12, 2012 10:18 am

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Wed Oct 29, 2014 12:09 am

That is odd as I have always had the network cable plugged in as I SSH and VNC into the pi to develop and have still seen continuous output. I didn't completely cover the receiver but I did cup my hands around it to see if that made a difference and it didn't. (I know not very scientific!!)

So if it is pull up that means it outputs HIGH when no IR light received and LOW when there is IR light, right? Is that the same as active low? Sorry I'm not very good at the whole electronic stuff!! :P

csa2a, did you manage to get LIRC and irrecord to properly configure your remote? Whenever I did it would seem to do something when I pressed buttons but also did stuff when I didn't press anything! :/

Thanks for your replies

bnjroos
Posts: 3
Joined: Tue Feb 16, 2016 7:10 am

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Tue Feb 16, 2016 7:33 am

I have exactly the same issue, any update on that matter ? the IR receiver is faulty maybe ?

thanks,

gauravsharma0190
Posts: 122
Joined: Tue Oct 28, 2014 6:36 am

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Wed Feb 24, 2016 6:17 am

sir
i have a problem whae i run the mode2 -d /dev/lirc0
it didn't show the pulse and space.
what is the problem.
please reply i am waiting.
my ir receiver is TSOP1838.
i did gpio 18 as in pin and remote is NEC protocol.

geekman92
Posts: 14
Joined: Wed Sep 12, 2012 10:18 am

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Wed Feb 24, 2016 11:09 am

I never got this to work, I gave up and just used a bluetooth keyboard/mouse combo instead. Maybe one day when I find some spare time I'll take another look but right now I have no fixes for the people... sorry!

istirbu
Posts: 1
Joined: Sun Sep 25, 2016 11:31 am

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Sun Sep 25, 2016 11:38 am

I have a receiver built using this guide http://lnx.manoweb.com/lirc/. Recently I got a wireless phone and I had it mounted right near the cable leading from the IR receiver. I did not make the connection initially, but after some moving around I figured out that the phone was creating the noise that was transformed in continuous output for mode2 tool. I moved the receiver farther from the phone and the noise disappeared. So the first thing, try to move away the receiver from any devices that use high frequency communication.

ddavy
Posts: 1
Joined: Sat Oct 15, 2016 7:02 pm

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Sat Oct 15, 2016 7:14 pm

Hi,

I'm having the same issue! When I run mode2 -d /dev/lirc0, I have a constant stream of pulse/space. I can fix this by covering the IR receiver (TSOP2238) for a few seconds. Sometimes I have to do this a few times before it works. It looks like LIRC needs to be 'calibrated' in order to work (It picks up stray light?). When the Raspberry Pi reboots, the same problem occurs again.
Any new insights on this?

Thanks in advance.

piBrikr
Posts: 1
Joined: Sat Oct 29, 2016 5:50 pm

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Sat Oct 29, 2016 6:07 pm

Had the same issues as previously described, using an IR circuit as mentioned in previous posts:
'mode2 -d /dev/lirc0' provided continuous garbage, and irw failed entirely.

Turned out that using (certain kinds of?) florescent lighting overloaded the IR receiver with continuous garbage.

Common desk lighting like http://www.made-in-china.com/showroom/j ... S600-.html within a meter from the receiver, when switched on, floods mode2 with garbage pulses and renders the ir receiver useless; once the light is switched off, mode2 shows clean input -- irw now sees the proper keys being pressed, and works fine.

So try moving your work area light source further away or switching florescent lighting off during testing.

tony359
Posts: 33
Joined: Mon Dec 21, 2015 9:59 pm
Location: Swindon, UK

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Mon Mar 26, 2018 5:22 pm

Hi
I'm digging this thread out as I have the same problem.

The difference is that if I aim the desk fluorencent light to the IR receives, the stream of garbage stops (well, not completely) and if I point a remote at it and press a button, I can see something happening on screen, but every time I press the SAME button I see different codes.

If I shield the thing, it keeps listing an endless list of garbage.

Any suggestions please?
Thanks

drgeoff
Posts: 9738
Joined: Wed Jan 25, 2012 6:39 pm

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Mon Mar 26, 2018 6:59 pm

The remote codes are not merely pulse trains turning the IR on and off. There is a carrier frequency of tens of kHz. The baseband codes turn that carrier on and off. It is that modulated carrier which turns the IR emitter on and off. The TSOP85 (and TSOP48) devices incorporate a demodulator and output the baseband code burst. That is why there are more digits on the part number. They specify the carrier frequency that the device is for.

https://www.sparkfun.com/datasheets/Sen ... sop853.pdf

The most common frequency used by remotes is 38 kHz. Unless you know that your remote uses other than 38 kHz, make sure you have a TSOP85338.

And it isn't only for cosmetic reasons that these sensors are invariably behind windows which have reduced transmission of non-IR light.

tony359
Posts: 33
Joined: Mon Dec 21, 2015 9:59 pm
Location: Swindon, UK

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Tue Mar 27, 2018 7:18 pm

Thanks,

I can shield the IR sensor but I am not sure it would work as I still see a stream of numbers with all the lights off and the Pi covered by a dark surface?

garrettd
Posts: 1
Joined: Sun May 12, 2019 6:20 pm

Re: LIRC: mode2 continuously receiving pulses from TSOP85

Sun May 12, 2019 6:29 pm

I just fought this for a while, and finally figured out an answer, which I felt compelled to create an account so I could share and hopefully help future LIRCers. It turns out that a noisy power supply for your pi can cause this sensor noise.

I have a Jacky Led power tower which has a pair of USB ports on it, which I'm using to power my pi. I was getting a continuous stream of noise making my reader useless. I turned off all my lights, closed the blinds, covered the reader in various opaque materials, and just couldn't get rid of the noise. I moved all nearby electronics away in case of other EM interference (which seemed unlikely, but other people mentioned it was possible). Running out of ideas, I had one last thing to try. One of the pair of USB ports I mentioned was powering my pi. The other had my phone plugged in to it. I unplugged my phone, cupped the sensor in my hand, and the noise disappeared! Remember when working with sensors this sensitive to interference: use a high quality power supply!

Return to “Troubleshooting”