rosignol
Posts: 4
Joined: Mon May 25, 2015 3:14 pm

Re: Howto: Disable Screen Saver In Raspbian

Sun May 31, 2015 3:17 pm

Thanks Jorgen I can see from other posts that nano would work too but as you will see from my updatad post I got there using the apt-get xscreensaver option
thanks for answering though
much appreciated
Rosignol

Krassegrand
Posts: 104
Joined: Sat Apr 25, 2015 3:20 pm
Location: Halmstad Sweden

Re: Howto: Disable Screen Saver In Raspbian

Sun May 31, 2015 3:58 pm

apt-get xscreensaver

That was new to me!

Thank You!

Jörgen

DerberMohikaner
Posts: 15
Joined: Wed Apr 10, 2013 6:05 am
Location: Germany, Düsseldorf
Contact: Website

Re: Howto: Disable Screen Saver In Raspbian

Thu Jul 23, 2015 6:48 am

That's it!
Thank you VERY, VERY much.
Perfect
Ben

User avatar
Fenhl
Posts: 5
Joined: Fri Nov 27, 2015 12:08 am
Location: Saarbrücken-Dudweiler, Germany
Contact: Website

Re: Howto: Disable Screen Saver In Raspbian

Fri Nov 27, 2015 12:38 am

I have tried following the instructions posted here to disable the text terminals (ctrl-alt-1 etc) from blanking after a few minutes, but they were ineffective. Has any of this changed with jessie? Does anyone know a working method?

klricks
Posts: 4875
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Howto: Disable Screen Saver In Raspbian

Sun Dec 13, 2015 12:49 am

Fenhl wrote:I have tried following the instructions posted here to disable the text terminals (ctrl-alt-1 etc) from blanking after a few minutes, but they were ineffective. Has any of this changed with jessie? Does anyone know a working method?
Try this: viewtopic.php?f=63&t=125863
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://blackeagle12.net/Comp/RPi/Rpi.html Click contact icon then world icon --->

User avatar
Fenhl
Posts: 5
Joined: Fri Nov 27, 2015 12:08 am
Location: Saarbrücken-Dudweiler, Germany
Contact: Website

Re: Howto: Disable Screen Saver In Raspbian

Sun Dec 13, 2015 7:50 pm

Thanks, but I already fixed it with help from the #raspbian IRC channel. The solution was to add the following to the zshrc:

Code: Select all

if [[ "$TERM" == "linux" ]]; then
    setterm --blank 0
fi

Bosse_B
Posts: 631
Joined: Thu Jan 30, 2014 9:53 am

Re: Howto: Disable Screen Saver In Raspbian

Sun Jan 17, 2016 11:03 am

I simply MUST get rid of this stupid screen blanking too. Is there no GUI window where such things can be configured?
I have Raspbian Jessie (Nov 2015) and it blanks the screen after a very short time.
In thus thread are so many different solutions and I get very confused...

What is the correct way to actually stop the blanking from happening on Raspbian Jessie????

What is zshrc as mentioned above? Surely there must be a path to it if it is a file?

Does xscreensaver work in Jessie? It was mentined here before Jessie was released...

The link above leads to a thread about the console, but I am talking about the GUI screen that gets black after a short time.

EDIT:
I installed the xscreensaver and then I found a new app in the Preferences submenu for the screensaver.
It has a selection for display mode on the first (left) tab where one can disable the screensaver altogether.
And it works in Jessie! All is now fine. :lol:
Bo Berglund
Sweden

rogerman
Posts: 3
Joined: Mon Jan 27, 2014 8:54 pm

Re: Howto: Disable Screen Saver In Raspbian

Thu Feb 04, 2016 1:02 pm

The only reliable way to totally disable screensaver that I have found is using xorg.conf.
This worked for me:

Code: Select all

sudo nano /etc/X11/xorg.conf
Add this section:

Code: Select all

Section "ServerFlags"
        Option          "BlankTime"     "0"
        Option          "StandbyTime"   "0"
        Option          "SuspendTime"   "0"
        Option          "OffTime"       "0"
EndSection
And also:

Code: Select all

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
Add to autostart this lines:

Code: Select all

@xset s noblank
@xset s off
@xset -dpms
Worked on X.Org X Server 1.12.4 version.

Hope this helps!

Gammon
Posts: 6
Joined: Thu Mar 17, 2016 11:39 pm

Re: Howto: Disable Screen Saver In Raspbian

Mon Apr 18, 2016 8:16 pm

rogerman wrote:The only reliable way to totally disable screensaver that I have found is using xorg.conf.
This worked for me:

Code: Select all

sudo nano /etc/X11/xorg.conf
Add this section:

Code: Select all

Section "ServerFlags"
        Option          "BlankTime"     "0"
        Option          "StandbyTime"   "0"
        Option          "SuspendTime"   "0"
        Option          "OffTime"       "0"
EndSection
And also:

Code: Select all

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
Add to autostart this lines:

Code: Select all

@xset s noblank
@xset s off
@xset -dpms
Worked on X.Org X Server 1.12.4 version.

Hope this helps!
Thanks! I've been having this same problem for a while. I had tried the autostart settings in all 3 locations (both /etc/xdg/xsession/ locations and ~./config/lxsession/LXDE-pi/) and it still wasn't working. Adding the xorg.conf file did the trick!

Alexandre34
Posts: 17
Joined: Sun Jan 31, 2016 6:18 am

Re: Howto: Disable Screen Saver In Raspbian

Wed Apr 20, 2016 1:18 pm

Just for info:
1) In my raspian jessie, the autostart file is in /home/pi/.config/lxsession/LXDE-pi
The files in /etc/xdg... seems to be obsolete..
I have add the following lines:

Code: Select all

@xset s noexpose
@xset s noblank
@xset s off
@xset -dpms
You can check if the settings have been done with this command:
xset q
2) xscreensaver works fine, but now put a big splash screen during a few seconds asking to update the version !

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: Howto: Disable Screen Saver In Raspbian

Wed Apr 20, 2016 1:21 pm

Here is how to turn off screen blanking, enable lock screen capability from keyboard shortcut, etc, using "light-locker":
viewtopic.php?p=961360#p961360


xscreensaver is garbage. Annoying popups, lockscreen broken (and doesn't use the debian/raspbian login), and the handful of screensavers that are selectable suck.

The author has also asked debian to remove it:
https://www.reddit.com/r/linux/comments ... remove_it/

Image

Image


Word from the author:
I stand by my words here: If you are considering removing this warning, then I ask that instead, you remove the XScreenSaver software from Debian entirely. I believe Gnome-Screensaver will be more to your liking anyway.



/* If you are in here because you're planning on disabling this warning
before redistributing my software, please don't.

I sincerely request that you do one of the following:

1: leave this code intact and this warning in place, -OR-

2: Remove xscreensaver from your distribution.

I would seriously prefer that you not distribute my software at all
than that you distribute one version and then never update it for
years.

I am *constantly* getting email from users reporting bugs that have
been fixed for literally years who have no idea that the software
they are running is years out of date. Yes, it would be great if we
lived in the ideal world where people checked that they were running
the latest release before they report a bug, but we don't. To most
people, "running the latest release" is synonymous with "running the
latest release that my distro packages for me."

When they even bother to tell me what version they're running, I
say, "That version is three years old!", and they say "But this is
the latest version my distro ships". Then I say, "your distro
sucks", and they say "but I don't know how to compile from source,
herp derp I eat paste", and *everybody* goes away unhappy.

It wastes an enormous amount of my time, and kind of makes me regret
ever having released this software in the first place.

So seriously. I ask that if you're planning on disabling this
obsolescence warning, that you instead just remove xscreensaver from
your distro entirely. Everybody will be happier that way. Check
out gnome-screensaver instead, I understand it's really nice.

Of course, my license allows you to ignore me and do whatever the
fuck you want, but as the author, I hope you will have the common
courtesy of complying with my request.

Thank you!

jwz, 2014
Source
DNPNWO

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: Howto: Disable Screen Saver In Raspbian

Mon May 02, 2016 11:32 am

I might be able to bring some clues to ditching screensaver or at at least saming it !

I had a poke around in /usr/bin/

I found a file called sleep and 'rm' it. A tad bold and it made no difference.

I am using the 18th March 2016 Rasbian and fully updated it and upgraded it.

but to no avail after 10 minutes the screen went off...

I tried 'deanbayley' 6th of march 2016 solution of

sudo /usr/bin/xset s off

sudo /usr/bin/xset -dpms

sudo /usr/bin/xset s noblank

but to no avail... now xset might be a hidden file ? I did not see it on my prowl of that directory..

Have I missed something ?

But what I did find was:-

xdg-screensaver and associated files

Now I don't have the skills needed to make sense of it...Is there anyway of contacting the Raspian team to give us the information to turn screensaver off ?

No Ubuntu have a 'System Settings' list and the second item in is a window which allows the user to make the adjustments to screensave on/off setting so it can be done.

Don't know if any of this makes sense...

:?:

Tim

CompanionConcierge
Posts: 2
Joined: Thu May 05, 2016 8:45 am
Contact: Website

Re: Howto: Disable Screen Saver In Raspbian

Thu May 05, 2016 8:50 am

Thanks this helped

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: Howto: Disable Screen Saver In Raspbian

Thu May 05, 2016 7:07 pm

Lets hope someone cracks this problem. Should be trivial but Unix always have been very awkward animal when it comes to this sometimes unwanted feature...
: ))

Tim

davenull
Posts: 1162
Joined: Thu Oct 22, 2015 7:22 am
Location: a small planet close to Betelgeuze

Re: Howto: Disable Screen Saver In Raspbian

Fri May 06, 2016 10:07 am

Is there anyway of contacting the Raspian team to give us the information to turn screensaver off ?
I'm also interested to disable the screen saver completely, once and forever.
But reading through this topic I don't understand anything about how to do it now - perhaps the solution is just obscured by too many words written here.
Now is there a final solution with reasonable effort for setting it up?
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;int main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PointOut(x,y);}}}for(;;);}

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: Howto: Disable Screen Saver In Raspbian

Fri May 06, 2016 4:05 pm

davenull wrote:
Is there anyway of contacting the Raspian team to give us the information to turn screensaver off ?
I'm also interested to disable the screen saver completely, once and forever.
But reading through this topic I don't understand anything about how to do it now - perhaps the solution is just obscured by too many words written here.
Now is there a final solution with reasonable effort for setting it up?

You just want it OFF? no darkening of screen (blanking) after 10 minutes (or custom time elapse)?, no powering off monitor?, no screen locking?

Then that It is easy (if you have previously installed anything like xscreensaver, or light-locker, remove it)

Then;

In Terminal

open:

Code: Select all

sudo nano ~/.config/lxsession/LXDE-pi/autostart
add:

Code: Select all

@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0
Select All (from above code), then right click 'copy', then in '/autostart', 'paste' so it looks like this:
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0

save with 'Ctrl' + 'x' key, then 'y', then 'enter'

then:

Code: Select all

sudo reboot

You will reboot and you are done. ;) No screensaver, no screen blanking, no monitor power saving mode.
Last edited by Rive on Sun May 08, 2016 1:15 pm, edited 6 times in total.
DNPNWO

davenull
Posts: 1162
Joined: Thu Oct 22, 2015 7:22 am
Location: a small planet close to Betelgeuze

Re: Howto: Disable Screen Saver In Raspbian

Fri May 06, 2016 4:24 pm

thank you, yes, I just intended the screen always to be visible, no black screen, no screen power save mode.
I followed your instructions just right now, and I'm observing wht's happening... ;)

edit:
30 min passed, everything is still on
Thanks again! :)
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;int main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PointOut(x,y);}}}for(;;);}

Bosse_B
Posts: 631
Joined: Thu Jan 30, 2014 9:53 am

Re: Howto: Disable Screen Saver In Raspbian

Sun May 08, 2016 7:25 am

Rive wrote: 'select all', then right click 'copy', then scroll to bottom with down arrow key, then 'paste'
I am assuming that by "select all" you mean in the code section of your post and not inside nano, right?
Anyway, doing so adds 4 spaces to the front of each line. This may or may not have detrimental effects.
If you instead just select the lines in the code section, then use Ctrl-C to copy and then paste into the nano window there are no extra spaces added.
Bo Berglund
Sweden

timmoore46
Posts: 266
Joined: Tue Jul 17, 2012 4:36 pm

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 10:28 am

I have tried out :-

sudo nano ~/.config/lxsession/LXDE-pi/autostart

etc

and wow ! Massive thanks to the member Rive that posted the fix !!

(Mega error ! Now corrected Huge appologies to Rive from me)

I like nano a lot, my preferred method to save is

CTRL/o to write the changes

and

CTRL/x to quit back to Bash prompt

Hero status to davenull who put forward this very elegant fix !

A very very happy,

:D :D :D :D

Tim
Last edited by timmoore46 on Fri May 13, 2016 12:16 pm, edited 1 time in total.

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 2:39 pm

timmoore46 wrote: Massive thanks to the member davenull that posted the fix !!
You must be super confused. It is very easy to confuse the quotes, and responses. FYI, "davenull" was requesting an 'easy to implement' fix, he didn't provide any fix ;)

Here is his original post:
davenull wrote: I'm also interested to disable the screen saver completely, once and forever.
But reading through this topic I don't understand anything about how to do it now - perhaps the solution is just obscured by too many words written here.
Now is there a final solution with reasonable effort for setting it up?
Last edited by Rive on Tue May 10, 2016 2:45 pm, edited 1 time in total.
DNPNWO

davenull
Posts: 1162
Joined: Thu Oct 22, 2015 7:22 am
Location: a small planet close to Betelgeuze

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 2:45 pm

davenull wrote:thank you, yes, I just intended the screen always to be visible, no black screen, no screen power save mode.
I followed your instructions just right now, and I'm observing wht's happening... ;)

edit:
30 min passed, everything is still on
Thanks again! :)
You must be super confused. It is very easy to confuse the quotes, and responses. FYI, "davenull" was requesting a fix, he didn't provide any fix ;)

Here is his original post:
davenull wrote: I'm also interested to disable the screen saver completely, once and forever.
But reading through this topic I don't understand anything about how to do it now - perhaps the solution is just obscured by too many words written here.
Now is there a final solution with reasonable effort for setting it up?

what fix?
viewtopic.php?f=91&t=57552&p=971373#p969057
it worked as it is!
Last edited by davenull on Tue May 10, 2016 2:47 pm, edited 1 time in total.
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;int main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PointOut(x,y);}}}for(;;);}

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 2:46 pm

This fix...
davenull wrote:I followed your instructions just right now...
In Terminal

open:

Code: Select all

sudo nano ~/.config/lxsession/LXDE-pi/autostart
add:

Code: Select all

@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0
Select All (from above code), then right click 'copy', then in '/autostart', 'paste' so it looks like this:
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0

save with 'Ctrl' + 'x' key, then 'y', then 'enter'

then:

Code: Select all

sudo reboot
Last edited by Rive on Tue May 10, 2016 2:48 pm, edited 1 time in total.
DNPNWO

davenull
Posts: 1162
Joined: Thu Oct 22, 2015 7:22 am
Location: a small planet close to Betelgeuze

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 2:48 pm

now I am super confused.
This was your post, and I followed it, and it worked.
viewtopic.php?f=91&t=57552&p=971373#p969057

Which fix am I missing?
Or do you mean "patch" ?
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;int main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PointOut(x,y);}}}for(;;);}

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 2:51 pm

davenull wrote:now I am super confused.
This was your post, and I followed it, and it worked.
viewtopic.php?f=91&t=57552&p=971373#p969057

Which fix am I missing?

Oh boy....

Another poster (quoted below for reference) thought that fix was provided by you, and was thanking you for providing it. I was informing him that he was confused and you were asking for a fix, not providing one.

Evidently the way this board does the quotes is very confusing.
timmoore46 wrote: Massive thanks to the member davenull that posted the fix !!
DNPNWO

davenull
Posts: 1162
Joined: Thu Oct 22, 2015 7:22 am
Location: a small planet close to Betelgeuze

Re: Howto: Disable Screen Saver In Raspbian

Tue May 10, 2016 2:57 pm

:idea: !
:geek:

+1
8-)
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;int main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PointOut(x,y);}}}for(;;);}

Return to “Beginners”

Who is online

Users browsing this forum: No registered users and 34 guests