Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Can see wireless networks but can't connect

Mon Nov 23, 2015 12:47 am

Raspbian Gnu/Linux 8\ n\ 1

- Fresh install of Raspbian.
- Boots to desktop just fine.
- I have used lsusb and ls mod to check that my wireless dongle is there, and it is.
- Ethernet works great.
- When I left click the networking icon in top right corner I see the list of wifi networks available
- I enter the pword for my network and hit OK button but nothing happens, no wireless connectivity.
- I have tried repeating this after unplugging ethernet and rebooting, still nothing.

What have I missed???

Edit: I should mention that I have used the wifi troubleshooting guide here as well as suggestions found throughout the forum but nothing seems to address this issue or resolve it.

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 10:55 am

Open an LXTerminal window.

What does ifconfig wlan0 show?
What does iwlist wlan0 scan show?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 1:56 pm

Hi Dougie.

ifconfig:

eth0 Link encap:Ethernet HWaddr b8:27:eb:f4:4a:d4
inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::19fe:734c:f78e:f50f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:68 errors:0 dropped:0 overruns:0 frame:0
TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6869 (6.7 KiB) TX bytes:13557 (13.2 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:140 errors:0 dropped:0 overruns:0 frame:0
TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11888 (11.6 KiB) TX bytes:11888 (11.6 KiB)

wlan0 Link encap:Ethernet HWaddr e8:4e:06:24:b2:1e
inet6 addr: fe80::ed7a:2625:15ef:95dc/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

iwlist wlan0 scan

wlan0 Scan completed :
Cell 01 - Address: 00:26:B8:EF:0E:18
ESSID:"TELUS0683"
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:144 Mb/s
Extra:wpa_ie=dd180050f20101000050f20401000050f20401000050f2020c00
IE: WPA Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra:rsn_ie=30140100000fac040100000fac040100000fac020c00
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD800050F204104A0001101044000102103B0001031047001059527B0451CFA87FD6A3A57E14936D0D1021000842726F6164636F6D1023000842726F6164636F6D1024000631323334353610420004313233341054000800060050F20400011011000A42726F6164636F6D415010080002200C103C0001011049000600372A000120
Quality=81/100 Signal level=56/100
Cell 02 - Address: 10:0D:7F:75:85:E0
ESSID:"casa phoebe_EXT"
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.437 GHz (Channel 6)
Encryption key:on
Bit Rates:144 Mb/s
Extra:wpa_ie=dd1c0050f20101000050f20202000050f2040050f20201000050f2020c00
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra:rsn_ie=30180100000fac020200000fac04000fac020100000fac020c00
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD7E0050F204104A00011010440001021041000100103B00010310470010E68B09FFBE3A46BE0D2F41240DFD91BF1021000D4E4554474541522C20496E632E10230008574E33303030525010240008574E3330303052501042000230311054000800060050F204000110110008574E333030305250100800020084103C000101
Quality=96/100 Signal level=49/100
Cell 03 - Address: C4:6E:1F:ED:23:C9
ESSID:"RAAAAAAAAAAAAAWR"
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.437 GHz (Channel 6)
Encryption key:on
Bit Rates:300 Mb/s
Extra:rsn_ie=30180100000fac020200000fac04000fac020100000fac020000
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD9B0050F204104A0001101044000101103B0001031047001000000000000010000000C46E1FED23C91021000754502D4C494E4B1023000A544C2D5744523433303010240003312E3010420003312E301054000800060050F20400011011001A576972656C65737320526F7574657220544C2D57445234333030100800020086103C000101104900140024E26002000101600000020001600100020001
Quality=91/100 Signal level=42/100
Cell 04 - Address: A8:39:44:5B:1D:10
ESSID:"TELUS2545"
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.462 GHz (Channel 11)
Encryption key:on
Bit Rates:144 Mb/s
Extra:wpa_ie=dd180050f20101000050f20401000050f20401000050f2020c00
IE: WPA Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra:rsn_ie=30140100000fac040100000fac040100000fac020c00
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD800050F204104A0001101044000102103B0001031047001041C1FCAE17C4AACC1D5051CC49BC2EC31021000842726F6164636F6D1023000842726F6164636F6D1024000631323334353610420004313233341054000800060050F20400011011000A42726F6164636F6D415010080002200C103C0001011049000600372A000120
Quality=80/100 Signal level=51/100
Cell 05 - Address: 8C:7F:3B:87:EC:37
ESSID:"casa phoebe"
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.437 GHz (Channel 6)
Encryption key:on
Bit Rates:144 Mb/s
Extra:wpa_ie=dd1c0050f20101000050f20202000050f2040050f20201000050f2020c00
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra:rsn_ie=30180100000fac020200000fac04000fac020100000fac020c00
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Quality=9/100 Signal level=23/100

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 2:05 pm

I assume one of those networks seen with the iwlist scan is your's.

Update /etc/wpa_supplicant/wpa_supplicant.conf with a network={} block for your network.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
        ssid="RAAAAAAAAAAAAAWR"
        psk="superSecretPasswordforRAAAAAAAAAAAAAWR"
}
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 3:07 pm

Yes one of those is mine. As I said originally I can see the list of available networks, including mine, from the desktop. But when I plug in my key and hit OK nothing happens. And I've also tried setting this up in the conf file too and still nothing.

Aydan
Posts: 704
Joined: Fri Apr 13, 2012 11:48 am
Location: Germany, near Lake Constance

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 3:19 pm

Chur Chontime wrote:Yes one of those is mine. As I said originally I can see the list of available networks, including mine, from the desktop. But when I plug in my key and hit OK nothing happens. And I've also tried setting this up in the conf file too and still nothing.
Did you try with ethernet disconnected?

Regards
Aydan

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 3:22 pm

Hi Aylan.

Yes I tried rebooting with the ethernet disconnected as well after reading that in some cases they won't work together.

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 3:55 pm

Have you tried updating the supplicant file using sudo nano in an LXterminal window and not with the stupid brain-dead GUI?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 4:11 pm

Heh. Yes I both updated and upgraded.

So I take it nothing obvious is jumping out as a potential cause of this issue? Maybe I should start from scratch? Or still some leads to run down?

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 4:16 pm

The other thing that stops WiFi working is a lousy power supply or lousy USB-A to microUSB cable. Are you getting the rainbow square in the top right of the display?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 4:41 pm

Hmm. You mean in the top right corner of the GUI? Nope nothing like that. Just the networks status icon, volume, CPU usage, clock and eject button.

EDIT: Did the reading and know now that the rainbow square is the under voltage warning in the terminal screen. Answer is still nope. Nothing like that visible.

Aydan
Posts: 704
Joined: Fri Apr 13, 2012 11:48 am
Location: Germany, near Lake Constance

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 8:07 pm

Chur Chontime wrote:Hmm. You mean in the top right corner of the GUI? Nope nothing like that. Just the networks status icon, volume, CPU usage, clock and eject button.

EDIT: Did the reading and know now that the rainbow square is the under voltage warning in the terminal screen. Answer is still nope. Nothing like that visible.
What type of Raspberry do you have? the "original" Type A & B don't show the undervoltage warning, only A+, B+ and 2B.

Regards
Aydan

stderr
Posts: 2178
Joined: Sat Dec 01, 2012 11:29 pm

Re: Can see wireless networks but can't connect

Mon Nov 23, 2015 9:17 pm

Chur Chontime wrote:Yes one of those is mine. As I said originally I can see the list of available networks, including mine, from the desktop. But when I plug in my key and hit OK nothing happens. And I've also tried setting this up in the conf file too and still nothing.
If there is something available that isn't secure on log in like "Xfinitiywifi", or another commercial effort that you can just test the log into, I'd try that directly without using wpa_supplicant as a test. Always break problems down to smaller pieces so you can clear them and see where the real trouble is. You could spend forever if you don't do that.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Tue Nov 24, 2015 1:39 am

Aydan: It is the B+.

Going to see if I can connect to insecure networks now. There is one that appears from time to time around here.

Aydan
Posts: 704
Joined: Fri Apr 13, 2012 11:48 am
Location: Germany, near Lake Constance

Re: Can see wireless networks but can't connect

Tue Nov 24, 2015 9:51 am

If you have an android phone you can try this as hotspot as well. Maybe your router is doing something strange that the raspberry cannot cope with.

Regards
Aydan

drgeoff
Posts: 9933
Joined: Wed Jan 25, 2012 6:39 pm

Re: Can see wireless networks but can't connect

Tue Nov 24, 2015 6:59 pm

Chur Chontime wrote:Aydan: It is the B+.

Going to see if I can connect to insecure networks now. There is one that appears from time to time around here.
Or temporarily turn off the security on yours.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Thu Nov 26, 2015 12:21 am

OK so as it turns out I CAN connect to the insecure wifi network. But I've checked the password for mine a dozen times, tried it 20 times and it still won't connect.

DarrenHill
Posts: 235
Joined: Fri Oct 03, 2014 3:03 pm

Re: Can see wireless networks but can't connect

Thu Nov 26, 2015 10:44 am

Have you got MAC address filtering or anything like that enabled on your router but without the Pi's MAC address inserted in the tables?

Also as a test, type the password into the SSID, user name or similar box (without pressing enter) so it appears in plain text, to confirm that under the conditions when you're entering the password that you're entering what you think you are (that there's no issue with keyboard layout/mapping for example). Or temporarily reset your wifi password to something simple (e.g. "87654321") and see if you can log in using that. If so then reset it back and try again using the check above, as you're maybe not entering the password that you think you are.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Sat Nov 28, 2015 7:56 pm

Hi.

I have the Pi plugged into ethernet now but I have no internet connection. I had at one point been able to connect to internet with ethernet so not sure what happened there.

The Pi appears in the list of devices connected to the router and is not blocked.

I tried your suggestion with SSID but still no success.

EDIT: I'm downloading another copy of Raspbian in preparation for possibly reinstalling from scratch. It's looking like it might take 4-6 hours. This is about how long it took last time too. Is the download always very slow?

stderr
Posts: 2178
Joined: Sat Dec 01, 2012 11:29 pm

Re: Can see wireless networks but can't connect

Sat Nov 28, 2015 10:11 pm

Chur Chontime wrote:I have the Pi plugged into ethernet now but I have no internet connection. I had at one point been able to connect to internet with ethernet so not sure what happened there.
If you plug in wifi and unplug wifi or do that with ethernet cables, the system will try to figure out how to connect to the internet behind your back, unless you've removed that crap. This will often be wrong when there is more than one interface. You need to look at your route, at /etc/resolv.conf and perhaps other places. Start at the base, can you ping the localhost? Can you ping the router? Can you ping google with an ip such as 8.8.8.8? Can you ping it with a name, www.google.com?
EDIT: I'm downloading another copy of Raspbian in preparation for possibly reinstalling from scratch. It's looking like it might take 4-6 hours. This is about how long it took last time too. Is the download always very slow?
If you have the current release and you've checked that it is correct and not somehow corrupt, downloading it again doesn't serve any purpose. When you test the wireless, you can do so interactively. This will give you live information about what the heck is going on.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Sat Nov 28, 2015 10:46 pm

Running with just ethernet connected and wifi dongle removed:

I can ping the router from the Pi.

I ca ping the Pi from my iPad and laptop.

I have internet access from both laptop and iPad.

Still no internet connection to the Pi.

Pinging outside Ips and www.google.com from the Pi results in all packets lost.

wwwgizy
Posts: 46
Joined: Tue Sep 08, 2015 1:12 am

Re: Can see wireless networks but can't connect

Sat Nov 28, 2015 10:57 pm

Would it work if it was wired

stderr
Posts: 2178
Joined: Sat Dec 01, 2012 11:29 pm

Re: Can see wireless networks but can't connect

Sat Nov 28, 2015 11:01 pm

Chur Chontime wrote:Still no internet connection to the Pi.
Pinging outside Ips and http://www.google.com from the Pi results in all packets lost.
If you try to ping 8.8.8.8 and you get nothing, does it have to be the default route set wrong? Maybe something else is possible, but I don't recall you've posted sudo route yet.

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Sat Nov 28, 2015 11:25 pm

It is connected to the router via cable right now.

I tried pinging 8.8.8.8 with all packets lost. Sorry forgot to mention that.

What is sudo route? When I use that command I get NIL as result.

EDIT: Did route -n . Is that what you meant? Results:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 202 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

Chur Chontime
Posts: 29
Joined: Wed Mar 04, 2015 2:44 am

Re: Can see wireless networks but can't connect

Mon Nov 30, 2015 5:02 pm

Morning! Anyone got any troubleshooting steps I can take or anything?

Return to “Troubleshooting”