User avatar
Posts: 177
Joined: Fri Feb 24, 2012 4:40 pm

Fedora 22 on Pi2B (some success!)

Fri Sep 11, 2015 8:43 am

I had a run through Jon Archer's instructions [0] to try and get the F22 Arm Workstation image working.
The instructions basically grab the image, then replace the boot partition with RPi boot, and put the v7
modules in the correct place.

I boots (woohoo) all the way to the graphical interface, but the mouse and keyboard don't work (boohoo).
Some people have fixed this by adding a static ip address, and running rpi-update via ssh. However, this
seems like a cop out to me, as rpi-update basically copies the built kernel and modules from github,
which has already been done.

Does anyone have any ideas how to either (1) debug this or (2) fix it without using rpi-update

Things I have thought of that might be an issue:

The instructions set up the v7 modules, but there is no kernel line in config.txt - does that mean it boots the v6 kernel?

rpi-update runs a depmod after putting the modules in place - is this the missing step? If so, is there any way to
perform a depmod for an arm target on an x86-64 host?

Of course, having tried to blame the modules here, there is nothing really concrete to point in that direction.

Any ideas?

[0] ... erry-pi-2/

User avatar
Posts: 177
Joined: Fri Feb 24, 2012 4:40 pm

Re: Fedora 22 on Pi2B (some success!)

Thu Sep 17, 2015 6:43 pm

After a series of failed attempts, I have managed to get a usable image. The approach is still the same, and I have written a (very scary) script to hack a clean Fedora image on an sdcard. I will github it up once I have cleaned it out a bit.
So far, I have only successfully got the XFCE image running. I will try the workstation one again to see if I have sorted all the issues.

Return to “Pidora / Fedora”