FerociousRPi
Posts: 7
Joined: Tue Jun 30, 2015 10:14 pm

Raspbian GUI login prompt?

Tue Jun 30, 2015 10:18 pm

Hello all,

Is there any way to get Raspbian GUI login prompt/window? Needing something similar to screenshot.
https://ubuntu-mate.org/gallery/Screens ... IGHTDM.png

Thx

klricks
Posts: 6609
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Raspbian GUI login prompt?

Wed Jul 01, 2015 1:09 pm

  • 1. First if not already done, you must use sudo raspi-config and set boot to desktop then reboot.

    2. Open a LXterminal then do:
    sudo leafpad /etc/lightdm/lightdm.conf

    3. Find this line: (approximately line 78 in file)
    autologin-user=pi

    4. Comment out (disable) that line by inserting a # like this:
    #autologin-user=pi

    5. Save and exit then reboot.
Note: If you ever go back and do set to desktop with raspi-config again, (Step 1), then the changes to lightdm.conf will revert back to the default (no login). If so simply redo the edit again - (Steps 2-5).
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

FerociousRPi
Posts: 7
Joined: Tue Jun 30, 2015 10:14 pm

Re: Raspbian GUI login prompt?

Wed Jul 01, 2015 8:50 pm

Thank you so much! This worked (see screenshot) and also added a new user account w/o sudo.
https://www.raspberrypi.org/documentati ... e/users.md

1.- Is there a way to set the default environment to Xsession only option? (see screenshot)
2.- Also on the screenshot is there a way to change the missing icon pic above the word raspberrypi? (see screenshot)
3.- Was wondering if there is any way to restrict what programs users have access too?

Thanks
Attachments
RPi2_Login.jpg
RPi2_Login.jpg (44.64 KiB) Viewed 4659 times

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: Raspbian GUI login prompt?

Wed Jul 01, 2015 9:04 pm

FerociousRPi wrote:2.- Also on the screenshot is there a way to change the missing icon pic above the word raspberrypi? (see screenshot)
See my post in this thread.

haridsv
Posts: 11
Joined: Sat Sep 05, 2015 8:48 am

Re: Raspbian GUI login prompt?

Tue Sep 15, 2015 2:37 pm

klricks wrote:
  • 1. First if not already done, you must use sudo raspi-config and set boot to desktop then reboot.

    2. Open a LXterminal then do:
    sudo leafpad /etc/lightdm/lightdm.conf

    3. Find this line: (approximately line 78 in file)
    autologin-user=pi

    4. Comment out (disable) that line by inserting a # like this:
    #autologin-user=pi

    5. Save and exit then reboot.
Note: If you ever go back and do set to desktop with raspi-config again, (Step 1), then the changes to lightdm.conf will revert back to the default (no login). If so simply redo the edit again - (Steps 2-5).
Thank you so much! For some reason, I had to search for a quite a few keywords before finding this simple solution.

Return to “Raspbian”