tr01
Posts: 10
Joined: Sat Jan 17, 2015 6:42 pm

I²C funtioniert nicht

Thu Jul 23, 2015 3:43 pm

Hallo,

ich will das Internetradio aus dem MagPi vom Juli 2015 nachbauen, habe aber ein Problem.

Ich habe I²C über

Code: Select all

sudo raspi-config
aktiviert. Wenn ich nun

Code: Select all

sudo i2cdetect -y 1
ausführe, bekomme ich folgenden Fehler:

Code: Select all

Error: Could not open file `/dev/i2c-1' or `/dev/i2c/1': No such file or directory
Woran liegt das und was kann ich dagegen tun?

User avatar
mline
Posts: 1417
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: I²C funtioniert nicht

Thu Jul 23, 2015 3:56 pm

Du musst noch das Modul "i2c-dev" laden.

Code: Select all

sudo modprobe i2c-dev
Kannst es auch in die Datei /etc/modules eintragen dann wird es schon beim Systemstart geladen. Dann nur folgendes am Ende der Datei reinschreiben:

Code: Select all

i2c-dev
<~~>

User avatar
KnightOfPi
Posts: 50
Joined: Sun Dec 28, 2014 12:57 pm
Location: Vienna - Austria
Contact: Website

Re: I²C funtioniert nicht

Tue Aug 18, 2015 11:34 am

Ich hatte auch Probleme mit der Einrichtung von I2C ueber raspi-config.

Probiere mal

Code: Select all

sudo apt-get install python-smbus
sudo apt-get install i2c-tools
sudo nano /etc/modules
Fuege am Ende der Datei ein

Code: Select all

i2c-bcm2708 
i2c-dev
Speichern und dann

Code: Select all

sudo nano /boot/config.txt
Aendere

Code: Select all

dtparam=i2c_arm=off
zu

Code: Select all

dtparam=i2c_arm=on
und ergaenze um

Code: Select all

dtparam=ic21=on
Check out www.knight-of-pi.org for many beginner-friendly tutorials!

Return to “Deutsch”