deltados
Posts: 1
Joined: Thu Jul 09, 2015 3:08 pm

Duda con la red y el DUC de no-ip en Raspbian

Thu Jul 09, 2015 8:08 pm

Hola a tod@s, adquirí recientemente una Raspberry Pi B+ y configurándola por primera vez me he encontrado con un problemilla que no se solucionarlo, a ver si me podéis ayudar, os pongo en situación.

Quiero instalarle el tightvncserver y el DUC de no-ip.org para poder acceder remotamente desde cualquier parte, no solo desde la red local.

Al activar la interfaz gráfica el icono de conexión de red me muestra que tengo la ip 192.168.1.33, pero yo he configurado una ip estática, la 192.168.1.54.

Esta es la configuración:

Code: Select all

auto lo
iface lo inet loopback

iface eth0 inet static

address 192.168.1.54
gateway 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
Las dos IPs me responden a pings desde otro ordenador de la red local.

Al instalar el DUC de no-ip.org (make install) me reporta lo siguiente:
if [ ! -d /usr/local/bin ]; then mkdir -p /usr/local/bin;fi
if [ ! -d /usr/local/etc ]; then mkdir -p /usr/local/etc;fi
cp noip2 /usr/local/bin/noip2
/usr/local/bin/noip2 -C -c /tmp/no-ip2.conf

Auto configuration for Linux client of no-ip.com.

Multiple network devices have been detected.

Please select the Internet interface from this list.

By typing the number associated with it.
0 eth0
1 eth0
Me pide que seleccione una de las dos interfaces de internet, entiendo que es por lo que he comentado antes, que tiene dos ip locales. Lo primero es que no se diferenciarlas y lo segundo es que creo que no es correcto, que deveria tener una única IP.

¿Por que ocurre esto y como puedo solucionarlo?

Muchas gracias de antemano, espero haberme explicado mas o menos bien.

Cefiro
Posts: 129
Joined: Tue Feb 26, 2013 4:14 pm

Re: Duda con la red y el DUC de no-ip en Raspbian

Sat Jul 11, 2015 2:06 pm

deltados wrote:Al activar la interfaz gráfica el icono de conexión de red me muestra que tengo la ip 192.168.1.33, pero yo he configurado una ip estática, la 192.168.1.54.
Si te conectas por cable, quita wlan0 y wlan1 (¿tienes dos tarjetas inalámbricas?) del fichero de configuración de red y mira a ver si te coge bien la IP estática de eth0.
Al instalar el DUC de no-ip.org (make install) me reporta lo siguiente:

Multiple network devices have been detected.

Please select the Internet interface from this list.

By typing the number associated with it.
0 eth0
1 eth0

Me pide que seleccione una de las dos interfaces de internet, entiendo que es por lo que he comentado antes, que tiene dos ip locales. Lo primero es que no se diferenciarlas y lo segundo es que creo que no es correcto, que deveria tener una única IP.
Sí, yo reinstalé ayer mismo Raspbian y al configurar no-ip me aparecían también esas dos interfaces de red eth0 (0 y 1). Elegí la primera (la 0) y funciona bien. Yo lo interpreté como un error del sistema en la última versión de Raspbian que hay ahora mismo disponible (que, por algún extraño motivo, muestra dos interfaces eth0 cuando sólo hay una), ya que con las anteriores versiones nunca me había pasado eso.

Saludos.
-----------
Mi web sobre la RasPi: http://rpi.uroboros.es

Return to “Español”