bigs
Posts: 50
Joined: Tue Feb 25, 2014 8:59 am

Problema (forse) in avvio del raspy 2

Mon Jun 08, 2015 9:57 pm

Buonasera a tutti ragazzi,
sono un felicissimo possessore di raspberry 2 e ho notato una cosa strana... stamattina ho spento il raspberry per riaccenderlo stasera al mio rientro a casa. Dopo averlo riacceso ho aperto amulegui per controllare lo stato dei download e noto che l'elenco dei file in download è vuoto. Controllando la cartella "Temp" trovo però tutti i file che stavo scaricando... Dopo un po' di test ho capito che il problema è dovuto al fatto che la cartella "Temp" è presente sull'hdd usb collegata al raspy. Credo che amule parta prima che il disco sia visto dal raspy e quindi l'elenco dei download rimane vuoto... Stoppando infatti il servizio e facendolo ripartire tutti i file in download riappaiono. A qualcun altro è successo lo stesso problema? A parte amule ho altri programmi che partono all'avvio che inciampano in questo problema... Grazie per l'aiuto.

bigs
Posts: 50
Joined: Tue Feb 25, 2014 8:59 am

Re: Problema (forse) in avvio del raspy 2

Wed Jun 10, 2015 6:37 pm

Secondo voi potrebbe dipendere dal fatto che accendo entrambi i dispositivi contemporaneamente? Magari il raspy si avvia prima dell'hdd? Entrambi sono collegati alla stessa presa quindi gli arriva la corrente contemporaneamente...

Grazie

User avatar
m3nhir
Posts: 117
Joined: Sat Mar 21, 2015 11:53 am

Re: Problema (forse) in avvio del raspy 2

Sun Jun 14, 2015 3:48 pm

per ovviare potresti creare uno script che fai partire all'avvio del raspi, ma nel quale inserisci un lasso di tempo di attesa prima di effetture l'avvio dei programmi che usano anche l'HDD esterno. cosi lascerai il tempo al raspi di vedere l'hd ed ai programmi di poterne usufruire correttamente

bigs
Posts: 50
Joined: Tue Feb 25, 2014 8:59 am

Re: Problema (forse) in avvio del raspy 2

Fri Jun 19, 2015 9:58 pm

Ti ringrazio per la dritta. Non sono molto esperto nel creare script... cercando su internet ho trovato il comando per ritardare l'esecuzione di un programma e ho inserito nel "crontab" questo codice:

Code: Select all

sleep 30 ; /usr/bin/amuled
Il comando però non ha funzionato. Mi riusciresti a dare una mano?
Grazie :)

troombatzia
Posts: 501
Joined: Fri Jun 29, 2012 4:27 pm

Re: Problema (forse) in avvio del raspy 2

Sat Jun 20, 2015 4:23 pm

bigs wrote:Ti ringrazio per la dritta. Non sono molto esperto nel creare script... cercando su internet ho trovato il comando per ritardare l'esecuzione di un programma e ho inserito nel "crontab" questo codice:

Code: Select all

sleep 30 ; /usr/bin/amuled
Il comando però non ha funzionato. Mi riusciresti a dare una mano?
Grazie :)
Non risolve perché probabilmente amuled è già partito come servizio all'avvio. Per fare le cose pulite bisognerebbe togliere il servizio dal boot, ma per ora tralasciamo.

Cancella la linea che hai messo in crontab.

Ipotizziamo che il tuo hard disk sia /dev/sda1.

Modifica il file /etc/rc.local. Prima di "exit 0", aggiungi:

Code: Select all

while ! (mount | grep -wq /dev/sda1) ; do
   
   sleep 1

done

sleep 3
sudo service amule-daemon restart
Riavvia per verificare che vada bene.

Spiegazione: queste poche righe controllano ogni secondo che l'hard disk /dev/sda1 sia montato e riconosciuto. Poi dà altri 3 secondi per sicurezza prima di far ripartire il servizio amule. Cambia /dev/sda1 con il tuo hard disk o con la directory dove è montato.

Nota: io non ho amule e quindi non posso verificare il nome esatto del servizio amule. In rete ho letto amule-daemon, vedi tu.
English isn’t my first language, so please excuse any mistakes.

bigs
Posts: 50
Joined: Tue Feb 25, 2014 8:59 am

Re: Problema (forse) in avvio del raspy 2

Sat Jun 20, 2015 5:37 pm

Grazie mille per l'aiuto :-)
Provo e ti faccio sapere!
Buona serata

troombatzia
Posts: 501
Joined: Fri Jun 29, 2012 4:27 pm

Re: Problema (forse) in avvio del raspy 2

Sat Jun 20, 2015 8:24 pm

P.S. puoi togliere sudo dall'ultima riga e lasciare solo:

service amule-daemon restart

rc.local viene eseguito da root, quindi non c'è bisogno di sudare ;-)
English isn’t my first language, so please excuse any mistakes.

bigs
Posts: 50
Joined: Tue Feb 25, 2014 8:59 am

Re: Problema (forse) in avvio del raspy 2

Fri Jun 26, 2015 7:58 pm

Grazie infinite ragazzi!!! Mi avete risolto una gran seccatura che avevo tutte le volte che riavviavo il raspy! :-)
Siete fantastici! Scusate il ritardo ma purtroppo in settimana non sono riuscito a provare quanto mi avete suggerito...

Return to “Italiano”