loudhush
Posts: 4
Joined: Sat Dec 13, 2014 5:31 am

Remote Connecting to Windows 10 IoT

Sat May 16, 2015 6:22 am

I can't seem to remote connect to my Raspberry PI2. I have Windows 10 installed on the PI2 so I can read the machines IP address and current time etc.

As I understand it, the next step is to remote into Windows 10 with PowerShell in Administrator mode.
I'm trying to follow this guide
http://ms-iot.github.io/content/win10/s ... rShell.htm

Unfortunately when run this step

Code: Select all

 Set-Item WSMan:\localhost\Client\TrustedHosts -Value 192.168.100.104
I get the error

Code: Select all

Set-Item : Access is denied.
At line:1 char:11
+   Set-Item <<<<  WSMan:\localhost\Client\TrustedHosts -Value 192.168.100.104
    + CategoryInfo          : NotSpecified: (:) [Set-Item], InvalidOperationException
    + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.PowerShell.Commands.SetItemCommand
I'm quite stumped by this....I have googled and blindly followed a few suggestions I found with no success.

Do you have any suggestions for me to try?

SoggyB
Posts: 6
Joined: Wed Oct 08, 2014 2:10 pm

Re: Remote Connecting to Windows 10 IoT

Sat May 16, 2015 3:51 pm

.. I have this same issue :/

loudhush
Posts: 4
Joined: Sat Dec 13, 2014 5:31 am

Re: Remote Connecting to Windows 10 IoT

Sat May 16, 2015 11:30 pm

OK I solved my issue.

I did not have a password on my main machine.

I added a password, and all is good! :) Hope this helps someone else.

SoggyB
Posts: 6
Joined: Wed Oct 08, 2014 2:10 pm

Re: Remote Connecting to Windows 10 IoT

Sun May 17, 2015 12:17 am

Sorry, can you elaborate? Did you add a password to the powershell command?

loudhush
Posts: 4
Joined: Sat Dec 13, 2014 5:31 am

Re: Remote Connecting to Windows 10 IoT

Sun May 17, 2015 2:52 am

The user account for the Windows 7 box did not have a password.

So I had to press Ctrl + Alt + Delete
Click on "Change Password"
Typed a password in twice

Then went back to PowerShell and everything just worked.

Let me know if this helped you out.

SoggyB
Posts: 6
Joined: Wed Oct 08, 2014 2:10 pm

Re: Remote Connecting to Windows 10 IoT

Sun May 17, 2015 1:20 pm

Nope, I already had a password for the account on my desktop. I tried rebooting, and locking/unlocking. No luck. This is a Win 7 desktop though :/

loudhush
Posts: 4
Joined: Sat Dec 13, 2014 5:31 am

Re: Remote Connecting to Windows 10 IoT

Sun May 17, 2015 3:19 pm

Darn sorry man, I don't have any other suggestions.

I posted my problem to a group of friends, I had one person say they had the same issue but their problem was they needed to reference the Raspberry PI by IP address instead of machine name.

Other than that I have nothing for you. Good luck.

SoggyB
Posts: 6
Joined: Wed Oct 08, 2014 2:10 pm

Re: Remote Connecting to Windows 10 IoT

Sun May 17, 2015 3:50 pm

Ok... turned UAC off, rebooted. Now it works.

Thanks for your help.

SoggyB
Posts: 6
Joined: Wed Oct 08, 2014 2:10 pm

Re: Remote Connecting to Windows 10 IoT

Mon May 18, 2015 3:29 pm

... don't forget to turn UAC back on ;)

Ken76
Posts: 25
Joined: Fri Oct 21, 2016 8:01 am

Re: Remote Connecting to Windows 10 IoT

Fri Oct 21, 2016 8:28 am

I can't connect to my Windows 10 IOT Rasbperry Pi 3 with the Powershell (Administrator Mode).
I have tried with theese lines

Code: Select all

net start WinRM
Set-Item WSMan:\localhost\Client\TrustedHosts -Value 192.168.1.6
I don't even get any kind of error messages. And I have also the UAC disabled.
Can someone help me?

leonardo.daga
Posts: 13
Joined: Fri Jul 15, 2016 10:24 am

Re: Remote Connecting to Windows 10 IoT

Thu Oct 27, 2016 7:22 am

And then you used this command, right?

Code: Select all

Enter-PSSession -ComputerName 192.168.1.6 -Credential 192.168.1.6/Administrator

Return to “Windows 10 for IoT”