User avatar
cosmo
Posts: 51
Joined: Mon Nov 19, 2012 8:36 pm

Raspberry Pi 2 doesn't boot, original Model B does (solved)

Mon Mar 09, 2015 2:51 pm

I have a new Raspberry Pi 2 which I cn't get to work. I get no activity on the startup LEDs (Only the red light is lit, no blinking green light).

I tried using the same SD card/power supply with one of my older model B, and everything works properly. I tried with 2 different power supplies, with the same result with both of them. I only have one Micro SD card to try this on, so I can't verify that it is the card or not. I loaded the latest OpenElec distribution and that boots up properly with the older model, but all I get with the new computer is the rainbow screen.

Is there anything different about the newer model that would prevent it from working with a card and components that work on the older model (I also have a WiFi adapter and an adapter for a wireless mouse connected, and both work with the older model)? Is there a way to determine if I have a bad computer or if there is something else I can try?

fruitoftheloom
Posts: 22091
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Raspberry Pi 2 doesn't boot, original Model B does

Mon Mar 09, 2015 2:55 pm

cosmo wrote:I have a new Raspberry Pi 2 which I cn't get to work. I get no activity on the startup LEDs (Only the red light is lit, no blinking green light).

I tried using the same SD card/power supply with one of my older model B, and everything works properly. I tried with 2 different power supplies, with the same result with both of them. I only have one Micro SD card to try this on, so I can't verify that it is the card or not. I loaded the latest OpenElec distribution and that boots up properly with the older model, but all I get with the new computer is the rainbow screen.

Is there anything different about the newer model that would prevent it from working with a card and components that work on the older model (I also have a WiFi adapter and an adapter for a wireless mouse connected, and both work with the older model)? Is there a way to determine if I have a bad computer or if there is something else I can try?
OpenElec have different version for the RPi2 B http://openelec.tv/get-openelec
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

User avatar
cosmo
Posts: 51
Joined: Mon Nov 19, 2012 8:36 pm

Re: Raspberry Pi 2 doesn't boot, original Model B does

Mon Mar 09, 2015 3:29 pm

fruitoftheloom wrote:
cosmo wrote:I have a new Raspberry Pi 2 which I cn't get to work. I get no activity on the startup LEDs (Only the red light is lit, no blinking green light).

I tried using the same SD card/power supply with one of my older model B, and everything works properly. I tried with 2 different power supplies, with the same result with both of them. I only have one Micro SD card to try this on, so I can't verify that it is the card or not. I loaded the latest OpenElec distribution and that boots up properly with the older model, but all I get with the new computer is the rainbow screen.

Is there anything different about the newer model that would prevent it from working with a card and components that work on the older model (I also have a WiFi adapter and an adapter for a wireless mouse connected, and both work with the older model)? Is there a way to determine if I have a bad computer or if there is something else I can try?
OpenElec have different version for the RPi2 B http://openelec.tv/get-openelec
Ok, thanks. I was hoping it was something simple like this. I had downloaded the latest from this site (http://www.raspberrypi.org/downloads/), didn't realize there was a different download for the multiprocessor model. I'll test this out when I get a chance.

Haven't had a chance to try out Raspbian or any other os just yet. Are there different versions of the other systems for the multiprocessor model as well?

Thanks again! Much appreciated.

DirkS
Posts: 10220
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Raspberry Pi 2 doesn't boot, original Model B does

Mon Mar 09, 2015 3:35 pm

cosmo wrote:Haven't had a chance to try out Raspbian or any other os just yet. Are there different versions of the other systems for the multiprocessor model as well?
If you click on one of the 'more info' links on the downloads page Pi1 / Pi2 compatibility information should show up.
Last time I looked only Raspbian and Snappy downloads were Pi2B compatible.

fruitoftheloom
Posts: 22091
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Raspberry Pi 2 doesn't boot, original Model B does

Mon Mar 09, 2015 3:55 pm

cosmo wrote:Haven't had a chance to try out Raspbian or any other os just yet. Are there different versions of the other systems for the multiprocessor model as well?
Raspbian latest version is suitable for all versions of the RPi

Raspbmc has been obsoleted and replaced by OSMC, though different versions for RPi1 & 2 https://osmc.tv/download/images

Arch Linux Arm also have different versions for RPi1 & 2
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

User avatar
cherokee
Posts: 2
Joined: Tue Mar 10, 2015 12:34 pm

Re: Raspberry Pi 2 doesn't boot, original Model B does

Tue Mar 10, 2015 12:50 pm

Although they claim the Pi2 to be "completely compatible" with the Pi1, I've found that a card installed on the Pi1 will not boot the Pi2 but just produce the "rainbow screen". I haven't tried it v.v. yet, but my guess is that it'll be the same, as at least parts of the SoC most likely need to be adressed differently.
So just try and copy NOOBS (or whatever else) onto a new micro sd card (or clear your current one) and go through the installation process on your Pi2 and you should be ok.
RPi B+ / RPi 2 // Raspbian / OpenElec / Retropie // DSL 40.7 Mbit/s

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12672
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Raspberry Pi 2 doesn't boot, original Model B does

Tue Mar 10, 2015 6:36 pm

You need a new compatible kernel, and it will work on both systems, You can do an upgrade for that, info at multiple places:
http://www.raspberrypi.org/forums/viewt ... 46#p695146

and

http://www.raspberrypi.org/forums/viewt ... 28&t=58151

Read the stickies!

User avatar
cherokee
Posts: 2
Joined: Tue Mar 10, 2015 12:34 pm

Re: Raspberry Pi 2 doesn't boot, original Model B does

Wed Mar 11, 2015 4:25 pm

I tried a.m. method yesterday and it undoubtedly works, although you may need a lot of time. The upgrade took more than an hour and the dist-upgrade took more than three hours on my Pi B+. Also at least some of my settings (config.txt) were overwritten with default values, so be sure to save your setting first.
Anyway, I found the all new installation onto a clean memory card to be the easier and much faster way.
RPi B+ / RPi 2 // Raspbian / OpenElec / Retropie // DSL 40.7 Mbit/s

User avatar
cosmo
Posts: 51
Joined: Mon Nov 19, 2012 8:36 pm

Re: Raspberry Pi 2 doesn't boot, original Model B does

Wed Mar 11, 2015 9:30 pm

Thanks for the replies, I was able to get the card to work using the proper distribution. Now I'm waiting for another card so I can set up the Raspbian OS.

Thanks again!

pixster
Posts: 12
Joined: Fri Aug 23, 2013 1:03 pm
Location: Cresscent City, CA USA
Contact: Website

Re: Raspberry Pi 2 doesn't boot, original Model B does (solv

Mon Mar 16, 2015 2:03 am

With a fresh copy of Wheezy, it boots just fine!

NO, an already running copy of Wheezy brought up on
a Pi 1 WON'T work on a Pi 2!! :roll:

Were talking about 2 different SoC's BCM2835 vs BCM2836

User avatar
rpdom
Posts: 16398
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Raspberry Pi 2 doesn't boot, original Model B does (solv

Mon Mar 16, 2015 7:27 am

pixster wrote:With a fresh copy of Wheezy, it boots just fine!

NO, an already running copy of Wheezy brought up on
a Pi 1 WON'T work on a Pi 2!! :roll:
Unless you run sudo apt-get update;sudo apt-get upgrade on the Pi 1 first. (and some voodoo stuff if you have NOOBS).

pixster
Posts: 12
Joined: Fri Aug 23, 2013 1:03 pm
Location: Cresscent City, CA USA
Contact: Website

Re: Raspberry Pi 2 doesn't boot, original Model B does (solv

Fri Mar 27, 2015 6:58 pm

rpdom wrote:
pixster wrote:With a fresh copy of Wheezy, it boots just fine!

NO, an already running copy of Wheezy brought up on
a Pi 1 WON'T work on a Pi 2!! :roll:
Unless you run sudo apt-get update;sudo apt-get upgrade on the Pi 1 first. (and some voodoo stuff if you have NOOBS).
A fresh download of Wheezy from their home sight boots just fine. Forget noobs! :ugeek:

Return to “Troubleshooting”