Posts: 20
Joined: Thu Jan 08, 2015 10:36 pm

SOLVED: Bluetooth Keyboard Help Needed

Thu Jan 08, 2015 11:01 pm

Hi, I've been enjoying my RPi B+ since Christmas, where it was an unexpected gift. Quite impressed! :D

I've had almost no trouble installing software and hardware of interest, but have hit a snag with trying to enable a Bluetooth keyboard. Can someone point me in the right direction to get this working.

I have a usb Bluetooth dongle which is recognized when I do an lsusb as

Code: Select all

Bus 001 Device 005: ID Oa12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
I've seen posts on these forums and elsewhere to install Bluez, and/or Bluez-utils, Bluez-tools, bluez python, etc. and have tried a lot of them.

I've done searches on this forum for "Bluetooth Keyboard" and checked through 5 pages of search results. Unfortunately, no references have specifically talked about what is actually necessary to install as software. or listed a procedure for connecting to a keyboard. Most deal with phones, or android devices, etc.

So I've removed all the Bluetooth software so far, auto removed, purged, and am ready to start from scratch again.

Can anyone help me to pick the right software to install, and then give steps to connect to a keyboard?

I very much appreciate your help! :D
Last edited by vtpi on Fri Jan 09, 2015 10:22 pm, edited 1 time in total.

Posts: 20
Joined: Thu Jan 08, 2015 10:36 pm

Re: Bluetooth Keyboard Help Needed

Fri Jan 09, 2015 9:12 pm

Since I'm a newcomer it took awhile for this question to appear, since it had to be approved, and in the meantime I was able to solve the problem.

Well the first problem finally figured out was that the search engine in this forum ignored the term "keyboard" when I had searched several times for the terms "bluetooth keyboard". Because the word keyboard was apparently too common! So all searches simply returned references to bluetooth, and none of the twenty or so I checked out addressed my issue. I figured it out when I did a search for "keyboard" alone, and got the no-go message loud and clear.

Luckily Ixquick doesn't think "keyboard" is so common so searching on the terms:

Code: Select all

host:raspberrypi.org/forums bluetooth keyboard
returned enough useful threads to find what I was looking for eventually linked to:

http://www.ctheroux.com/2012/08/a-step- ... pberry-pi/

And following those steps did the trick. And it works for many bluetooth devices. It has clear download and step-by-step instructions for bringing up the devices.

There oughta be a sticky. :D

User avatar
Posts: 93
Joined: Thu Jan 23, 2014 3:50 pm
Location: Virginia, USA

Re: SOLVED: Bluetooth Keyboard Help Needed

Mon Feb 23, 2015 10:01 pm

Unfortunately, the link in the 2nd post to the "guide" isn't entirely working for me - I was able to get a bluetooth keyboard enabled and to stay enabled across shutdowns and reboots, however a bluetooth mouse (Microsoft) is simply not coming up correctly though I have been able to get its presence acknowledged now and then.

And, while putzing around with the various commands available trying to get the mouse working, errors in those invocations that had nothing apparently to do with the keyboard caused the keyboard to disconnect. Powercycling the keyboard did not bring it back to life. Plugging in a wired keyboard and resetting the bluetooth device via "hciconfig hci0 reset" (or something like that) did bring the bluetooth keyboard back to life and usable, but that is not a viable solution if I'm planning on NOT having a wired keyboard around to plug in to fix things. I suspect there is something flakey about the bluetooth driver causing the keyboard to go offline and preventing the mouse from being consistently recognized.

BTW, the GUI method of interaction itself is not working for the mouse (though it was earlier today) so maybe there is some sort of database somewhere that got corrupted?

Anyhow, earlier today I had both keyboard and mouse working inside a X session but not across reboots - now I have the keyboard working across reboots but the mouse simply isn't there consistently and nt working at all other than being noticed sometimes.

Return to “Beginners”