kaspencer
Posts: 80
Joined: Wed Mar 07, 2012 11:37 pm
Location: UK, England, Wiltshire

Windows 8.1 cannot connect to SAMBA shares

Sun Dec 21, 2014 6:29 pm

Greetings all.

I have used one of my Raspberries Pi for years now as a file server, and highly successful it has been, having saved me alot of cash on electricty compared to my old Windows 2003 server.

I recently acquired a Windows 8.1 tablet, and have pulled all my hair out (haven't any really) trying to get it to connect the shares on the RPi file-server.
OK:
The Win8.1 machine can connect to my Windows 7 and Windows Vista PCs.
The Vista & 7 machines have used the RPi file-server for years, and still can.

So it must(??) be something up with Windows 8.1 eh?
So, I have set it up without a Homegroup, and the LAN is Private.
The RPi fileserver is visible in the LAN browser window, with the other machines. It's just that the User/Password is not acceptable. I have tried with the RPi machine name as the domain and with the workgroup as the domain name (works that way for Win8.1 to access the other PCs) and of course with the Win8.1 machine name as the domain name (the default).

I have tried switching off (and on) SMB2 and .SMB3 on the Win8.1 machine with SC CONFIG LANMANWORKSTATION. When SMB2 & SMB3 are off, Win8.1 cannot connect to Win7 or WinVista anyway.

So chaps, any answers? It's worth a pint in our local!

Ken
2x256Mb + 2x512Mb RPi, Eth'netLAN+Win2k3R2 svr, 40MbpsFTTC.
RaspBMC: 128G SD, K400 wl Kb+TPd, HD32tv&Rem.
RW'y webserver: 64G SD, Y-RK49 wl Kb+M, HannsG W24" screen
RW'y PDC & fileserver: as above + 2TB disc.
+RiscOSPi on 32G uSD.

beta-tester
Posts: 1237
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: Windows 8.1 cannot connect to SAMBA shares

Sun Dec 21, 2014 6:40 pm

are you really sure, that you enabled the "SMB1.0/CIFS File Sharing Support"-feature?
(Control Panel\All Control Panel Items\Programs and Features -> "Turn Windows features on or off" -> "SMB1.0/CIFS File Sharing Support")
for some reason not all Windows 8.1 versions have that feature enabled by default

and "File and Printer Sharing for Microsoft Networks" has to be enabled - it is enabled by default
(Control Panel\Network and Internet\Network Connections -> "Ethernet Propertied" -> "File and Printer Sharing for Microsoft Networks")
{ I only give negative feedback }
RPi Model B (rev1, 256MB) & B (rev2, 512MB) & B+, RPi2B, RPi3B, RPi3B+, RPiZeroW, ...

User avatar
emgi
Posts: 357
Joined: Thu Nov 07, 2013 4:08 pm
Location: NL

Re: Windows 8.1 cannot connect to SAMBA shares

Sun Dec 21, 2014 8:16 pm

Did you enter the win8 username through smbpasswd?

/emgi

kaspencer
Posts: 80
Joined: Wed Mar 07, 2012 11:37 pm
Location: UK, England, Wiltshire

Re: Windows 8.1 cannot connect to SAMBA shares

Mon Dec 22, 2014 12:28 am

Thanks for the replies, Beta & MG.

1. Yes, SMB1.0/CIFS File Sharing Support is definitely enabled.
2. And, MG, thanks: yes I have had my network in action in all its forms since 1994! And every machine has a standard set of users, and they are all configured for SAMBA (et al). And they all function properly on the Win7 and WinVista machines.

Anyone else with any ideas?

Thanks

Ken.
2x256Mb + 2x512Mb RPi, Eth'netLAN+Win2k3R2 svr, 40MbpsFTTC.
RaspBMC: 128G SD, K400 wl Kb+TPd, HD32tv&Rem.
RW'y webserver: 64G SD, Y-RK49 wl Kb+M, HannsG W24" screen
RW'y PDC & fileserver: as above + 2TB disc.
+RiscOSPi on 32G uSD.

DirkS
Posts: 9940
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Windows 8.1 cannot connect to SAMBA shares

Mon Dec 22, 2014 12:31 am

kaspencer wrote:Thanks for the replies, Beta & MG.

1. Yes, SMB1.0/CIFS File Sharing Support is definitely enabled.
2. And, MG, thanks: yes I have had my network in action in all its forms since 1994! And every machine has a standard set of users, and they are all configured for SAMBA (et al). And they all function properly on the Win7 and WinVista machines.

Anyone else with any ideas?

Thanks

Ken.
Are you actually getting errors about user / id password or could it be something else?

Gr.
Dirk.

User avatar
emgi
Posts: 357
Joined: Thu Nov 07, 2013 4:08 pm
Location: NL

Re: Windows 8.1 cannot connect to SAMBA shares

Mon Dec 22, 2014 4:23 am

Well, the issue is known on the web: http://support.microsoft.com/kb/2976995

And you can find a lot more (at least I did 8-) ) when searching for "windows 8.1 samba".


/emgi

kaspencer
Posts: 80
Joined: Wed Mar 07, 2012 11:37 pm
Location: UK, England, Wiltshire

Re: Windows 8.1 cannot connect to SAMBA shares

Sun Dec 28, 2014 11:14 am

Thanks for the replies, MG and Dirk.

Comments are thus:

1. For Dirk: Windows 8.1 sees the server in the Networks view.
The error as reported by Windows 8.1 after completing the login credentials is
"[servername] is not accessible. You might not ... .
... The user is not allowed to log in from this workstation
."

That message does not make sense, because the user CAN access the server from other PCs AND Windows 8.1 CAN access other PCs on the LAN too.

2. For MG: I have searched here and there and everywhere. There is much comment and complaint about Windows 8.1 and networking (and other areas too.) But you know that. I have tried several little ideas involving LanManWorkstation parameters etc etc. To no avail.

3. Other information. I have examined the SAMBA log and find that whenever I try to hit the SAMBA server with the Windows 8.1 client, I get this added to the SAMBA LOG for the Windows 8.1 client:
"[2014/12/28 10:49:44.230554, 1, pid=8548, effective(0, 0), real(0, 0)] passdb/pdb_ldap.c:2550(ldapsam_getgroup)
ldapsam_getgroup: Duplicate entries for filter (&(objectClass=sambaGroupMapping)(sambaSID=S-1-5-21-3949262546-995700555-407426867-513)): count=7
[2014/12/28 10:50:16.222589, 1, pid=8551, effective(0, 0), real(0, 0)] smbd/process.c:457(receive_smb_talloc)
receive_smb_raw_talloc failed for client 10.0.0.97 read error = NT_STATUS_CONNECTION_RESET.


Unsurprisingly, 10.0.0.97 is the IP address of the Windows 8.1 client. The SAMBA LOG file for the client is named by the Windows 8.1 hostname. I am completely unable to see any duplicate entries in the SAMBA config file.

Any further ideas?

Seasons Greetings all

Kenneth Spencer
2x256Mb + 2x512Mb RPi, Eth'netLAN+Win2k3R2 svr, 40MbpsFTTC.
RaspBMC: 128G SD, K400 wl Kb+TPd, HD32tv&Rem.
RW'y webserver: 64G SD, Y-RK49 wl Kb+M, HannsG W24" screen
RW'y PDC & fileserver: as above + 2TB disc.
+RiscOSPi on 32G uSD.

kaspencer
Posts: 80
Joined: Wed Mar 07, 2012 11:37 pm
Location: UK, England, Wiltshire

Re: Windows 8.1 cannot connect to SAMBA shares

Sun Dec 28, 2014 12:19 pm

OK OK - it is solved now!

I couldn't find a duplicated name in the SAMBA/LDAP configurations but I did find a spelling error in one of the Group Lists. Funny that the error message was a bit misleading, as one wouldn't usually call an omission a duplication, but that's computing for you!

All the best

Ken
2x256Mb + 2x512Mb RPi, Eth'netLAN+Win2k3R2 svr, 40MbpsFTTC.
RaspBMC: 128G SD, K400 wl Kb+TPd, HD32tv&Rem.
RW'y webserver: 64G SD, Y-RK49 wl Kb+M, HannsG W24" screen
RW'y PDC & fileserver: as above + 2TB disc.
+RiscOSPi on 32G uSD.

Return to “Troubleshooting”