Markodius
Posts: 134
Joined: Fri Jan 04, 2013 11:14 pm

Various errors including ack/nak

Fri Dec 19, 2014 1:11 am

Dear all,

My Raspberry pi is experiencing some sort of metaphysical dichotomy. When booting I mostly get ack/nak errors in an eternal loop followed by kernel panic. I've tried disconnecting the usb peripherals and that does seem to reduce the frequency of the errors a little but not a lot. Even with no keyboard and mouse and logging in via ssh the problem persists. When it does boot to the gui the external SSD drive is lost and I get various file-system errors after a short while. If I disconnect the ethernet prior to boot then all errors go away and the pi functions, as far as I can tell, as per spec. If I boot and then plug in the ethernet I get kernel panic and or filesystem errors usually immediately - sometimes just the filesystem errors. Often running gparted and a root terminal will induce these errors after a few minutes.

The pi has been running as a file server for about a year overclocked and it's absolutely wonderful when operating. I thought it might be my version of raspbian (the hacked-up installer version) so I loaded the latest version of raspbian and did the update process but still the same. Have I cooked my pi? Any help appreciated.
“In the modern age, to call a man unelectable means he cannot be bought”

Markodius
Posts: 134
Joined: Fri Jan 04, 2013 11:14 pm

Re: Various errors including ack/nak

Fri Dec 19, 2014 2:49 am

:idea: Interestingly, underclocking the pi (down to 500mhz) also makes these problems 'go away'.
“In the modern age, to call a man unelectable means he cannot be bought”

Markodius
Posts: 134
Joined: Fri Jan 04, 2013 11:14 pm

Re: Various errors including ack/nak

Fri Dec 19, 2014 3:05 am

O.k. - the problems haven't 'gone away' entirely but are somewhat less ubiquitous :roll: and I can now boot to the gui, watch 'Voyage to the bottom of the sea' :o if I should so want.
“In the modern age, to call a man unelectable means he cannot be bought”

User avatar
rpdom
Posts: 14447
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Various errors including ack/nak

Fri Dec 19, 2014 7:13 am

Have you tried a different power supply?

Those problems all sound like ones that can be caused by insufficient voltage, and power supplies can fail over time.

Markodius
Posts: 134
Joined: Fri Jan 04, 2013 11:14 pm

Re: Various errors including ack/nak

Fri Dec 19, 2014 12:18 pm

I don't have a spare power supply to hand but I'll have a rummage and report back when one is in place. Thanks for the tip, I'll report back when I have another power supply in place 8-)
“In the modern age, to call a man unelectable means he cannot be bought”

Markodius
Posts: 134
Joined: Fri Jan 04, 2013 11:14 pm

Re: Various errors including ack/nak

Sun Dec 21, 2014 10:23 pm

I couldn't find a replacement power supply but used the old 'backfeed' power tricj via an old USB hub. The pi stabilised and I can now run overclocked reliably. Thanks rpdom! :D
“In the modern age, to call a man unelectable means he cannot be bought”

Markodius
Posts: 134
Joined: Fri Jan 04, 2013 11:14 pm

Re: Various errors including ack/nak

Fri Jan 09, 2015 8:04 pm

Oh happy days! I got a 5.25v supply (and a USB to micro USB lead) and the pi now clocks at 1.1ghz, Just goes to show that power supplies do indeed fail over time and some power supplies, such as the one supplied my by RS along with the PI do this very quickly indeed because my PI has never reliably operated at 1.1ghz before.

https://www.modmypi.com/5v-2A-modmypi-r ... wer-supply
“In the modern age, to call a man unelectable means he cannot be bought”

Return to “Troubleshooting”