Posts: 11
Joined: Sun Jan 27, 2013 2:55 pm

Error seting up netcfg

Sat Apr 06, 2013 4:29 pm


I am triying to use netcfg to set up the connection but I get this error :

Code: Select all

Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or directory.
My /etc/wpa_supplicant.conf is :

Code: Select all

When I run:

Code: Select all

wpa_supplicant -iwlan0 -c /etc/wpa_supplicant.conf & dhcpcd wlan0
It connects, but when I try to use netcfg I get the previous error. The config profile I am using is:

Code: Select all

DESCRIPTION='A wpa_supplicant configuration based wireless connection'
# Uncomment this if your ssid is hidden
Do you know what could happen?
Thank you very much

Posts: 54
Joined: Sun Sep 09, 2012 8:06 am

Re: Error seting up netcfg

Sun Apr 07, 2013 7:13 am

This is a bit of a wild guess, but based on your error message, try adding the following to the top of your wpa_supplicant.conf (outside the network block):

Code: Select all

Raspberry Pi (rev 000f, 512MB RAM) with heatsinks and a modmypi case running Arch Linux ARM (armv6h) hooked up to a 750GB 2.5" USB-harddrive

Posts: 1
Joined: Thu Apr 03, 2014 12:40 am

Re: Error seting up netcfg

Thu Apr 03, 2014 12:42 am

Since OP didn't reply, I'll say that this was my problem and adding the ctrl,_interface line fixed it.

Posts: 2
Joined: Tue Jun 25, 2013 6:41 pm

Re: Error seting up netcfg

Tue Aug 22, 2017 5:16 pm

Hello :D ,

I had a similar bug with Raspian Stretch, when I executed "sudo wpa_cli reconfigure", it has always return this error :x : (Notice the nil in place of the null)

Code: Select all

Failed to connect to non-global ctrl_ifname: (nil)  error: No such file or directory
I solved it by doing:

Code: Select all

sudo ln -s /usr/share/dhcpcd/hooks/10-wpa_supplicant /etc/dhcp/dhclient-enter-hooks.d/
Do I've done something wrong? I am using on Raspberry Pi B Model with a Wifi Dongle, Headless with net.ifname=0...
I've followed the procedure from here ...

Return to “Arch”

Who is online

Users browsing this forum: No registered users and 1 guest