luisgibe
Posts: 8
Joined: Fri Nov 15, 2013 12:25 pm

Pi stops working after unplug HDMI

Fri Nov 15, 2013 12:42 pm

Hi guys,

First of all I would like to say hello to everyone here, as this forum has been incredibly helpful.

But I have an issue which is driving me crazy.

I have a Pi with raspbmc installed (based on raspbian) acting as media server. It has an external HD connected via USB, working just fine.

The problem comes when I have to unplug the HDMI cable from the TV, as my TV only has 1 HDMI input and I want to use my Xbox, Sky box, or whatever. The Raspberry just freezes completely (no ssh, no ping, nothing), and I have to reboot it completely removing the power supply, which is quite annoying.

It is even shown in the LED status lights. Only the PWR one keeps on.

Is this normal? How can address this?

Thanks in advance

MoosePi
Posts: 112
Joined: Wed Nov 06, 2013 4:42 pm

Re: Pi stops working after unplug HDMI

Fri Nov 15, 2013 12:50 pm

Purchasing a HDMi Hub would make it easier on the connectors:

http://www.amazon.co.uk/Duronic-HDS3-Sw ... s=hdmi+hub
Pi Forum Search and Google yields answers to many questions

User avatar
RaTTuS
Posts: 10574
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Pi stops working after unplug HDMI

Fri Nov 15, 2013 12:51 pm

dunno the answer but
how about one of these
http://www.amazon.co.uk/Duronic-HDS3-Sw ... 0020426AG/
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

luisgibe
Posts: 8
Joined: Fri Nov 15, 2013 12:25 pm

Re: Pi stops working after unplug HDMI

Fri Nov 15, 2013 12:58 pm

oh! I didn't know this exists! I would buy one, but the issue is still annoying me :/

User avatar
Davespice
Forum Moderator
Forum Moderator
Posts: 1665
Joined: Fri Oct 14, 2011 8:06 pm
Location: The Netherlands
Contact: Twitter

Re: Pi stops working after unplug HDMI

Fri Nov 15, 2013 1:17 pm

luisgibe wrote:oh! I didn't know this exists! I would buy one, but the issue is still annoying me :/
I’m fascinated by this. It seems like it’s almost an electrical issue, unplugging the hdmi lead is causing something to spike on the board which is causing a crash. That’s how it seems to me anyway. I’d like to find out if the issue is either with the TV, the Pi or the HDMI Lead. So can you try these tests?
  • Pi and original HDMI cable on different TV
  • Pi and different HDMI cable on original TV
  • Pi and different HDMI cable on different TV
The quality of HDMI cables can vary a lot and it might be that the one you have doesn’t have the wires inside insulated very well. That’s just a conjecture though, but if you do the tests above you’ll probably be a bit closer to understanding what is going on.

luisgibe
Posts: 8
Joined: Fri Nov 15, 2013 12:25 pm

Re: Pi stops working after unplug HDMI

Fri Nov 15, 2013 1:22 pm

Davespice wrote:
luisgibe wrote:oh! I didn't know this exists! I would buy one, but the issue is still annoying me :/
I’m fascinated by this. It seems like it’s almost an electrical issue, unplugging the hdmi lead is causing something to spike on the board which is causing a crash. That’s how it seems to me anyway. I’d like to find out if the issue is either with the TV, the Pi or the HDMI Lead. So can you try these tests?
  • Pi and original HDMI cable on different TV
  • Pi and different HDMI cable on original TV
  • Pi and different HDMI cable on different TV
The quality of HDMI cables can vary a lot and it might be that the one you have doesn’t have the wires inside insulated very well. That’s just a conjecture though, but if you do the tests above you’ll probably be a bit closer to understanding what is going on.

Hi,

Thanks for your inputs, didn't think about an electrical issue.

I will try this. Unfortunately I don't have an additional TV for trying it, but I do have 2 HDMI cables (which I swap over between the Pi, Xbox and Sky box).

I will keep this updated ;)

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5800
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Pi stops working after unplug HDMI

Fri Nov 15, 2013 2:34 pm

FWIW, and further to the suggestions of @MoosePi and @RaTTuS I've found this 3-port HDMI switch very reliable:
http://www.cpmspectrepi.webspace.virgin ... tcher.html
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Return to “Troubleshooting”