Edimax Light blinking all the time


26 posts   Page 1 of 2   1, 2
by darkpollo » Mon Jan 28, 2013 12:48 am
Hi,
After several tries i was able to connect to my RPI using my Edimax Wifi dongle but the blue light keep blinking all the time.
Is that normal?

How can i make it to stay just blue.

Thanks
Posts: 2
Joined: Mon Jan 28, 2013 12:40 am
by Mobius » Mon Jan 28, 2013 3:33 pm
If it works don't worry about it. Some devices blink to indicate activity.
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA
by darkpollo » Mon Jan 28, 2013 3:48 pm
It works. I have been able to connect to it through ssh without any problem. :)

Thanks
Posts: 2
Joined: Mon Jan 28, 2013 12:40 am
by PaulCheffus » Mon Jan 28, 2013 4:44 pm
darkpollo wrote:Hi,
After several tries i was able to connect to my RPI using my Edimax Wifi dongle but the blue light keep blinking all the time.
Is that normal?

How can i make it to stay just blue.

Thanks



Hi

Completely normal and as has been mentioned it shows activity.

Cheers

Paul
Procrastination - The Thief of Time.
Posts: 381
Joined: Tue May 29, 2012 2:51 pm
Location: Lincolnshire UK
by Pinkie Pi » Tue Jun 04, 2013 7:12 pm
Hi guys,

I too have the edimax usb adapter in use with my raspi. It works like a charme, but the led keeps going on and off, which wouldn't bother me if the pi weren't placed next to my bed. The blinking blue light is quite disturbing when you want to sleep, so I had to halt the pi every night so far, which makes it impossible for it to fulfill its aspired job as a light alarm clock (it shall simulate sunrise with a bunch of leds in the morning). I don't really want to tape something on the led to make this go away, so... does anyone have an idea on how to disable this "inactivity blinking" software wise? I've tried to disable the led entirely by adding some options to iwlagn.conf and wlan.conf in /etc/modprobe.d but to no effect. Any help is lots appreciated :)

Thanks and all the best,

Pinkie Pi
Posts: 1
Joined: Tue Jun 04, 2013 7:02 pm
by itimpi » Wed Jun 05, 2013 11:55 am
As far as I know the blinking LED to show activity is built into the EdiMax adapter. I would suggest a bit of bluetack over the LED if you find it disturbing.
Posts: 1063
Joined: Sun Sep 25, 2011 11:44 am
Location: Potters Bar, United Kingdom
by solar3000 » Wed Jun 05, 2013 1:18 pm
I have one of those too.
While other adapters just keep the LED lit to indicate that it is connected, the EDImax just flashes blue to show that it is connected.
I think the solution is to yell at the manufacture. On the up side, it isn't very brightly lit.
Antikythera
User avatar
Posts: 964
Joined: Sat May 18, 2013 12:14 am
by MrEngman » Wed Jun 05, 2013 5:23 pm
It is possible to stop the LED flashing - keeping it turned off all the time. Personally I'd feel completely lost without it flashing.

I don't know if it can be done by changing some configuration file but it can be turned of by editing one of the files in the rtl8192cu module source and recompiling the module.

You need to edit the file rtl8192cu/include/autoconf.h and comment out line 120 as in the patch following:
Code: Select all
diff -aur rtl8192cu-flashingLED/include/autoconf.h rtl8192cu/include/autoconf.h
--- rtl8192cu-flashingLED/include/autoconf.h    2013-06-05 17:27:32.725842096 +0100
+++ rtl8192cu/include/autoconf.h        2013-06-05 17:25:09.405027367 +0100
@@ -117,7 +117,7 @@

 #define CONFIG_SKB_COPY        1//for amsdu

-#define CONFIG_LED
+//#define CONFIG_LED
 #ifdef CONFIG_LED
        #define CONFIG_SW_LED
        #ifdef CONFIG_SW_LED


However, for those of you using the images 2013-02-09-wheezy-raspbian or 2013-05-25-wheezy-raspbian, the latest raspbian image, and rpi-updates to these images to 4 Jun, I have posted a compiled driver on dropbox.

Instructions on installing it follow.
Code: Select all
# save the original module in case you decide you want the LED flashing after all.
cp /lib/modules/3.6.11+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko 8192cu.ko.orig
# download the modified module.
wget https://dl.dropboxusercontent.com/u/80256631/8192cu-noLED.tar.gz
tar -xzvf 8192cu-noLED.tar.gz
# install the new module with the correct file permissions.
sudo install -p -m 644 8192cu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless/rtl8192cu
# stop and unload the currently running module.
sudo rmmod 8192cu
# load and start up the new module.
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko
# update any module dependencies.
sudo depmod -a
# check the wifi is up and running and has a network connection
ifconfig

OK, Pinkie Pi, hope this may be useful and you can now keep your Pi running and get some sleep.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by notger.heinz » Fri Jun 14, 2013 1:54 pm
Thx a lot for the fix!

(Actually I registered on this board just to thank you.)
Posts: 3
Joined: Fri Jun 14, 2013 1:42 pm
by MrEngman » Fri Jun 14, 2013 3:50 pm
notger.heinz wrote:Thx a lot for the fix!

(Actually I registered on this board just to thank you.)

Thank you. Much appreciated that you let me know.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by brtnshrdr » Thu Mar 27, 2014 6:02 pm
Would anyone be able to help me compile this for the 3.10.25+ kernel?
Posts: 2
Joined: Thu Mar 27, 2014 6:00 pm
by MrEngman » Thu Mar 27, 2014 9:19 pm
brtnshrdr wrote:Would anyone be able to help me compile this for the 3.10.25+ kernel?

So you want to turn of the LED? I can compile it so the LED stays off if you want.

Much easier than trying to describe how to compile it yourself.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by DougieLawson » Thu Mar 27, 2014 11:40 pm
Isn't it easier to stick a piece of gaffer/duck/duct tape over the end of the dongle?
We did that with the TV in our bedroom because the standby light can't be disabled from the menu on it.

Gaffer tape is "The Force". It has a dark side and a light side and it holds the universe together.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.
User avatar
Posts: 28142
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by MrEngman » Fri Mar 28, 2014 12:12 am
If you have a suitable tape it probably is easier. However, I don't so a couple of minutes recompiling and installing the driver is simpler for me. And cheaper, no needing to buy some tape. ;)

And there's always the possibility the wifi adaptor may get rather too hot if you cover it in gaffer tape. Gets hot enough without it.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by MrEngman » Fri Mar 28, 2014 12:29 am
There is also a much simpler solution which allows me to keep the LED flashing so I know it is connected and working but also hide the led when I don't want to see it flashing.

I connect my wifi to my Pi using a USB extension cable. By turning the wifi adaptor around I can easily reposition it so the LED is visible so I can see it flashing if I want to or not visible so I can't see it flashing so it doesn't interfere with me sleeping.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by brtnshrdr » Thu Apr 03, 2014 5:36 pm
MrEngman wrote:
brtnshrdr wrote:Would anyone be able to help me compile this for the 3.10.25+ kernel?

So you want to turn of the LED? I can compile it so the LED stays off if you want.

Much easier than trying to describe how to compile it yourself.


MrEngman


If you could, that would be awesome!
Posts: 2
Joined: Thu Mar 27, 2014 6:00 pm
by MrEngman » Thu Apr 03, 2014 5:59 pm
brtnshrdr wrote:
MrEngman wrote:
brtnshrdr wrote:Would anyone be able to help me compile this for the 3.10.25+ kernel?

So you want to turn of the LED? I can compile it so the LED stays off if you want.

Much easier than trying to describe how to compile it yourself.


MrEngman


If you could, that would be awesome!

Need to check what image you are using to make sure I have the right linux source. Please post the output from commands uname -a and lsusb.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by MrEngman » Thu Apr 03, 2014 7:08 pm
Hi brtnshrdr,

Assuming uname -a returns one of the following
Code: Select all
Linux raspberrypi 3.10.25+ #616 PREEMPT Mon Dec 23 18:13:02 GMT 2013 armv6l GNU/Linux
Linux raspberrypi 3.10.25+ #618 PREEMPT Thu Jan 2 20:00:10 GMT 2014 armv6l GNU/Linux
Linux raspberrypi 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l GNU/Linux
Linux raspberrypi 3.10.25+ #624 PREEMPT Tue Jan 7 20:10:18 GMT 2014 armv6l GNU/Linux
and lsusb shows the wifi as
Code: Select all
 ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
I have compiled a driver with NO flashing LED available here.

If your uname -a returns a different value let me know.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by elaine » Thu May 08, 2014 4:29 pm
Thanks MrEngman for posting the fix to turn the led off.

Elaine
Posts: 1
Joined: Thu May 08, 2014 4:13 pm
by dirtydischo » Sat Jul 19, 2014 8:41 pm
I'd like to turn the led off on my wifi dongle too, but as I have a different kernel the two versions that people have uploaded here don't work for me.

Can someone explain how to compile the driver without the led on (or even better, compile an updated version for me!) please?

My uname returns:
Linux rpicamtouch2 3.10.33+ #1 PREEMPT Sat Mar 8 18:51:35 CET 2014 armv6l GNU/Linux


Grateful for any help on this.
Posts: 26
Joined: Mon Feb 11, 2013 6:18 pm
by MrEngman » Sat Jul 19, 2014 9:43 pm
To recompile the driver without the LED enabled you will first need to obtain the kernel source code, which I find can be the most difficult part of recompiling a driver. You will then need the .config file which should be included in the image in the file /proc/config.gz. You will then need to compile the kernel to generate the infomation required to re-compile the driver. However, if the driver is included in the kernel source compiling the kernel will include compiling the driver. I think the Raspberry Pi wiki has examples for compiling the kernel.

There is a rather simpler method though. I always find the LED is useful to be able to check the wifi is running. If you don't want to see the LED flashing a very simple way to 'disable' it is cover it with a piece of electrical tape. Rather easier than trying to recompile the driver. And if you have problems with the wifi you can remove the tape to see the LED activity to see if it is working or not. This is not possible if the LED is disable in the module.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by RockOn_23 » Tue Dec 08, 2015 6:16 pm
Hi MrEngman,

can you please recompile the modified driver for me?

Code: Select all
[root@runeaudio http]# uname -a
Linux runeaudio 3.18.7-3-ARCH #1 SMP PREEMPT Fri Feb 13 06:23:21 MST 2015 armv7l GNU/Linux


Thank you very much,
Kr
Benjamin
Posts: 3
Joined: Tue Dec 08, 2015 5:58 pm
by AlleyCat66 » Sun Mar 06, 2016 12:11 pm
Hi MrEngman
Thank you very much for your support. I am looking for the Edimax AC600 drivers (8812au) for Rune Audio, which is running on Kernel 3.18.7-3-ARCH . I am writing to ask if you could point me to where I can get the drivers that you may have compiled?

AlleyCat66
Posts: 1
Joined: Fri Mar 04, 2016 4:54 pm
by GamerGun » Sat Apr 30, 2016 4:29 pm
Hi MrEngman,
Could you please help me as well?

Linux OpenELEC 4.1.18 #1 SMP Mon Feb 29 20:48:22 CET 2016 armv7l GNU/Linux

Module Size Used by
8812au 900699 0
hci_uart 11657 1
btbcm 3852 1 hci_uart
bluetooth 273858 3 btbcm,hci_uart
brcmfmac 164388 0
brcmutil 4729 1 brcmfmac
cfg80211 226808 2 brcmfmac,8812au
bcm2835_gpiomem 2588 0
bcm2708_rng 821 0

Thanks in advance!

Tommy
Posts: 2
Joined: Sat Apr 30, 2016 4:27 pm
by MrEngman » Sun May 01, 2016 3:13 pm
GamerGun wrote:Hi MrEngman,
Could you please help me as well?

Linux OpenELEC 4.1.18 #1 SMP Mon Feb 29 20:48:22 CET 2016 armv7l GNU/Linux

Module Size Used by
8812au 900699 0
hci_uart 11657 1
btbcm 3852 1 hci_uart
bluetooth 273858 3 btbcm,hci_uart
brcmfmac 164388 0
brcmutil 4729 1 brcmfmac
cfg80211 226808 2 brcmfmac,8812au
bcm2835_gpiomem 2588 0
bcm2708_rng 821 0

Thanks in advance!

Tommy

Help with what?



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.
Posts: 3470
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK