Posts: 9
Joined: Mon Aug 27, 2012 8:44 pm

Old OS won't boot on new Pi

Fri Feb 22, 2013 11:17 pm

I just got a batch of 4 new Raspberry Pis from Newark Electronics. Model B, REV 2 with the mounting holes. Silk screening on the back of the board includes "KCE MC1", "94V-0 F1", "07/02" and "13:01", "3A." I hope that is enough to establish that these are the very latest.

I copied an image of Arch Linux Arm from several months ago onto a new SDHC card. I think that image was from archlinuxarm-13-06-2012.img. It was configured on a REV 1 Pi with 256 MB RAM. I loaded it into one of my new Pis, plugged in the network and the power cable.

It wouldn't boot. It just sat there with a single red LED on solid, and no other LEDs lighting up at all.

I swapped around power supplies, prepared a second SDHC card with the same image; nothing, not on any of the 4 boards.

I took it to the location where I am using the earlier REV 1 boards, and verified that my newly prepared SDHC card works on the old board, and that the new board fails with an old, tested SDHC image of Arch Linux ARM.

All of this was consistent with a bad batch of boards. Then I tried one more test. I prepared an SDHC card with the latest Raspbian Wheezy image (2013-02-09) and it worked. All 4 of my new boards are fine.

So, apparently there is some difference between the older REV 1 boards and the newer REV 2 board such that the old version of Arch Linux ARM fails to boot on it. Is this a known condition?

I was hoping just to duplicate what I had done with the old boards, and Arch has even changed the way they handle start-up daemons, so that this means I will have to re-do some stuff.

Added: I have not yet tested whether the new OS boots on the old REV 1 boards. Those are in another building, so I'll have to make another trip over there.

Posts: 982
Joined: Fri Sep 14, 2012 9:13 am

Re: Old OS won't boot on new Pi

Fri Feb 22, 2013 11:39 pm

Changes I know about

support for 512MB Memory
I know everything about nothing"

User avatar
Posts: 6374
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: Old OS won't boot on new Pi

Sat Feb 23, 2013 10:58 am

I know less than many about it, but here goes anyway ...

On the new SD card, with the old software, replace bootcode.bin and start.elf with new versions. That should get something going. At least it stands a chance of seeing the memory (which was the major change)

You may need to also swap the kernel.img as well

Return to “Troubleshooting”