Supertotor
Posts: 3
Joined: Sun Feb 03, 2013 6:46 pm

Qualité son Jack 3.5 mauvaise?

Sun Feb 03, 2013 7:24 pm

Bonjour,
J'ai récemment acquis un Raspberry Pi, et j'ai décidé d'y installer Openelec pas de problème XBMC lit correctement les vidéos SD et HD. Le raspberry Pi est branché à un moniteur qui ne possède pas d'enceintes j'ai donc branché des enceintes en prise jack.
Je lance une vidéo et là! HORREUR (oui j'éxagère...) déjà quand je lance, arrête, met en pause une vidéo j'entend un "pop" plutôt fort, encore ça ce n'est pas grave mais ce qui me gène le plus c'est un souffle, qu'on entend constamment, qui ressemble un peu au bruit d'un moteur et quand je monte les basses c'est juste ignoble.
J'aimerai savoir si c'est un problème connu, si ça vient du Raspberry ou d'Openelec, et comment y remédier (si possible).

Merci d'avance pour vois réponses.

listentruth
Posts: 284
Joined: Wed Dec 26, 2012 8:56 pm

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 05, 2013 9:29 am

Tu peut jouer avec les règlage du volume (max sur XBMC) et plus bas sur tes enceintes ?

Supertotor
Posts: 3
Joined: Sun Feb 03, 2013 6:46 pm

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 05, 2013 6:44 pm

Merci pour ta réponse,
J'ai déjà essayé de jouer avec le son, le souffle est moins audible lorsque le son XBMC est au plus faible, mais il reste quand même assez dérangeant... :cry: Je me doute bien que si je voulais avoire une exellente qualité il fallait pas prendre un RPI mais bon c'est moche! (Je ne regrette pas mon achat hein!)

Je précise aussi que j'ai branché mes enceintes sur mon ordinateur perso et aucun problème de son.

User avatar
fdion
Posts: 307
Joined: Sun Sep 16, 2012 2:33 pm
Location: North Carolina, USA
Contact: Website

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 05, 2013 10:07 pm

Supertotor wrote:Bonjour,
J'ai récemment acquis un Raspberry Pi, et j'ai décidé d'y installer Openelec pas de problème XBMC lit correctement les vidéos SD et HD. Le raspberry Pi est branché à un moniteur qui ne possède pas d'enceintes j'ai donc branché des enceintes en prise jack.
Je lance une vidéo et là! HORREUR (oui j'éxagère...) déjà quand je lance, arrête, met en pause une vidéo j'entend un "pop" plutôt fort, encore ça ce n'est pas grave mais ce qui me gène le plus c'est un souffle, qu'on entend constamment, qui ressemble un peu au bruit d'un moteur et quand je monte les basses c'est juste ignoble.
J'aimerai savoir si c'est un problème connu, si ça vient du Raspberry ou d'Openelec, et comment y remédier (si possible).

Merci d'avance pour vois réponses.
C'est openelec, (en fait le driver audio). En mode console sous raspbian, mpg123 ou mplayer c'est bien. Sinon, j'entends une distortion et cliquetis.

L'audio analogique est fait par PWM et Il se peut aussi que l'overclock cause des problèmes si le pilote ne gère pas cela bien (throttling du cpu)

François
Francois
http://raspberry-python.blogspot.com - http://www.3dFutureTech.info - @f_dion

vlg
Posts: 9
Joined: Sat Feb 09, 2013 5:27 pm

Re: Qualité son Jack 3.5 mauvaise?

Sat Feb 09, 2013 6:09 pm

bonjour à tous
je voudrais revenir sur ce problème de son ..
en vidéos, lecture, arrête, pause augmentation coupé du son !
j'ai pas bien compris " PWM ? et l'overclock cause des problèmes si le pilote ne gère pas cela bien (throttling du cpu) " .. /-))
peu t-ont changer le driver du son par un autre ?
merci d'avance

j'ai un Pi 512mo - openelec 2.99.2 frodo

vlg
Posts: 9
Joined: Sat Feb 09, 2013 5:27 pm

Re: Qualité son Jack 3.5 mauvaise?

Sat Feb 09, 2013 10:05 pm

Bonjour, je reviens sur votre post..
J'ai le même problème avec mon PI 512Mo sous openelec 2.99.2.
En mode vidéo, la pause, lecture, avance avant / arrière me crée un " "pop" sonore de fort niveau, et vue l'amplification que j'ai derrière j'ai peur de cassé un haut parleur.
J'ai pas bien compris le PWM et de l'overclock .. ?
As t-ont une possibilité de changer le driver peu être ..
Merci d'avance
Attachments
raspberry home 2.jpg
raspberry home 2.jpg (15.54 KiB) Viewed 14047 times

nikotinux
Posts: 766
Joined: Sat Feb 02, 2013 2:11 am

Re: Qualité son Jack 3.5 mauvaise?

Sun Feb 10, 2013 12:36 am

Le son généré sur la sortie jack n'est pas produit par un composant spécialisé comme dans un pc mais par un système électronique très simple dont le but, a la base, n'est pas de produire du son, du moins sur le raspberry.
Un PWM (Pulse Width Modulation) permet de générer de façon régulière et assez rapidement des impulsions électriques plus ou moins longues. Si on 'lisse' ensuite ces impulsions on obtient une tension proportionnelle a la largeur des impulsions. Par exemple si toutes les secondes on envoie une impulsion de 1/10 de secondes sous 5V, on obtient une tension de 0,5 V . Si l'impulsion dure 9/10 de seconde la tension sera de 4,5 V . On peut comme cela faire varier une tension de 0 a 5 V mais par pas de 1 seconde. C'est bien pour commander une LED ou un moteur ou on ne demande pas une tension très 'propre' ni très précise. Mais pour produire un son il faut envoyer des impulsions beaucoup plus courtes beaucoup plus rapidement. Et on obtient de toute façon pas un son de très grande qualité. Ça va bien pour de la téléphonie par exemple. Les convertisseurs numérique-analogique utilisés en Hifi sont plus complexes et plus chers ...
Pour calculer la largeur et la fréquence des envois d'impulsions, le processeur se base sur sa propre horloge. Si on change cette fréquence alors la qualité du son peut être altérée.

J'ai essayé une carte son USB sur mon raspberry comme celle ci http://www.konigelectronic.com/en_us/1088473
Le son est bien meilleur , le seul plop a lieu quand mon hub auto alimenté se mets sous tension et la carte par la même occasion. Par contre le trafic sur le bus USB est assez intense et ralenti un peu le raspberry, ce qui prouve quand même l'efficacité du PWM en terme de ressources utilisées. Sous VLC pas de problème mais avec RaspBMC on est plus que limite en temps processeur et il faut overclocker (mais ça n'influence pas la qualité du son cette fois). Je n'ai pas testé avec openELEC.

ren0
Posts: 90
Joined: Thu Feb 07, 2013 3:57 pm

Re: Qualité son Jack 3.5 mauvaise?

Sun Feb 10, 2013 10:51 pm

Malheureusement à l'heure actuelle, OpenELEC s'appuyant sur OMXPlayer (Openmax), il ne devrait pas gérer les carte/DAC-USB
""XBMC doesn't support ALSA on the PI. Even if we support ALSA, only PAPlayer for audio would work. The video player is limited to OpenMAX and it's components and doesn't support ALSA."
Tout est question de puissance. Pour avoir les performances voulues en multimédia (vidéo HD), des choix sont opérés.
Openmax est la solution choisie (ainsi sur Rasbian), mais aussi avec les limites qui vont avec.

vlg
Posts: 9
Joined: Sat Feb 09, 2013 5:27 pm

Re: Qualité son Jack 3.5 mauvaise?

Mon Feb 11, 2013 11:43 am

merci pour vos explications !
j'ai compris le fonctionnement maintenant ;-)
je vais voir pour passé tout le signal son en numérique pour contré ce souci ..
++

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Qualité son Jack 3.5 mauvaise?

Mon Feb 11, 2013 3:20 pm

Bien dommage qu'on ne puisse pas utiliser de carte son USB avec XBMC, j'ai un DAC en kit de très bonne facture, avec, heureux hasard, un port USB que je n'utilise pas.
Je rêve de pouvoir y brancher mon Pi, et pouvoir enfin profiter pleinement de mon système HiFi...

vlg
Posts: 9
Joined: Sat Feb 09, 2013 5:27 pm

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 12, 2013 12:17 pm

j'ai une petite idée pour récup le son analogique ..

http://www.izenet.com/epages/255617.sf/ ... tViaPortal

;-)

ren0
Posts: 90
Joined: Thu Feb 07, 2013 3:57 pm

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 12, 2013 3:21 pm

maintenant, tout dépend de la qualité du convertisseur D/A
vlg wrote:j'ai une petite idée pour récup le son analogique ..

http://www.izenet.com/epages/255617.sf/ ... tViaPortal

;-)

ren0
Posts: 90
Joined: Thu Feb 07, 2013 3:57 pm

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 12, 2013 3:23 pm

la problématique survient du fait de l'utilisation d' Openmax
il est possible de faire un serveur audio, avec Debian, et de gérer un DAC-USB

Zoolander06 wrote:Bien dommage qu'on ne puisse pas utiliser de carte son USB avec XBMC, j'ai un DAC en kit de très bonne facture, avec, heureux hasard, un port USB que je n'utilise pas.
Je rêve de pouvoir y brancher mon Pi, et pouvoir enfin profiter pleinement de mon système HiFi...

nikotinux
Posts: 766
Joined: Sat Feb 02, 2013 2:11 am

Re: Qualité son Jack 3.5 mauvaise?

Tue Feb 12, 2013 7:23 pm

RaspBMC supporte ma carte son USB, pas OpenELEC.

Supertotor
Posts: 3
Joined: Sun Feb 03, 2013 6:46 pm

Re: Qualité son Jack 3.5 mauvaise?

Wed Feb 13, 2013 7:07 am

Merci à tous pour vos réponses!
Je pense que je vais changer mon openelec par un RaspBMC et me prendre une carte son.

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Qualité son Jack 3.5 mauvaise?

Wed Feb 13, 2013 1:25 pm

nikotinux wrote:RaspBMC supporte ma carte son USB, pas OpenELEC.
Salut,

Est ce que RaspBMC supporte la carte son au niveau système (ce qui serait logique vu que c'est basé sur Raspbian), ou est ce que tu peux réellement avoir le son des vidéos que tu lis dans XBMC sur ta carte son ?

Dans le second cas, je passe directement sous RaspBMC à la place de Xbian !

J

ren0
Posts: 90
Joined: Thu Feb 07, 2013 3:57 pm

Re: Qualité son Jack 3.5 mauvaise?

Wed Feb 13, 2013 4:27 pm

à ma connaissance, tout ce qui utilise OMXPlayer ne sait gérer les carte/DAC-USB.
donc, si je ne me trompe pas, OpenELEC ou Raspbian n'y change rien.
ainsi, en exemple, si on utilise Audacious pour lire les fichiers musicaux, il est possible de déterminer que le signal utilisera une carte interne/externe ou le HDMI.
Openmax (et donc OMXPlayer) ne devrait permettre que de choisir entre l'analogique (via la détestable prise jack 3.5) ou le HDMI.
il est toutefois possible de brancher un DAC sur la sortie Toslink de votre téléviseur (attention aux signaux multicanaux)

nikotinux
Posts: 766
Joined: Sat Feb 02, 2013 2:11 am

Re: Qualité son Jack 3.5 mauvaise?

Wed Feb 13, 2013 7:59 pm

je donne la procédure de tête pour activer le stick USB Audio sur raspBMC

- dans Programmes, ouvrir RaspBMC Settings
- aller dans l'onglet System Configuration
- activer Audio engine enabled
- valider, une fenêtre s'ouvre demandant la confirmation, valider encore.
le système doit redémarrer.

-dans Système, paramètres
- aller dans l'onglet Sortie Audio
- selectionner la sortie analogique bien sur ...
- des options supplémentaires doivent apparaître et en particulier Périphérique
- sélectionner la carte USB
enjoy !

chez moi le stick, avec lsusb, s'appelle Planet UP-100 Genius G-talk et c'est ce nom de periph que je sélectionne.
Vous pouvez faire joujou avec les autres paramètres ...

User avatar
fdion
Posts: 307
Joined: Sun Sep 16, 2012 2:33 pm
Location: North Carolina, USA
Contact: Website

Re: Qualité son Jack 3.5 mauvaise?

Thu Feb 14, 2013 3:29 am

Ma solution:

Image

http://raspberry-python.blogspot.com/20 ... rrypi.html

Audio numerique par fibre optique et convertisseur externe

Francois
Francois
http://raspberry-python.blogspot.com - http://www.3dFutureTech.info - @f_dion

ren0
Posts: 90
Joined: Thu Feb 07, 2013 3:57 pm

Re: Qualité son Jack 3.5 mauvaise?

Thu Feb 14, 2013 2:38 pm

possibilités / exemples :

sortie optique via USB : AUREON Dual USB http://www.terratec.net/fr/produkte/AUR ... 12339.html (~20€)

entrée optique (D/A Toslink/RCA) : FiiO TAISHAN-D03K http://www.fiio.com.cn/products/index.a ... =105026003 (~30€) - [pas compatible son multicanal]
compatible multicanal : FiiO D07 http://www.fiio.com.cn/products/index.a ... =105026003 - [souvent avec perte de niveau sonore]

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Qualité son Jack 3.5 mauvaise?

Thu Feb 14, 2013 3:31 pm

Bon ben ce soir je teste RaspBMC...

Je perd rien, toute façon, j'ai cramé la table de partition de ma Xbian...

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Qualité son Jack 3.5 mauvaise?

Fri Feb 15, 2013 8:38 am

Alors j'ai testé RaspBMC avec mon DAC USB hier soir... C'est certes encourageant, mais soyons clair : ça n'est pas utilisable !

- d'abord, une fois activé le module audio, on a des "clicks" à chaque appui de touche, et on ne peut pas les désactiver, c'est usant (je ne supporte pas les bips et clicks incessants).
- on ne peut pas switcher de l'USB vers le HDMI (ou alors je n'ai pas pigé comment).
- et enfin, mais ça ne vient peut être que de mon DAC, le son est pourri, y a des "craquements" sans arrêt (le même genre de son qu'on obtiens quand le débit est trop faible). Je pense, pour ce dernier cas, que c'est lié à une mauvaise gestion de certains taux d'échantillonnage par mon DAC, et comme on peut pas ré-échantillonner, ça semble compromis...

M'enfin, RaspBMC prouve que c'est possible, et ça c'est cool !

Return to “Français”