bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

LXDE no taskbar with raspbain

Fri Nov 16, 2012 9:35 pm

I have the 2012-10-28 raspbian stock install and there is no taskbar on the lxde desktop.

Is there supposed to be one?

If yes, any idea how to make it show?

I assumed there was supposed to be one and have modified my config.txt to make a smaller screen resolution and tried the overscan setting for the bottom edge, both positive numbers and negative numbers and nothing makes a taskbar show up.

I see the icons on the desktop just fine and the RPi logo background.

I have clicked all along the bottom edge etc and there just doesn't seem to be a taskbar there.

Any insights?

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: LXDE no taskbar with raspbain

Sat Nov 17, 2012 9:23 pm

No one is even sure if there is supposed to be a task bar at the bottom of the screen on Raspbian with the default install?

Cloudcentric
Posts: 982
Joined: Fri Sep 14, 2012 9:13 am

Re: LXDE no taskbar with raspbain

Sat Nov 17, 2012 11:45 pm

bgirardot wrote:No one is even sure if there is supposed to be a task bar at the bottom of the screen on Raspbian with the default install?
Yes there is a bottom bar http://debianarmpi.blogspot.co.uk

...are you sure the screen resolution is correct ?
I know everything about nothing"

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: LXDE no taskbar with raspbain

Sun Nov 18, 2012 2:44 am

I am not 100% sure about the screen resolution, but having tried a few, I think I see the whole screen. I left it default and have made it smaller and the screen seems to be the full screen. Everything looks to be onscreen, the logo is nice and centered, the icons along the left all show and wrap appropriately if I make the screen resolution smaller.

Not sure what is up. I have two 10-28-2012 installs and neither one have a task bar.

Pantarhei
Posts: 4
Joined: Mon Sep 17, 2012 8:55 pm
Location: The Netherlands

Re: LXDE no taskbar with raspbain

Sun Nov 18, 2012 10:36 am

I had the same issue, the task bar not showing up. This happened when the first boot of the RasPi with the new firmware was "headless". When the first boot was with attached monitor and keyboard the task bar did show up. You have to install "wheezy" again and then boot with monitor and keyboard attached.

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: LXDE no taskbar with raspbain

Sun Nov 18, 2012 1:24 pm

Pantarhei wrote:I had the same issue, the task bar not showing up. This happened when the first boot of the RasPi with the new firmware was "headless". When the first boot was with attached monitor and keyboard the task bar did show up. You have to install "wheezy" again and then boot with monitor and keyboard attached.
Oh interesting, I do all my installs headless. I will try out as you suggested.

Thank you both very much for the help.

risidoro
Posts: 1
Joined: Tue Sep 11, 2012 12:00 pm

Re: LXDE no taskbar with raspbain

Mon Nov 19, 2012 12:51 pm

Hi,
I had a similar problem some time ago and solved by removing files in ~/.config/lxpanel/ (backup them first if you want).

Hope this helps.

Bye

bgirardot
Posts: 517
Joined: Wed Oct 10, 2012 6:20 am
Location: Switzerland

Re: LXDE no taskbar with raspbain

Tue Nov 20, 2012 1:06 am

Just a follow up. This is definitely because I do my set ups headless. If I do the set up and config with a monitor attached, everything works fine.

Just removing the directory ~/.config/lxpanel/ does not fix the problem until you actually connect it to a monitor, doing it headless and then using X forwarding to run the GUI doesn't get it fixed. The problem for me is, nothing ever gets put in that directory if you didn't have a monitor connected and type startx.

You can fix it manually by copying everything from the default lxpanel config to your local user's lxpanel config directory:

cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/

Then it will work again no matter how you access the LXDE gui

I submitted this as a bug to the raspbian repository on github

Ettore_M
Posts: 26
Joined: Sun Apr 08, 2012 10:48 am

Re: LXDE no taskbar with raspbain

Tue Nov 26, 2013 4:26 pm

bgirardot wrote:Just a follow up. This is definitely because I do my set ups headless. If I do the set up and config with a monitor attached, everything works fine.

Just removing the directory ~/.config/lxpanel/ does not fix the problem until you actually connect it to a monitor, doing it headless and then using X forwarding to run the GUI doesn't get it fixed. The problem for me is, nothing ever gets put in that directory if you didn't have a monitor connected and type startx.

You can fix it manually by copying everything from the default lxpanel config to your local user's lxpanel config directory:

cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/

Then it will work again no matter how you access the LXDE gui

I submitted this as a bug to the raspbian repository on github
bgirardot, thank you very very much, my friend! You were the only one with an answer and a solution to this problem. I, too, run my RPi headless to a direct connection to my laptop using VNC. And every time, I had this problem which frustrated me a lot! Sometimes, I got to work, by true luck though. But most times I had no taskbar. Now, I have thanks to you! :)

Thanks a lot again!

Hector

cyborg5
Posts: 3
Joined: Tue Apr 30, 2013 6:16 pm

Re: LXDE no taskbar with raspbain

Thu Jan 02, 2014 7:01 pm

by bgirardot » Tue Nov 20, 2012 1:06 am
You can fix it manually by copying everything from the default lxpanel config to your local user's lxpanel config directory:
cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/
I typed that exact command and now when I type "lxsession" it says "no such file or directory".

Like an idiot I didn't back up what was in that folder before I did the copy. Any suggestions on what to try now?

User avatar
auto
Posts: 1
Joined: Mon Jul 27, 2015 10:22 am

Re: LXDE no taskbar with raspbain

Mon Jul 27, 2015 10:24 am

You can fix it manually by copying everything from the default lxpanel config to your local user's lxpanel config directory:

cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/

Then it will work again no matter how you access the LXDE gui
Thanks!!! Works like a charm. #KILLERTIP

Orbital6
Posts: 138
Joined: Sat Aug 08, 2015 6:32 pm

Re: LXDE no taskbar with raspbain

Mon Jan 25, 2016 2:10 pm

bgirardot wrote:Just a follow up. This is definitely because I do my set ups headless. If I do the set up and config with a monitor attached, everything works fine.

Just removing the directory ~/.config/lxpanel/ does not fix the problem until you actually connect it to a monitor, doing it headless and then using X forwarding to run the GUI doesn't get it fixed. The problem for me is, nothing ever gets put in that directory if you didn't have a monitor connected and type startx.

You can fix it manually by copying everything from the default lxpanel config to your local user's lxpanel config directory:

cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/

Then it will work again no matter how you access the LXDE gui

I submitted this as a bug to the raspbian repository on github
thank you, this worked for me too!

m00rush
Posts: 3
Joined: Fri Jan 05, 2018 8:42 pm

Re: LXDE no taskbar with raspbain

Fri Jan 12, 2018 12:26 pm

I had the same issue, but in my case:

Code: Select all

cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/
did't help me and lxpanel had no taskbar after reboot. Perhaps because there are 2 directories:
../LXDE/..
../LXDE-pi/..


I started lxterminal by pressing Alt+F2 and reinstalled lxpanel:

Code: Select all

sudo apt-get remove lxpanel
sudo apt-get install lxpanel
Taskbar has appeared again after reboot, but x interface looks differ from the first Jessy install. But it works.
Any suggestions how to force back to default lxpanel view are appreciated.

m00rush
Posts: 3
Joined: Fri Jan 05, 2018 8:42 pm

Re: LXDE no taskbar with raspbain

Fri Jan 12, 2018 11:46 pm

There are 2 ways how to force back to default lxpanels settings:
Ideas by Joe Schmoe & madtom1999 (thank you guys): viewtopic.php?t=104956

1. Copy existing settings from another working machine:

Code: Select all

~/.config/lxpanel/LXDE-pi/panels/panel
Then re-start the GUI. Icons are back.

2. If you don't have another working machine, then do this:
Create temp user and fill in details as required

Code: Select all

sudo adduser temp
Log in as temp and go into LXDE desktop& It creates the default panels file. You may need to

Code: Select all

sudo raspi-config 
so you can login as temp
Login to your normal user (pi) and copy the new one settings over

Code: Select all

sudo cp /home/temp/.config/lxpanel/LXDE-pi/panels/panel ~/.config/lxpanel/LXDE-pi/panels/panel
Set yourself as owner of the file:

Code: Select all

sudo chown pi ~/.config/lxpanel/LXDE-pi/panels/panel
2.5 Delete temporary user:

Code: Select all

sudo deluser temp

fmk2
Posts: 1
Joined: Fri Apr 27, 2018 9:46 pm

Re: LXDE no taskbar with raspbain

Fri Apr 27, 2018 9:50 pm

Ettore_M wrote:
Tue Nov 26, 2013 4:26 pm
bgirardot wrote:...You can fix it manually by copying everything from the default lxpanel config to your local user's lxpanel config directory:

cp -rp /etc/xdg/lxpanel/profile/LXDE/* ~/.config/lxpanel/LXDE/

Then it will work again no matter how you access the LXDE gui...
I've been searching for an answer to this problem for several days, and your suggestion is the only thing that has worked.

Thanks very much!

Frank

Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 31 guests