User avatar
wallarug
Posts: 459
Joined: Mon May 14, 2012 8:21 am
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 7:04 am

kavi96 wrote:
kavi96 wrote:I can't work out how to set a static ip address for wlan0 after using the gui wifi setup. My /etc/network/interfaces looks like this:

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
I tried changing it to

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet static
address 192.168.0.200
netmask 255.255.255.0
gateway 192.168.0.1
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
But when I did that it wouldn't connect. What should I change to get a static ip?
Any ideas on how to get this working?
You seem to be missing the wireless Access point ssid and the password.

add:

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet static
address 192.168.0.200
netmask 255.255.255.0
gateway 192.168.0.1
wpa-ssid "<name of wireless network>"
wpa-psk "<password of wireless network>"
# wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
# iface default inet dhcp
Hash the last two statements if you are adding networks manually. They are only for the gui wireless facility.

This should work if your network is wpa/wpa2 security. If it is not, let me know and I will find a solution.
RPi Hardware Guide

App Store: https://itunes.apple.com/us/app/rpi-hardware-guide/id723108328?ls=1&mt=8
Play Store: https://play.google.com/store/apps/details?id=org.cmdenterprises.rpihardwareguide

http://www.youtube.com/user/CMDenterprises

User avatar
mister_wavey
Posts: 98
Joined: Sun Sep 02, 2012 8:23 am
Location: Abergavenny, Wales, UK
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 9:31 am

the static address for wlan0 config above worked perfectly for me - thx!

User avatar
wallarug
Posts: 459
Joined: Mon May 14, 2012 8:21 am
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 10:13 am

mister_wavey wrote:the static address for wlan0 config above worked perfectly for me - thx!
Glad I could help! :D :D :D :D
RPi Hardware Guide

App Store: https://itunes.apple.com/us/app/rpi-hardware-guide/id723108328?ls=1&mt=8
Play Store: https://play.google.com/store/apps/details?id=org.cmdenterprises.rpihardwareguide

http://www.youtube.com/user/CMDenterprises

nummy
Posts: 35
Joined: Tue Aug 14, 2012 12:07 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 2:07 pm

milhouse wrote:Has anyone had any luck running Quake3 with overclocked settings using the latest firmware? Any setting other than stock (ie. no overclock/powersave governor) seems to cause a reboot as soon as I begin a map (the game starts OK, I can choose options etc. but just as it's loaded all the assets, it reboots).

I've got a decent 2A power supply (from an HP/Palm Touchpad) and last time I tested TP1/TP2 I had no power issues.

I've tried two pre-built Quake3 binaries, plus one I built myself compiled on this latest 2012-09-18 Raspbian, with ARM/Core/SDRam/Over-voltage settings of 1000/500/450/6 without any problem in 41 minutes (SDRam @ 500 would cause a panic during boot, as soon as the governor switched to ondemand). Max temp at 1000Mhz was 60C.

At the moment I've got the following settings at the end of config.txt, and Quake3 *still* causes a reboot:

Code: Select all

...
#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=800

# for more options see http://elinux.org/RPi_config.txt
#core_freq=300
#sdram_freq=300
over_voltage=6
That's a pretty rubbish overclock... so I'm hoping something else is wrong! :)
I have had the same problems, I even tried compiling Quake 3 by myself and it compiled fine, but I couldn't get it to run without crashing at 1000MHz & 950MHz (overvolt 6). As soon as it loads the map and starts the game, a few seconds later it reboots ... at 900MHz setting in raspi-config (overvolt 2) it runs fine though for hours ... seems like it's an overvoltage thing.

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 9:32 pm

Just lost an image...

I had it on Medium... and it was working very well. this morning I went to load git and I got some weird package errors. Tried to clean them up but they kept getting worse. Finally did a reboot and it never came back.

Expanding a new image now (again), but most likely will stick with normal clocking which is still faster than the previous versions until something gets worked out. Too much time setting up all over. My backup was unrestorable because I did the normal raspi-config expand and it won't fit....
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

milhouse
Posts: 613
Joined: Mon Jan 16, 2012 12:59 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 9:36 pm

nummy wrote: I have had the same problems, I even tried compiling Quake 3 by myself and it compiled fine, but I couldn't get it to run without crashing at 1000MHz & 950MHz (overvolt 6). As soon as it loads the map and starts the game, a few seconds later it reboots ... at 900MHz setting in raspi-config (overvolt 2) it runs fine though for hours ... seems like it's an overvoltage thing.
Sounds like you're hitting the current limit - enabling the current_limit_override in config.txt should fix it (but will void your warranty). With current_limit_override enabled I'm now stable at 1000/500/500/+6 (also +4 for over_voltage_sdram), and can play Quake3 no problem. Soldered links over the polyfuses on my revision 1 board so the warranty was already toast! :)

iZzy
Posts: 4
Joined: Mon Sep 24, 2012 9:03 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 9:40 pm

Hi. Got no one freezes with this new build ?

i always got after some hours messages @ syslog like this:

Code: Select all

Sep 24 22:52:18 rpi kernel: [15384.756662] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
Sep 24 22:52:18 rpi kernel: [15384.756691] smsc95xx 1-1.1:1.0: eth0: MII is busy in smsc95xx_mdio_read
Sep 24 22:52:25 rpi kernel: [15390.856779] smsc95xx 1-1.1:1.0: eth0: Failed to read register index 0x00000114
with older builds, my pi is working day after day. Any ideas ?

der-don
Posts: 10
Joined: Fri Sep 21, 2012 8:58 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Mon Sep 24, 2012 11:11 pm

Ed Raket wrote:@DevelopNow
@der-don

Great that you guys got things working by re-writing the "config.txt"! Could you check in a day or two if those settings/that file remains intact? (unscrambled)
Just checked it, after 3 days and a handful reboots, the config.txt is still intact.

User avatar
Ed Raket
Posts: 164
Joined: Mon Apr 30, 2012 4:28 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Tue Sep 25, 2012 6:36 am

der-don wrote:
Ed Raket wrote:@DevelopNow
@der-don

Great that you guys got things working by re-writing the "config.txt"! Could you check in a day or two if those settings/that file remains intact? (unscrambled)
Just checked it, after 3 days and a handful reboots, the config.txt is still intact.
That's great! it raises more questions but.. oh well ;)

zores
Posts: 1
Joined: Fri Jun 29, 2012 1:46 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Tue Sep 25, 2012 3:25 pm

rleyden wrote:
mister_wavey wrote:I had this too with python2. I downloaded and installed the RPi.GPIO package manually to fix it. http://pypi.python.org/pypi/RPi.GPIO/#downloads if you want to do the same.
This was very helpful. I'm still confused about whether I'm using python2 or python3 (mentioned in the included install.txt). I tried both. After doing the python3 install, I have progress. I no longer get the "RPi.GPIO not found" error. However, I get a new error "RuntimeWarning: This channel is already in use.". This occurs in my code where the pins are assigned.

Code: Select all

# SPI port on the ADC to the Cobbler
SPICLK = 18
SPIMISO = 23
SPIMOSI = 24
SPICS = 25
# set up the SPI interface pins
GPIO.setup(SPIMOSI, GPIO.OUT)
GPIO.setup(SPIMISO, GPIO.IN)
GPIO.setup(SPICLK, GPIO.OUT)
GPIO.setup(SPICS, GPIO.OUT)
The program ignores the "in use warning" but doesn't see any output.
Do I have to re-assign the pins?
@rleyden: I have the exact same problem. Did you find a solution?

der-don
Posts: 10
Joined: Fri Sep 21, 2012 8:58 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Tue Sep 25, 2012 4:56 pm

Ed Raket wrote:
der-don wrote:
Ed Raket wrote:@DevelopNow
@der-don

Great that you guys got things working by re-writing the "config.txt"! Could you check in a day or two if those settings/that file remains intact? (unscrambled)
Just checked it, after 3 days and a handful reboots, the config.txt is still intact.
That's great! it raises more questions but.. oh well ;)
As I mentioned, when I tried overclocking for the first time, it worked great ! Maybe it's just an issue when changing the Overclocking settings again.

User avatar
rleyden
Posts: 67
Joined: Thu Jun 14, 2012 2:17 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Wed Sep 26, 2012 10:08 pm

rleyden wrote: The program .... doesn't see any output.
Regarding GPIO issues:
One of the jumper wires to my cobbler board had become disconnected. The output is now back to normal. Fixing the Python library seemed essential but with several things going on at once, my comments to this thread should be taken with a grain of salt.

Damn those little wires, it took me 3 days to debug.

NielsMayer
Posts: 13
Joined: Mon Aug 13, 2012 4:25 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Sep 28, 2012 5:32 pm

My feeling is that with the 9/18 raspbian image, anything over the "modest" overclock causes filesystem corruption. Perhaps the first/best thing to do when testing an overclock is a apt-get update && apt-get upgrade. Mine coredumped. Othertimes it would complete successfully but leave /var/lib/dpkg/status corrupted.

My feeling is that the issues occur due to overvolting in the "medium", "high" and "turbo" overclocks. Perhaps there's a glitch caused by switching frequencies and voltages dynamically? The other "gut" is that overclocking core to 500Mhz is problematic, but 450Mhz isn't. And that using ethernet over wifi adapter seems to contribute to corruption at higher core rates. Again these are just gut feelings from several corruptions and reformattings across three 'pi's.

My pi's are heatsinked and I didn't experience corruption w/ modest overclocking w/o overvolting prior to latest updates: http://www.nielsmayer.com/bin/view/Rasp ... sure_clock

I'm running ok at "modest":

Code: Select all

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=800

# for more options see http://elinux.org/RPi_config.txt
core_freq=300
sdram_freq=400
over_voltage=0
On latest rpi-update:

Code: Select all

rpi2-3-~> uname -a
Linux rpi2 3.2.27+ #171 PREEMPT Tue Sep 25 00:08:57 BST 2012 armv6l GNU/Linux
rpi2-4-~> vcgencmd version
Sep 25 2012 00:18:47 
Copyright (c) 2012 Broadcom
version 339137 (release)

grabowski
Posts: 3
Joined: Fri Sep 28, 2012 6:08 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Sep 28, 2012 6:15 pm

aotto2012 wrote:Thanks for all the great work!

Updating with sudo apt-get update && sudo apt-get upgrade works as far as:

Code: Select all

Setting up raspberrypi-bootloader (1.20120918-1) ...
Your current start.elf is the same as arm224_start.elf
Removing 'diversion of /boot/arm128_start.elf to /usr/share/rpikernelhack/arm128_start.elf by rpikernelhack'
This is probably nearly at the end and apt-get upgrade stays there forever, rendering the raspberry pi unresponsive.

Restarting and doing the update and upgrade process again results in:

Code: Select all

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
Yes, sure it was interrupted. Running dpkg works as far as:

Code: Select all

Setting up raspberrypi-bootloader (1.20120918-1) ...
Your current start.elf is the same as arm224_start.elf
Removing 'diversion of /boot/arm128_start.elf to /usr/share/rpikernelhack/arm128_start.elf by rpikernelhack'
How can I fix this apart from installing the image from scratch?
I had the exact same error. I had an external HDD mounted that time. I've removed the HDD, unplugged the Pi from the electricity and plugged it in again. After that I've ran:

Code: Select all

sudo apt-get update && sudo apt-get install raspberrypi* raspi-config
that resulted in:

Code: Select all

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
After running that command however, the install process completed successfully. Do you have a HDD mounted to your Pi?

HDFrank
Posts: 3
Joined: Thu Jul 05, 2012 9:42 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Sep 28, 2012 9:49 pm

Overclocking howto?

I set one of the 5 Overclocking modes in raspi-config, after I choose one, I get the overclocking config settings in /boot/config.txt
Examble Turbo Mode adds to config.txt

# uncomment for
arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=2
after rebooting from the raspi-config / shutdown -r now / reboot -f

raspi comes back with standard 700 MHz

Code: Select all

pi@raspberrypi ~ $ cat /proc/cpuinfo
Processor       : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2708
Revision        : 0002
Serial          : 000000009b69cd41

Code: Select all

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
700000
where is the fault?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5097
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Sep 28, 2012 10:05 pm

HDFrank wrote:where is the fault?
No fault. The frequency is only high when busy.

User avatar
jbeale
Posts: 3263
Joined: Tue Nov 22, 2011 11:51 pm
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Tue Oct 02, 2012 6:07 pm

Given the amount of filesystem corruption people have been seeing, wouldn't it be a good idea for the default install to do some sort of e2fsck check automatically, at least periodically if not at every reboot after a configuration change? I understand that would make bootup slower, but if you have to reimage your entire SD card due to a corrupt FS that would be even more slow, I'd think...?

Synthetic_Darkness
Posts: 30
Joined: Sun Sep 23, 2012 12:22 pm
Location: JHB, South Africa
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Wed Oct 03, 2012 5:13 am

Has anybody tried overclocking using different scenarios? Like I said, unplugging the LAN cable worked for me. Has anyone tried this?

If we all pitched in, we could narrow this issue down. Also I think a new thread regarding that is in order.
http://codefridge.com/ - where cool code comes to chill.

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Wed Oct 03, 2012 5:29 am

Synthetic_Darkness wrote:Has anybody tried overclocking using different scenarios? Like I said, unplugging the LAN cable worked for me. Has anyone tried this?

If we all pitched in, we could narrow this issue down. Also I think a new thread regarding that is in order.
Look here...
http://www.raspberrypi.org/phpBB3/viewt ... =29&t=6201
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

Synthetic_Darkness
Posts: 30
Joined: Sun Sep 23, 2012 12:22 pm
Location: JHB, South Africa
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Wed Oct 03, 2012 5:37 am

Dweeber wrote:
Synthetic_Darkness wrote:Has anybody tried overclocking using different scenarios? Like I said, unplugging the LAN cable worked for me. Has anyone tried this?

If we all pitched in, we could narrow this issue down. Also I think a new thread regarding that is in order.
Look here...
http://www.raspberrypi.org/phpBB3/viewt ... =29&t=6201
Yeah my bad, I meant to say that these issue should be in that forum.
http://codefridge.com/ - where cool code comes to chill.

gakiris
Posts: 2
Joined: Thu Aug 09, 2012 1:02 am

Re: Updating to the 2012-09-18-wheezy-raspbian image

Wed Oct 10, 2012 6:34 pm

ovacikar wrote:Hello,

I have the custom installer version of raspbian, to boot from sdcard and online install on a usb key.

But I am having trouble getting the upgrades and new packages, what am i doing wrong (PS: my apt.sources is the one from RaspbianFAQ) ?


uname -a
Linux rpi 3.2.27+ #165 PREEMPT Thu Sep 20 22:28:17 BST 2012 armv6l GNU/Linux

cat /etc/apt/sources.list
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi


sudo apt-get update && sudo apt-get install raspberrypi* raspi-config
Hit http://archive.raspbian.org wheezy InRelease
Hit http://archive.raspbian.org wheezy/main Sources
Hit http://archive.raspbian.org wheezy/contrib Sources
Hit http://archive.raspbian.org wheezy/non-free Sources
Hit http://archive.raspbian.org wheezy/rpi Sources
Hit http://archive.raspbian.org wheezy/main armhf Packages
Hit http://archive.raspbian.org wheezy/contrib armhf Packages
Hit http://archive.raspbian.org wheezy/non-free armhf Packages
Hit http://archive.raspbian.org wheezy/rpi armhf Packages
Ign http://archive.raspbian.org wheezy/contrib Translation-en_US
Ign http://archive.raspbian.org wheezy/contrib Translation-en
Ign http://archive.raspbian.org wheezy/main Translation-en_US
Ign http://archive.raspbian.org wheezy/main Translation-en
Ign http://archive.raspbian.org wheezy/non-free Translation-en_US
Ign http://archive.raspbian.org wheezy/non-free Translation-en
Ign http://archive.raspbian.org wheezy/rpi Translation-en_US
Ign http://archive.raspbian.org wheezy/rpi Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package raspberrypi*
E: Couldn't find any package by regex 'raspberrypi*'
E: Unable to locate package raspi-config

i am getting the same error. Is there any solution?

ronb
Posts: 9
Joined: Fri Sep 14, 2012 10:07 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Tue Oct 16, 2012 4:37 am

Just updated to the new image (from the 2012-07-15 image). I'm running headless. Had a couple of problems (like I lost ssh enabling) but got past that. I'm a little new with Linux, and I ran into a problem I can't resolve. Don't want to try turbo until I get my system back to the way it was working before the upgrade.

I have a USB hard drive attached and shared on my LAN with samba. In the previous image, this device would automount as "/media/Netstorage" per the disk's label, with one of my logins as the owner. In this image, there is a "/media/NetStorage" owned by root, and a "/media/NetStorage_" owned by my login. The disk is actually mounted in this second directory. The first is inaccessible. I know that the system adds the trailing "_" to the disk's label name if it finds the name there already. The problem is I can't get rid of the directory. I tried umounting the first one but it says it's unmounted. I can't delete the directory either.

I could mod my samba config to use the "_" name, but this seems like a hack, not a real fix.

Did something change with automount? Any ideas how I can fix this?

ronb
Posts: 9
Joined: Fri Sep 14, 2012 10:07 pm

Re: Updating to the 2012-09-18-wheezy-raspbian image

Tue Oct 16, 2012 4:50 pm

ronb wrote: I have a USB hard drive attached and shared on my LAN with samba. In the previous image, this device would automount as "/media/Netstorage" per the disk's label, with one of my logins as the owner. In this image, there is a "/media/NetStorage" owned by root, and a "/media/NetStorage_" owned by my login. The disk is actually mounted in this second directory. The first is inaccessible. I know that the system adds the trailing "_" to the disk's label name if it finds the name there already. The problem is I can't get rid of the directory. I tried umounting the first one but it says it's unmounted. I can't delete the directory either.

Did something change with automount? Any ideas how I can fix this?
Newbie problem, at least in terms of fixing this! chown'ed the directory to my login, then removed it. (Found that an empty subdir was still there; I presume that was why it wasn't automatically removed/reused.) Once I removed the directory and rebooted, the hard drive was automounted correctly to /media/label. Still not sure how it got in this state to begin with, but I'm back in business!

User avatar
wallarug
Posts: 459
Joined: Mon May 14, 2012 8:21 am
Contact: Website

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Jan 25, 2013 12:29 pm

asb wrote:
nommo wrote: Should I be worried about "Error opening '/dev/input/event*': No such file or directory" ??
I guess you're running headless?
Dom,

What is the quick fix for this problem?
RPi Hardware Guide

App Store: https://itunes.apple.com/us/app/rpi-hardware-guide/id723108328?ls=1&mt=8
Play Store: https://play.google.com/store/apps/details?id=org.cmdenterprises.rpihardwareguide

http://www.youtube.com/user/CMDenterprises

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5097
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Updating to the 2012-09-18-wheezy-raspbian image

Fri Jan 25, 2013 3:15 pm

wallarug wrote:
asb wrote:
nommo wrote: Should I be worried about "Error opening '/dev/input/event*': No such file or directory" ??
I guess you're running headless?
Dom,

What is the quick fix for this problem?
I think this comes from the script that disables overclock (ondemand governor) when shift key is held down on boot. If you have no keyboard plugged in there is no /dev/input/event.
The quick fix is to plug in a keyboard or ignore the (harmless) error message.

The less quick fix is to change the script that detects the shift key to handle no keyboard more gracefully.

Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 26 guests