henrig
Posts: 27
Joined: Mon Apr 10, 2017 4:32 pm

[RESOLU]je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Mon May 18, 2020 10:49 am

Bonjour Tous,
Mon RPI 4 me fait des misères au démarrage,
Je n'ai JAMAIS pu le configurer par le HDMI sur une TV malgré toutes les combines trouvé sur le NET, donc je suis passé par un câble RJ45 sur mon routeur,
J'ai créé un fichier ssh et ai donné une adresse libre de mon réseau dans le fichier cmdline.txt comme l'explique plusieurs site web, AINSI j'ai pu démarrer, faire un "raspi-config" et paramétrer ce Raspberry sous JESSY,
Il doit ABSOLUMENT tourner avec le WIFI 8-)
MAIS MAINTENANT je n'arrive plus à me débarrasser de la prise RJ45, et ceci au démarrage uniquement, alors que j'ai paramétrer correctement le WIFI puisqu'ensuite tout fonctionne correctement
IL me faut ABSOLUMENT la RJ45 pour démarrer, et après je peux l'enlever,
Il me semblai logique de me débarrasser du fichier ssh mais je n'en trouve plus trace ! ! !
Je suis plutôt novice avec LINUX, donc je sollicite votre aide et conseils sur ce problème,
merci à tous pour vos conseils à venir,
Henri
Last edited by henrig on Sun May 24, 2020 11:01 am, edited 1 time in total.

epoch1970
Posts: 5022
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Mon May 18, 2020 12:20 pm

Pi 4 c'est Raspbian Buster.
Du temps de Jessie il n'était pas né.

En suivant une documentation à jour, le "problème" devrait disparaître.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

henrig
Posts: 27
Joined: Mon Apr 10, 2017 4:32 pm

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Mon May 18, 2020 3:38 pm

Désactiver le SSH dans le panneau de config suffirai-il ?
Par précaution je vais tout de même faire une sauvegarde de ce qui fonctionne(sait-on jamais par ces temps d'épidermes, et puis les emmerdes volent toujours en escadrilles selon Jaques Chirac)
Henri

henrig
Posts: 27
Joined: Mon Apr 10, 2017 4:32 pm

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Mon May 18, 2020 7:15 pm

Désactiver le SSH dans le panneau de config suffirai-il ?
BIN NON : ceci ne fonctionne pas.

Truc étrange : Je mets le RPI sous tension, je branche le câble RJ45, j'attends quelques secondes de voir apparaitre ce RPI sur mon réseau, dés que son IP apparait je peux débrancher le RJ45 et me connecter en WIFI :roll: :roll: :roll:
BOF y mieux comme truc non !
Henri


henrig
Posts: 27
Joined: Mon Apr 10, 2017 4:32 pm

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Mon May 18, 2020 8:24 pm

Je n'en ai qu'une :oops:
IL doit y avoir un autre moyen moins couteux :roll:

totoharibo
Posts: 4436
Joined: Thu Jan 24, 2013 8:43 am

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Tue May 19, 2020 6:57 am

changer la définition de la TV dans raspi-config

henrig
Posts: 27
Joined: Mon Apr 10, 2017 4:32 pm

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Tue May 19, 2020 8:35 am

Ok mais l'écran est noir, je n'ai pas accès à quoi que ce soit ;)
Je ne vois jamais raspi-config.
Henri

totoharibo
Posts: 4436
Joined: Thu Jan 24, 2013 8:43 am

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Tue May 19, 2020 7:34 pm

en ssh tu vois raspi-config en console (avec sudo) :

tu peux refaire la définition du Wifi -> network options
et la résolution : ->advanced options -> resolution

et un reboot ensuite.

le fichier ssh n'existe que pour la première connexion par l'extérieur. Il est effacé ensuitea par sécurité.

mike913
Posts: 54
Joined: Thu Dec 19, 2019 6:38 am
Location: Essonne FRANCE
Contact: Website

Re: je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer

Wed May 20, 2020 6:19 am

Bonjour,

Je ne connaissais pas l'astuce que tu cites pour avoir une ip fixe au démarrage. Mais cette astuce attribue l'adresse IP à l'interface eth0 et pas à wlan0. Une question est-ce que tu as renseigné le fichier wpa_supplicant.conf. en lui indiquant le SSID et la passphrase.
Plutôt que de modifier le fichier cmdline.txt je te conseille de créer un fichier wpa_supplicant.conf sur la carte SD (avec le fichier ssh) avec les lignes suivantes:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FR

network={
	ssid="Nom de ton reseau"
	psk="PassPhrase"
}
ensuite tu démarres ton PI et sur la box tu cherches l'adresse ip qui lui a été attribué.
et tu te connectes en SSH

henrig
Posts: 27
Joined: Mon Apr 10, 2017 4:32 pm

RESOLU

Wed May 20, 2020 9:58 am

Bonjour,

Je suis sorti de ce mauvais pas en décommentant une ligne dans le fichier config.txt

Code: Select all

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1
Une fois cette ligne dé-commenter, j'ai pu accéder à mon écran TV.
Je n'ai malheureusement plus le lien www de cette info, un site en Anglais

Merci à tous,
Henri

Return to “Français”