Bosse_B
Posts: 1121
Joined: Thu Jan 30, 2014 9:53 am

How to disable terminal screen blanking on non-GUI system?

Mon Apr 06, 2020 6:26 am

I am hoping someone here can help me after I have looked for a solution for hours without success...

How can one permanently disable the console screen saver on a server only (no GUI installed) system?

I have hit this "saver" on an Ubuntu 16 server installation, which kicked in during the lengthy process of upgrading from 16 to 18 and it left me totally blind concerning the upgrade process. No idea what was going on...

I don't know if a monitor/keyboard screen saver is also used on Raspbian since I access my numerous RPi boxes almost exclusively via PuTTY and this seems to be void of such blanking.

But if I would connect a monitor/keyboard to the RPi it might behave like my Ubuntu server and I would like to disable it.

AFAIK both Raspbian and Ubuntu are Debian based so the same method might work on both.
But as I said I have not yet found that method.
It is most important to solve on my Ubuntu server...
Bo Berglund
Sweden

fruitoftheloom
Posts: 26506
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: How to disable terminal screen blanking on non-GUI system?

Mon Apr 06, 2020 7:22 am

Bosse_B wrote:
Mon Apr 06, 2020 6:26 am
I am hoping someone here can help me after I have looked for a solution for hours without success...

How can one permanently disable the console screen saver on a server only (no GUI installed) system?

I have hit this "saver" on an Ubuntu 16 server installation, which kicked in during the lengthy process of upgrading from 16 to 18 and it left me totally blind concerning the upgrade process. No idea what was going on...

I don't know if a monitor/keyboard screen saver is also used on Raspbian since I access my numerous RPi boxes almost exclusively via PuTTY and this seems to be void of such blanking.

But if I would connect a monitor/keyboard to the RPi it might behave like my Ubuntu server and I would like to disable it.

AFAIK both Raspbian and Ubuntu are Debian based so the same method might work on both.
But as I said I have not yet found that method.
It is most important to solve on my Ubuntu server...

https://www.raspberrypi.org/documentati ... ensaver.md
The information is out there....you just have to let it in.

My other Linux machines: ChromeBox
https://www.aliexpress.com/item/32966393971.html
& Stone Desktop Intel CoreDuo circa 2010

Bosse_B
Posts: 1121
Joined: Thu Jan 30, 2014 9:53 am

Re: How to disable terminal screen blanking on non-GUI system?

Mon Apr 06, 2020 8:44 am

Thanks,
I have read it and used further links and also googled "consoleblank"....

But I have an issue here in that I suspect that most discussions are on how to enable the blanking or display shutdown which is the complete opposite of what I want.

Also it seems as if the consoleblank parameter controls the dimming of the display rather than the shutoff of it.
So I don't know how to set it to make the display remain fully working indefinitely.
This happens:

Code: Select all

cat /sys/module/kernel/parameters/consoleblank
0
on both RPi4 with Raspbian Buster and Ubuntu server 18.04 LTS on a desktop PC.
According to the linked doc this is the timeout value for blanking in seconds with 0 indicating that the function is OFF.
But when I read the /boot/config.txt file the parameter line consoleblank=0 is missing and yet the above command returns the value 0.
How come?
And does this indicate that I need do no further to have my display always on for both the Raspbian and Ubuntu systems?
Bo Berglund
Sweden

Return to “General discussion”