SQLScott
Posts: 2
Joined: Mon Aug 03, 2015 4:52 pm

Idle3 command not found: Terminal to Pi3

Fri Feb 14, 2020 11:21 pm

I am using PuTTY to terminal into my Pi3. I want to create and push some Python to it using IDLE. I am running Python 2.7.13. In my terminal, I executed the following to create a file on the Pi:

touch gpio_led.py

This command worked. I now want to open the file:

idle3 gpio_led.py

This does not work, returning the error: Idle3 command not found (see attached screenshot). I am simply following the instructions in the tutorial i am going through but have hit a wall at this point. What am I missing?

Thank you in advance for any help.

Scott
Attachments
Screenshot_1.png
Screenshot_1.png (35.14 KiB) Viewed 172 times

klricks
Posts: 6860
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Idle3 command not found: Terminal to Pi3

Sat Feb 15, 2020 1:34 am

Idle3 is no longer installed by default.

Code: Select all

sudo apt install idle3
Then run from the local Desktop keyboard and screen not ssh.

Code: Select all

idle gpio_led.py
Note idle3 is for Python 3 code. You mentioned Python 2. Python 2 will go EOL soon.

idle is a GUI program so it can't be easily run via SSH.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

SQLScott
Posts: 2
Joined: Mon Aug 03, 2015 4:52 pm

Re: Idle3 command not found: Terminal to Pi3

Mon Feb 17, 2020 8:00 pm

Thanks klricks. Per your feedback, I installed idle3 (which succeeded), and then tried to execute the second command. I got a different error (see attached screenshot). I tried both on the local desktop/keyboard as well as via terminal, and got the same error on both.
Attachments
Screenshot_2.png
Screenshot_2.png (54.56 KiB) Viewed 116 times

User avatar
B.Goode
Posts: 9627
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Idle3 command not found: Terminal to Pi3

Mon Feb 17, 2020 11:09 pm

As the man said:
idle is a GUI program so it can't be easily run via SSH.



Guessing you are accessing your RPi remotely via PuTTY on a Windows system?

You need an X-windows server (such as XMing) running under Windows, and you need to configure PuTTY to use X-windows forwarding.



Alternatively, enable the provided RealVNC server on Raspbian using the raspi-config utility, and install the RealVNC client under Windows.
Ref: https://www.raspberrypi.org/documentati ... /README.md

Return to “Beginners”