haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Gentoo Demouser password

Thu Dec 26, 2019 9:49 am

Hello

What is the demouser password? I was seeing before "raspberrypi64" but it doesn t accept? When screen lock (Ctrl alt del vs) i cant reach desktop.

Thanks

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Thu Dec 26, 2019 4:39 pm

Unless you have changed it, "raspberrypi64" is the default password for the demouser account, and should unlock the X screensaver (I have just tried this, and it works on my setup).
Make sure you the correct keyboard locale defaults set for X.

hth, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Fri Dec 27, 2019 9:17 am

Hi Sakaki

Unfortunatelly it doesn t accept password. (Authentication failed) I changed password.2 -3 time And it changed correctly. Where i know because it asked before pass. And accept it. But x screen window doesnot accept. Is there way to see ****


Thank you

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Thu Jan 02, 2020 12:50 pm

Hi - apologies for the delay in responding, I have been travelling over the holiday period.

Have a look at the file /etc/X11/xorg.conf.d/00-keyboard.conf, and ensure that the XkbLayout listed there is appropriate for your locale / keyboard, as listed by issuing "man xkeyboard-config" (look in the "LAYOUTS" section).

If you need to change the layout code, reboot once done.

hth, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Fri Jan 03, 2020 6:19 am

Hi Sakaki

No problem.Thank you for your reply. I have seen which you mention

Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "gb"
EndSection

It is gb but when i see Application -- Settings -- Keyboard -Layout is seeting up Turkish

It should be change?

Regards

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Fri Jan 03, 2020 11:46 am

Yes, you should change /etc/X11/xorg.conf.d/00-keyboard.conf so it reads (for a standard Turkish setup):

Code: Select all

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "tr"
EndSection
and restart. Hopefully the screenlock will work then.

Which reminds me: I need to add a localectl-like utility, to ensure the keyboard layout gets sets uniformly in the various required locations, without manual editing like this...

hth, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Sun Jan 05, 2020 11:47 am

Hi Sakaki

I changed it tr like you mention (first i did not know how i can change then it is exacly same like rasbian with sudo nano So i did it). Then i reboot it and test it unfortunatell not accept it Authantication failed

On command line when i enter passwd
Changing password for demouser.
Current password: ......... (It accept it on command line)
New password : I try 123456 not accepted. i try to very simple (only english charecters and it is ok passwrod chanced. But when screen lock it didnot

Regards

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Mon Jan 06, 2020 1:25 pm

OK, this is quite strange. I have tried this extensively here and it all seems to work OK.

It is possible that different keyboard scan code mappings are being used depending on the app (particularly if you also have a keyboard layout set in XFCE4 separately to the one /etc/X11/xorg.conf.d/00-keyboard.conf).

To check, try using a (long) string of numbers only in the password; as these share the same scan codes between UK, Turkish-F and Turkish-Q keyboards.

For example, just as a test, try 5449000053879:

Code: Select all

demouser@pi64 ~$ passwd
Changing password for demouser.
Current password: <type current password and press Enter>
New password: <type 5449000053879 and press Enter>
Retype new password: <type 5449000053879 and press Enter>
passwd: password updated successfully
(Incidentally, this number is the UPC used on cans of Diet Coke in the UK, so only use it as a test!)

Then try activating the screenlock. Use the password 5449000053879 when prompted. Does this unlock OK?

best, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Tue Jan 07, 2020 11:17 am

Hi Sakaki

No it doesnot unlock screen/
I did
demouser@pi64 ~$ passwd
Changing password for demouser.
Current password: <type current password and press Enter>
New password: <type 5449000053879 and press Enter>
Retype new password: <type 5449000053879 and press Enter>
passwd: password updated successfully

Then i lock screen when enter 5449000053879 Authentication failed again/

Also after change tr /etc/X11/xorg.conf.d/00-keyboard.conf now keboard turkish characters not working/ i check keyboard/conf is setting up tr and applications\setting\ keybard set tr . Before turkish characters working correctly now not working

best
Hakan

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Tue Jan 07, 2020 11:41 am

OK, so what do you have when you go to Applications -> Settings -> Keyboard, Layout tab?

Do you have "Use system defaults" unchecked?
Do you have multiple entries in the Keyboard layout list?

Best, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Tue Jan 07, 2020 12:37 pm

It 's unchecked sytem defaults
Keyboard model Generic 105 key Pc Intr
Change layout option none
Compose key none
on keyboard layout only turkish

best

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Tue Jan 07, 2020 12:52 pm

OK so try:

Code: Select all

demouser@pi64 ~ $ sudo emerge -v xfce-extra/xfce4-xkb-plugin
Once this has completed, right-click in an empty part of the top (grey) panel bar, and select Panel -> Add New Items... from the drop-down.
Then click on the "Keyboard Layouts" entry (you may have to scroll through the list to find it) and click the Add button.
You should now see a flag (hopefully, a Turkish flag!) on your panel bar. Right-click on this and choose Properties from the drop-down.
Under "Behavior" choose Manage layout: "globally" (from the menu there) and then click Close.

Does your keyboard work now in e.g. a terminal?
If you change the password, does the lock screen work now?

Best, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Tue Jan 07, 2020 12:58 pm

Code: Select all

demouser@pi64 ~ $ sudo emerge -v xfce-extra/xfce4-xkb-plugin

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "xfce-extra/xfce4-xkb-plugin" have been masked.
!!! One of the following masked packages is required to complete your request:
- xfce-extra/xfce4-xkb-plugin-0.8.1::gentoo (masked by: missing keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
H'i Sakaki
I received this error to download What i have to do

Regards

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Tue Jan 07, 2020 5:53 pm

Oops, sorry about that. Try:

Code: Select all

demouser@pi64 ~ $ sudo emaint sync --repo genpi64
demouser@pi64 ~ $ sudo emerge -v xfce-extra/xfce4-xkb-plugin
Best, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Tue Jan 07, 2020 6:34 pm

Hi Sakaki

I did it. Its downloaded and add Keyboard panel i saw Turkish flag and i right click and set up behavior globally. And check Turkish characters still not working .

Regards

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Tue Jan 07, 2020 6:48 pm

Hi Sakaki

I added Applications -Setting - Keyboard Language English keyboard and delete Turkısh Then i added Turkish again and delete English now characters working good on Turkish Q Keyboard(logitech k400 wireless)

now can i try lock screen ( asking becasue when screen lock i had to hard reset to reach again)

Thanks

hakan

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Tue Jan 07, 2020 6:51 pm

Yes, please try lock again. Hopefully it will work now. I tested today with several non-UK keyboard layouts (French, German) and it worked this end.
Best, sakaki
PS you may want to change your password first (with passwd) to ensure it is set correctly, now you know the keyboard is working OK.

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Wed Jan 08, 2020 9:16 am

Hi Sakaki

Unfortunatelly not working. Same as before Authentication failed again. on command line passwd accept always passwords. It still this password =
5449000053879 . Also Turkish characters gone after restart. So i did again English remove Turkish than add Turkish remove English i,t work again. But when restart it gone? Is it possible to fit?

Thanks, Hakan

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Wed Jan 08, 2020 5:14 pm

Very strange. The keyboard layouts you setup should be saved in ~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml, and so be persistent.
Are you using the demouser account or your own? Once you have the kbd set up, did you (at least once) use Demo User -> Log Out..., "Shutdown" button (with the "Save session for future logins" checked)?

Best, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Thu Jan 09, 2020 9:57 am

Hi Sakaki

Keyboard settings gone afrer restart. It seems persistent i mean it shows Turkish on keyboard layout. but in reel not working. It shows Turkish but setting up English keyboard
Yes I am using default not changed Demouser. Yest it selected and i did not touch save session checked

Thanks

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Thu Jan 09, 2020 2:36 pm

Hi Sakaki


I realized something new when i click Demo User on screen there are Lock Screen ( doesn't accept pasword) But also Log out it accept 5449000053879 pasword. I accidentally came there. then i tested again it accept that pasword. So it working different with lock screen? Also when i click Log out there blue gentoo linux lihgtdm i saw en-GB.utf8 on top righ corner. But main gentoo has Turkish flag over there.

Thanks

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Thu Jan 09, 2020 9:52 pm

Hi,

so I have tried this, several times, on a v1.5.3 image and the keyboard layouts appear to be remembered across reboots OK, and the globally selected layout seems to be used on the X screensaver (lock) also. So something must be different at your end.

Can you please post a screenshot similar to the below for your system?

Image

Thanks, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Fri Jan 10, 2020 6:20 am

Hi Sakaki


you can link from here

https://ibb.co/nbC5qnn

Thanks

User avatar
sakaki
Posts: 551
Joined: Sun Jul 16, 2017 1:11 pm

Re: Gentoo Demouser password

Sat Jan 11, 2020 2:34 pm

Hi Hakan,

well that looks OK, but the reported behaviour (wrt X screensaver, persistence of layouts across reboots etc.) does not match what I am seeing here.

Are you working from a fresh v1.5.3 copy of the image, or is this one that has been upgraded from e.g. 1.5.2 or earlier?

What does your file /home/demouser/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml look like after you have added the Turkish layout, but before reboot? And what does the same file look like after reboot?

Did you change any other keyboard-related config files on your system?

Lastly, to help rule out other issues, it might be worth trying this from a fresh v1.5.3 image on a spare microSD card, where the only thing you change is to do:

Code: Select all

demouser@pi64 ~ $ sudo emaint sync --repo genpi64
demouser@pi64 ~ $ sudo emerge -v xfce-extra/xfce4-xkb-plugin
and install the plugin into the top panel (as before), and setup Applications -> Settings -> Keyboard, Layout to have your required Turkish layout as the top entry.

best, sakaki

haaldemir
Posts: 59
Joined: Mon Jul 08, 2019 2:46 pm
Location: Istanbul, Turkey

Re: Gentoo Demouser password

Sat Jan 11, 2020 3:38 pm

Hi Sakaki

Its from 1.5.2 .I have installed with Pinn together with rasbian and librelec 64 gb sd card/ I have upgraded after your post on Gentoo.

I installed again Keyboard Turkish. Turkish charcaters working. Then Keyboard-layout.xml looks like;

Code: Select all

<channel name="keyboard-layout" version="1.0">
<property name="Default" type="empty">
<property name="XkbDisable" type="bool" value="false"/>
<property name="XkbLayout" type="string" value="tr"/>
<property name="XkbVariant" type="string" value=""/>
<property name="XkbModel" type="string" value="pc105"/>
</property>
</channel>
After reboot without touch keyboard-layout. Turkish characters not working ;

Code: Select all

<channel name="keyboard-layout" version="1.0">
<property name="Default" type="empty">
<property name="XkbDisable" type="bool" value="false"/>
<property name="XkbLayout" type="string" value="tr"/>
<property name="XkbVariant" type="string" value=""/>
<property name="XkbModel" type="string" value="pc105"/>
</property>
</channel>

No. I didnot anything myself. Only after your offer *for example add tr somefile...

I will install ony gentoo. 1.5.3 another card and instali and test it and share with yoou after..

thanks

Return to “Gentoo”