RDPUser
Posts: 152
Joined: Tue Jan 30, 2018 12:18 pm

PI Zero W: SSH Login hangs after password [solved]

Sun Dec 29, 2019 11:46 am

I have a PI Zero W, last update was from Juli 2019. A few days ago I did apt update and apt upgrade and rebootet. I've logged in and everyting seemed to work fine.
Now today I wanted to connect again. I instantly get the login prompt via putty. But after entering the password it hangs. Sometimes I see the shell welcome screen, sometimes it disconnects before. It is not a network connectivity issue. Ping is stable at about 6ms. There is a nginx Webserver running. Downloading from there gets 3 MB/s (about 24 MBit/s).
About an hour ago I manged to login. I've rebooted. Still no login. I've pulled power plug for about 10 seconds. Pi Zero W reboots instantly. But still no working login via ssh.
It is a headless PI without monitor or keyboard. I'm confident that I manage to login sometime. So if I'm in what can I do to prevent this problem?

UPDATE: Sorry for bothering. Very strange. I've rebooted the Wifi-AP and now it seems to work as expected. Very strange problem since all other network connectivity was still given. I'll leave this post for reference if somebody has this same strange behaviour.

Return to “Troubleshooting”