SpaceMaker
Posts: 5
Joined: Sat Sep 14, 2019 9:23 pm

Raspberry pi 4 won't boot start*.elf not found

Mon Oct 07, 2019 6:18 pm

hi,

i wanted to try the raspberry pi 4 to get more speeds in things. after my first installation with a 16 GB micro sd card it worked like it should be.
because it worked i wanted to instantly upgrade it to a 32GB sd card. After installing raspbian it didnt work, not even with the 16 anymore. i tried looking up what coused this problem and how to fix it. After reading some forums i saw that the 32gb didnt work on the pi. i was shocked. and some more reading i thought it was the EEPROM was corupted. so i got a small 2GB sd card. extracted the files pieeprom.bin and recovery.bin.
inserded the sd card, turned on the power and it keeps giving the same 4 green blinks on the ACT LED. i dont know what to do anymore.

any help would be usefull

with best regards
Last edited by SpaceMaker on Mon Oct 14, 2019 8:37 pm, edited 1 time in total.

bjtheone
Posts: 391
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: Raspberry pi 4 won't boot start_x.elf not found

Mon Oct 07, 2019 7:04 pm

For starters I would suggest vetting the forums you read. 16,32,64,128 GB SD cards all work just fine in a Pi 4. It is unlikely the EEPROM just went bad and flashing it should be fairly far down the chain of trouble shooting steps. I would suggest sticking with the Raspberrypi.org forums until you can better distinguish good advice from bad.

Not quite sure what steps you did between having the 16 GB card working and the 32 Gb card not working, but just the act of trying another card CAN NOT break your 16 GB card. Given that, can you describe in more detail what you have done, starting with how you installed the OS on the 32 GB card and what you did to the 16 Gb card? If you can provide enough information, likely someone can help get it sorted out.

Another suggestion, is to load Etcher on a Windows or MacOS PC, download the latest Raspbian and reinstall the OS on the 32 GB card and try again.

The 4 green blinks is saying that it could not boot, most likely as you do not have a correctly installed OS on the SD card.

Note: The bootup process is different on the 4 than on earlier Pi's. Make sure you are following instructions and trouble shooting steps that are relevant to the Pi 4.

I would start by reading this:

https://www.raspberrypi.org/forums/vie ... 4#p437084

SpaceMaker
Posts: 5
Joined: Sat Sep 14, 2019 9:23 pm

Re: Raspberry pi 4 won't boot start_x.elf not found

Mon Oct 14, 2019 5:55 pm

so i installed the raspbian software on the 16 gb sd card. inserted it and booted up the pi. it worked like it should. after some time i had some trouble with the this forum:
https://www.raspberrypi.org/forums/view ... 9#p1536219
after some feedback i thought it wasnt a big deal, only more effort.
I also have a raspberry pi 3 with the 32 GB card with pihole installed. after some thinking i wanted to switch the sd cards because i wanted to use the pi 4 for a NAS. so after shutting down the pi 3, i removed the sd card, formatted the thing and istalled raspbian on the 32 sd card. i wanted to boot the pi 4 but after some time i was confused. seeing the 4 blink code. i thought it was wrong installed so i formatted it and installed it again. no results. formatting the 16 GB sd and installing the OS again. didnt do anything. still the stupid 4 blinks. so atm i thought it was the program. after some time i wanted to test the new open media vault with support for the pi 4. on the 16 and the 32 cards. nothing. at the end ( just now) i tried diffrend SD cards. i bought new ones and did the whole process again. nothing. i think the reading system of the pi is just broken and nothing to do about it. ( after each time i boot the pi with any OS, it flickers fast for 1-2 seconds and then give the 4 blink code). so it does read the files. i just dont know anything anymore. ( they still both work on the pi 3 )

User avatar
PeterO
Posts: 5150
Joined: Sun Jul 22, 2012 4:14 pm

Re: Raspberry pi 4 won't boot start_x.elf not found

Mon Oct 14, 2019 8:24 pm

What has this got to do with start_x.elf ?
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

SpaceMaker
Posts: 5
Joined: Sat Sep 14, 2019 9:23 pm

Re: Raspberry pi 4 won't boot start_x.elf not found

Mon Oct 14, 2019 8:36 pm

it was a typo, i meant start*.elf

User avatar
thagrol
Posts: 1994
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Raspberry pi 4 won't boot start*.elf not found

Mon Oct 14, 2019 10:10 pm

You mention trying a 32GB card taken from a working 3B that doesn't work on a 4B.
  1. Is it stretch or Buster? Stretch doesn't run on a 4B.
  2. If Buster, was it installed as Buster or upgraded from Stretch? Upgrading is not supported and not guaranteed to work.
  3. Did you shutdown the 3B properly before pulling the SD card? I don't mean just cutting power but performing a proper OS shutdown. If not you may have corrupted the card.
As others have suggested, download the stock raspbian lite image, write it to an SD card then boot preferably with a screen attached.
Attempts to contact me outside of thes forums will be ignored unless signed in triplicate, sent in, sent back, queried, lost, found, subjected to public enquiry, lost again, and finally buried in soft peat for three months and recycled as firelighters

SpaceMaker
Posts: 5
Joined: Sat Sep 14, 2019 9:23 pm

Re: Raspberry pi 4 won't boot start*.elf not found

Mon Oct 14, 2019 10:29 pm

thanks fo the suggestions

1. i always use Buster.
2. like i mentioned, i have formatted the 32 GB sd card when it came out of the pi 3 and installed Buster again.
3. yes i did and i even bought new sd cards. didnt work.
And ive tried all 3 Raspbian programs. still those horrible 4 blinks.

I am afraid i have to buy a new pi 4.
all suggestions are still helpfull

Return to “Troubleshooting”