MrZhangEPSB
Posts: 7
Joined: Tue Nov 28, 2017 8:08 pm

Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Thu Aug 15, 2019 7:35 pm

Hi Everyone,

With the update to Raspbian Buster, my Raspberry Pi 3B+ and new Raspberry Pi 4 cannot connect to my school wifi. In Stretch, the same Raspberry Pi 3B+ could using the following information:

Code: Select all

country=CA
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
	ssid="SSID_NAME"
	priority=1
	proto=RSN
	key_mgmt=WPA-EAP
	pairwise=CCMP
	auth_alg=OPEN
	eap=PEAP
	identity="USER_NAME"
	password=hash:##########################
	phase1="peaplabel=0"
	phase2="auth=MSCHAPV2"
}
When I use Buster, the Wifi icon goes through the animation of connecting, but then loses the connection and cycles re-attempting to connect. The log lines are below:

Code: Select all

Aug 15 13:33:01 raspberrypi dhcpcd[418]: wlan0: carrier acquired
Aug 15 13:33:01 raspberrypi dhcpcd[418]: wlan0: IAID 32:05:55:7d
Aug 15 13:33:01 raspberrypi dhcpcd[418]: wlan0: adding address fe80::e6bf:687a:80ad:c1ac
Aug 15 13:33:01 raspberrypi avahi-daemon[400]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::e6bf:687a:80ad:c1ac.
Aug 15 13:33:01 raspberrypi avahi-daemon[400]: New relevant interface wlan0.IPv6 for mDNS.
Aug 15 13:33:01 raspberrypi avahi-daemon[400]: Registering new address record for fe80::e6bf:687a:80ad:c1ac on wlan0.*.
Aug 15 13:33:02 raspberrypi dhcpcd[418]: wlan0: soliciting an IPv6 router
Aug 15 13:33:02 raspberrypi dhcpcd[418]: wlan0: soliciting a DHCP lease
Aug 15 13:33:04 raspberrypi dhcpcd[418]: wlan0: carrier lost
Aug 15 13:33:04 raspberrypi dhcpcd[418]: wlan0: deleting address fe80::e6bf:687a:80ad:c1ac
Aug 15 13:33:04 raspberrypi avahi-daemon[400]: Withdrawing address record for fe80::e6bf:687a:80ad:c1ac on wlan0.
Aug 15 13:33:04 raspberrypi avahi-daemon[400]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::e6bf:687a:80ad:c1ac.
Aug 15 13:33:04 raspberrypi avahi-daemon[400]: Interface wlan0.IPv6 no longer relevant for mDNS.
Aug 15 13:33:05 raspberrypi systemd[1]: Started Session c3 of user pi.
Aug 15 13:33:06 raspberrypi dhcpcd[418]: wlan0: carrier acquired
Aug 15 13:33:06 raspberrypi dhcpcd[418]: wlan0: IAID 32:05:55:7d
Aug 15 13:33:06 raspberrypi dhcpcd[418]: wlan0: adding address fe80::e6bf:687a:80ad:c1ac
Aug 15 13:33:06 raspberrypi avahi-daemon[400]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::e6bf:687a:80ad:c1ac.
Aug 15 13:33:06 raspberrypi avahi-daemon[400]: New relevant interface wlan0.IPv6 for mDNS.
Aug 15 13:33:06 raspberrypi avahi-daemon[400]: Registering new address record for fe80::e6bf:687a:80ad:c1ac on wlan0.*.
Aug 15 13:33:07 raspberrypi dhcpcd[418]: wlan0: soliciting a DHCP lease
Aug 15 13:33:07 raspberrypi dhcpcd[418]: wlan0: soliciting an IPv6 router
Aug 15 13:33:09 raspberrypi dhcpcd[418]: wlan0: carrier lost
Aug 15 13:33:09 raspberrypi dhcpcd[418]: wlan0: deleting address fe80::e6bf:687a:80ad:c1ac
Aug 15 13:33:09 raspberrypi avahi-daemon[400]: Withdrawing address record for fe80::e6bf:687a:80ad:c1ac on wlan0.
Aug 15 13:33:09 raspberrypi avahi-daemon[400]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::e6bf:687a:80ad:c1ac.
Aug 15 13:33:09 raspberrypi avahi-daemon[400]: Interface wlan0.IPv6 no longer relevant for mDNS.
Any support would be awesome as I teach in Python3 and the jump from 3.5 to 3.7 would be awesome!

cyberchucktx
Posts: 6
Joined: Wed Apr 17, 2013 3:14 am

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Fri Aug 16, 2019 6:41 pm

I just got my RPI4 and went to add to my Campus Wifi (WPA2 Enterprise).

As was shown by a number of articles, I had to edit my WPA_SUPPLICANT configuration file :
network={
ssid="SSID"
proto=RSN
key_mgmt=WPA-EAP
pairwise=CCMP
auth_alg=OPEN
eap=PEAP
identity="YOURUSERID"
password="YOURPASSWORD"
phase1="peaplabel=0"
phase2="auth=MSCHAPV2"
priority=1
}
Note: replace "SSID", "YOURUSERID", and "YOURPASSWORD" with your SSID, userid, and password respectively.

HOWEVER the "wpa_supplicant.conf" file "magically" got reset to default after boot (and after stopping/starting the WIFI).

The MAGIC COMMAND at this point is:
wpa_cli -i wlan0 reconfigure
Which makes the changes "stick".

I really hope this helps someone else struggling with WPA2 Enterprise & Buster.

Charlie

MrZhangEPSB
Posts: 7
Joined: Tue Nov 28, 2017 8:08 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Tue Aug 20, 2019 4:27 pm

Thanks, but it didn't solve my problem. When I reboot the config file stays updated, but the network still refuses to hold a connection.

SophieLiu
Posts: 3
Joined: Fri Aug 23, 2019 7:36 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Tue Sep 10, 2019 6:56 pm

I also have the same problem. Just want to ask have you found a way to solve the problem? I'm really confused since I had used the same before, the first time it works. But now, it doesn't.

MrZhangEPSB
Posts: 7
Joined: Tue Nov 28, 2017 8:08 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Wed Sep 11, 2019 10:40 pm

No luck so far. No one has been able to offer any suggestions that fix the problem. I have tried the wext driver instead of the default, messed with the wpa_supplicant setting and a bunch of other things to no effect. I'm basically waiting for a new update for Raspbian before trying more things.

MrZhangEPSB
Posts: 7
Joined: Tue Nov 28, 2017 8:08 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Mon Oct 07, 2019 2:07 pm

New September update does not fix this issue. Anyone else with suggestions?

mpwcbs
Posts: 2
Joined: Tue Oct 08, 2019 11:59 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Wed Oct 09, 2019 12:12 am

Hi,

I have the exact same issue. I tried to update one of my Pi's to raspbian buster and after many many tries am giving up and going back to stretch....

To summarize, I can connect the enterprise WiFi fine with stretch and also can connect fine with standard Debian buster. I have tried many of the suggestions online including those in this post and the WPA-EAP WiFi network refuses to connect - it just cycles 5 or so times and then gives up.

If anyone has any thoughts I am willing to try them out and try and solve the problem.

Mark


MrZhangEPSB
Posts: 7
Joined: Tue Nov 28, 2017 8:08 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Thu Oct 10, 2019 2:55 am

Excellent to hear. Hopefully, a fix will trickle down soon.

mwa
Posts: 1
Joined: Tue Oct 15, 2019 7:51 pm

Re: Raspberry Pi 3B+/4, Buster, Enterprise Wifi cycles with no connection.

Tue Oct 15, 2019 7:56 pm

seems to be a bug with PEAP/WPA-Enterprise, the broadcom WIFI Driver and the wpa_supplicant.

a possible workaround is described in the article:
https://www.raspberrypi.org/forums/view ... p?t=247310

Walter

Return to “Troubleshooting”