User avatar
TerryC65
Posts: 151
Joined: Sat May 09, 2015 7:50 am
Location: Wimborne, Dorset, UK

Is there a bug in raspi-config in Buster Lite?

Fri Aug 23, 2019 10:33 am

Hi,

I may have stumbled across this by a round about route, but it is driving me wild. A week or two ago I downloaded the image for Raspbian Lite and set up an SD Card to use with our project. At the time I had an old cheapo US layout keyboard and I remember I had some problems setting it up in raspi-config because the list of keyboard layouts contained mostly unprintable characters.

Today, I received a nice shiny new red and white Official Raspberry Pi keyboard with the UK layout and used the same Buster Lite image to create another SD Card for a second device in our project. I had no problems and didn't have to use raspi-config to set up the keyboard; it just worked.

I then thought that I should change the keyboard layout on the original SD Card to match my new keyboard and had the same problem with unprintable chars. This time however, I've been unable to change the layout back to UK.

Any ideas about this (either the unprintable chars or how to get the keyboard setting to UK layout)?

BTW. The graphical version of rasp-config in Buster Full is OK, but we need to use Lite in our project.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6206
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Is there a bug in raspi-config in Buster Lite?

Fri Aug 23, 2019 10:37 am

If you're talking about what I think you're talking about, then it's an issue in Debian that they say should be fixed in the next point release. Something to do with caching layout name translations and then the lookup returning wrong values.

User avatar
TerryC65
Posts: 151
Joined: Sat May 09, 2015 7:50 am
Location: Wimborne, Dorset, UK

Re: Is there a bug in raspi-config in Buster Lite?

Fri Aug 23, 2019 10:40 am

So there's no way that I can fix this other than to make an new SD Card from the Buster image and set it up with the new KB?

User avatar
DougieLawson
Posts: 38448
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Is there a bug in raspi-config in Buster Lite?

Fri Aug 23, 2019 10:47 am

TerryC65 wrote:
Fri Aug 23, 2019 10:40 am
So there's no way that I can fix this other than to make an new SD Card from the Buster image and set it up with the new KB?
You can make a change with sudo nano /etc/default/keyboard to set the right keyboard definition.

Code: Select all

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT=us
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
TerryC65
Posts: 151
Joined: Sat May 09, 2015 7:50 am
Location: Wimborne, Dorset, UK

Re: Is there a bug in raspi-config in Buster Lite?

Fri Aug 23, 2019 11:08 am

DougieLawson wrote:
Fri Aug 23, 2019 10:47 am
You can make a change with sudo nano /etc/default/keyboard to set the right keyboard definition.
Thanks Dougie. Somewhere in the mists that are all that are left of my memory I remember doing that once before! I can't remember why, but I certainly recall doing it.

User avatar
TerryC65
Posts: 151
Joined: Sat May 09, 2015 7:50 am
Location: Wimborne, Dorset, UK

Re: Is there a bug in raspi-config in Buster Lite?

Fri Aug 23, 2019 11:11 am

Wouldn't it be nice if raspi-config had an entry for the 'Official Raspberry Pi Keyboard'? ;)

Return to “Raspbian”