pidloop
Posts: 1
Joined: Fri Jul 12, 2019 7:41 pm

vcgencmd display_power not working in buster

Fri Jul 12, 2019 7:49 pm

Hello!

On my rpi 3 running Stretch I could turn my hdmi power off and on using vcgencmd display_power 0/1. On my new rpi 4 running Buster, with the same display, this no longer works. Whether I give 0 or 1 the display stays on and the command always reports display_power=1.

Thanks for any ways to fix this or an alternate means to control display power.

Thanks.

User avatar
sapnho
Posts: 215
Joined: Sun Sep 14, 2014 3:49 pm
Location: Frankfurt am Main
Contact: Website

Re: vcgencmd display_power not working in buster

Sat Jul 20, 2019 9:05 am

Yep, same issue here. Buster works fine on the Pi 3 but on the Pi4 the command doesn't work.
www.TheDigitalPictureFrame.com
Build a really great digital picture frame with the Raspberry Pi.
With lots of great tips from this forum.

User avatar
Iri-dium
Posts: 40
Joined: Wed Mar 27, 2019 11:25 am

Re: vcgencmd display_power not working in buster

Sat Jul 20, 2019 9:14 am

Code: Select all

tvservice -o
might work

User avatar
sapnho
Posts: 215
Joined: Sun Sep 14, 2014 3:49 pm
Location: Frankfurt am Main
Contact: Website

Re: vcgencmd display_power not working in buster

Sat Jul 20, 2019 10:47 am

Yes, that works and

Code: Select all

 /opt/vc/bin/tvservice -p; sudo /bin/chvt 6; sudo /bin/chvt 7
to turn it back on.

But I used vcgencmd in many areas and it would be nice to have it back. :?
www.TheDigitalPictureFrame.com
Build a really great digital picture frame with the Raspberry Pi.
With lots of great tips from this forum.

cfreybergu
Posts: 10
Joined: Sat Jan 05, 2019 8:43 pm

Re: vcgencmd display_power not working in buster

Wed Sep 18, 2019 1:34 am

As of noon 18 Sept 2019 NZST, this problem appears to have been fixed by the latest firmware/kernel version ( ?? 4.19.73-v71+#1266 SMP ??) :D

vcgencmd version

returned

Sep 17 2019 21:10:29
Copyright (c) 2012 Broadcom
version 549267a4b69d1c83ccc9cce7f60773831609f208 (clean) (release) (start)

At the time I installed it, that firmware/kernel package was unavailable through apt-get update, but I guess that situation will change fairly soon.
Chris F

User avatar
sapnho
Posts: 215
Joined: Sun Sep 14, 2014 3:49 pm
Location: Frankfurt am Main
Contact: Website

Re: vcgencmd display_power not working in buster

Thu Sep 19, 2019 2:06 pm

Excellent news for all digital picture frame fans! :D
www.TheDigitalPictureFrame.com
Build a really great digital picture frame with the Raspberry Pi.
With lots of great tips from this forum.

User avatar
sapnho
Posts: 215
Joined: Sun Sep 14, 2014 3:49 pm
Location: Frankfurt am Main
Contact: Website

Re: vcgencmd display_power not working in buster

Mon Oct 21, 2019 2:03 pm

I only just got around to checking on the updated vcgencmd in Buster which again allows for turning the hdmi output on/off.

So I updated everything with

Code: Select all

sudo apt update && sudo apt full-upgrade
and rebooted. However when I enter sudo

Code: Select all

vcgencmd display_power 0
the display doesn't turn off.

Does it work with anybody in the described way?

Firmware is
Linux pi4withpi3d 4.19.79-v7l+ #1273 SMP Fri Oct 11 18:23:45 BST 2019 armv7l GNU/Linux
www.TheDigitalPictureFrame.com
Build a really great digital picture frame with the Raspberry Pi.
With lots of great tips from this forum.

User avatar
sapnho
Posts: 215
Joined: Sun Sep 14, 2014 3:49 pm
Location: Frankfurt am Main
Contact: Website

Re: vcgencmd display_power not working in buster

Mon Oct 21, 2019 2:31 pm

Ah, just found out that it actually works in HDMI 0 (I believe that is the left HDMI slot of the two)

Does anybody know how to activate it also for HDMI 1?
www.TheDigitalPictureFrame.com
Build a really great digital picture frame with the Raspberry Pi.
With lots of great tips from this forum.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23876
Joined: Sat Jul 30, 2011 7:41 pm

Re: vcgencmd display_power not working in buster

Mon Oct 21, 2019 2:48 pm

It should work on both at the same time...not sure what is going on there.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

User avatar
Botspot
Posts: 183
Joined: Thu Jan 17, 2019 9:47 pm
Location: Texas

Re: vcgencmd display_power not working in buster

Wed Oct 23, 2019 5:00 pm

It hasn't been implemented for the Pi 4 until recently. See here, here, here, and here.

But recently the bootloader and kernel got an update. Just run this and you should be good to go.

Code: Select all

sudo apt update
sudo apt full-upgrade -y
Edit: clarified grammar
My doctor told me my brain is as useful as a Raspberry Pi. Is that a compliment?

Return to “Raspbian”