Posts: 21
Joined: Sun Oct 14, 2012 4:51 pm

[solved] Cant get hdmi to work from pi4

Thu Jul 18, 2019 12:53 pm

Just bought a pi4.. and cant get it to drive my monitor an HPL1906 .. I see a message ..."Signal out of range Change settings to 1280x1024 @ 60hz"
Ive set up the SD card in a Pi3 connected identically to the Pi4 , the Pi3 works perfectly, but the Pi4 gives me the error message above.
The SD card is loaded with "2019-07-10-raspbian-buster"
Ive modified the config.txt file with ..
Ive also tried ..
which gives the same result .. good in Pi3 .. failure in Pi4

Ive noticed that the menu item "Raspberry Pi Configuration" windows differ between pi3 and pi4 ... the pi4 window lacks a "Set Resolution" button

The Pi3/Pi4 hdmi output is connected via a hdmi->VGA converter to to a KVM switch to the HP monitor.

The Pi4 display works in hdmi_safe=1 , I also get a display when booting to CLI only. I'm using the new 3A PS and the new hdmi cable with a hdmi_female_to_female adaptor.

With hdmi_safe=1 the Pi3 has a resolution of 640x480 but the Pi4 resolution is 1024x768 ... as measured by xrandr

Any ideas please ? :)
Last edited by Hcgrant on Fri Jul 19, 2019 10:29 pm, edited 1 time in total.

User avatar
Posts: 14
Joined: Sun Jul 23, 2017 2:36 pm
Location: River Vale NJ US

Re: Cant get hdmi to work from pi4

Thu Jul 18, 2019 11:14 pm

I appreciate your response to my issue.

When I uncommented t the "HDMI_SAFE=1" I was able to get a screen display,

Once in I used the Menu preferences / screens menu to adjust my screen.

I disabled HDMI2 to avoid any confusion.

then used the the "Configure" "Screens" "HDMI-1" "Resolution" and played with the available options.

the default kept failing but I was able to see the desktop.

Please let me know if it works for you.

Gracious Regards

Posts: 21
Joined: Sun Oct 14, 2012 4:51 pm

Re: Cant get hdmi to work from pi4

Fri Jul 19, 2019 9:12 pm

:D :D Done it!
Many thanks Neil ...you know, I missed the Menu/Preferences/Screen Configuration option! How I did I dont know. :oops:
Its now working at the resolution I get with a Pi3. :D

Return to “Troubleshooting”