robins250
Posts: 4
Joined: Thu May 17, 2018 5:10 am

Auto Exposure Issues with Creative Live! Cam Sync HD

Mon Sep 24, 2018 2:30 am

I learned something I figured others might find useful.

I ran into an issue were the Creative Camera would pulse, flash, cycle with bright white and then return back to normal, specifically if pointed at a light or window, but sometimes just when the room is bright. It was driving me nuts and took me weeks to solve the problem. I had to learn that the driver for the cameras is called V4l2 and through trial and error I figured out how to muck with the driver settings; which can be done in real time.

First I learned I can see the current V4l2 settings for my cameras with the following command:

Code: Select all

v4l2-ctl -d /dev/videoX -l      #where videoX is the identifier for each camera, typically video0, video1 ect. 

From here you can then set the driver to stop using auto exposure with:

Code: Select all

v4l2-ctl -d /dev/videoX --set-ctrl=exposure_auto=1  
I tested this while motion was running a stream and found it stopped the auto exposure issues. This was specifically for the Creative Live! Cam Sync HD 720P Webcam.

I was wondering if anyone knew if/how I could get motion to configure the exposure_auto for the webcam through the config. I tried adding exposure_auto 1, but that didn't work.

I need more testing, but it seems the configured values are kept even when a reboot or shutdown is triggered. Otherwise a crontab could be used to set these once a day, incase of power failure.

Pangu69
Posts: 1
Joined: Fri Jul 12, 2019 10:13 pm

Re: Auto Exposure Issues with Creative Live! Cam Sync HD

Fri Jul 12, 2019 10:16 pm

I just created this account to say thank you.


Also

Code: Select all

sudo v4l2-ctl -d /dev/video0 -L
shows more details about the config

The "auto" exposure on Creative Live! Cam Sync HD is a joke, it doesn't work at all.

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 8148
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Auto Exposure Issues with Creative Live! Cam Sync HD

Sat Jul 13, 2019 7:31 am

Pangu69 wrote:
Fri Jul 12, 2019 10:16 pm
I just created this account to say thank you.


Also

Code: Select all

sudo v4l2-ctl -d /dev/video0 -L
shows more details about the config

The "auto" exposure on Creative Live! Cam Sync HD is a joke, it doesn't work at all.
You don't need the sudo as long as you are in the video group (normally the case), nor the "-d /dev/video0" as that is the default.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

Return to “Graphics, sound and multimedia”