ttwr
Posts: 2
Joined: Mon May 27, 2019 4:16 pm

Internet on Compute Module 3 via USB Hub with ethernet

Mon May 27, 2019 4:28 pm

Hi guys,

i'm a bit familiar with Raspberry but I try for the very first time to manage a compute module 3 (with memory on it).

I've the CMIO card, my issue is to succeed to access to internet for the first steps of configuration, i've a USB Hub + Ethernet, and i've try most of the technics i've seen on internet, but i still not succeed to connect internet from my CM3.

Btw, i've installed raspbian Stretch Desktop Version (the tiny one, not with all software), with etcher from a macbook. I've try to change the files into the boot partition, dtoverlay and so on, but i'm a bit confused, i still don't know if it's the correct way to do it with compute module 3 Vs Pi Zero or pi 3 B.

My bad if the correct information already exists, i've try to reach it, without success.

Thanks to all, take care.

TTWR

fruitoftheloom
Posts: 20125
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Internet on Compute Module 3 via USB Hub with ethernet

Mon May 27, 2019 6:26 pm

ttwr wrote:
Mon May 27, 2019 4:28 pm
Hi guys,

i'm a bit familiar with Raspberry but I try for the very first time to manage a compute module 3 (with memory on it).

I've the CMIO card, my issue is to succeed to access to internet for the first steps of configuration, i've a USB Hub + Ethernet, and i've try most of the technics i've seen on internet, but i still not succeed to connect internet from my CM3.

Btw, i've installed raspbian Stretch Desktop Version (the tiny one, not with all software), with etcher from a macbook. I've try to change the files into the boot partition, dtoverlay and so on, but i'm a bit confused, i still don't know if it's the correct way to do it with compute module 3 Vs Pi Zero or pi 3 B.

My bad if the correct information already exists, i've try to reach it, without success.

Thanks to all, take care.

TTWR

You need a Compute Model base board, see:

https://www.raspberrypi.org/documentati ... /README.md
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

User avatar
rpdom
Posts: 14701
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Internet on Compute Module 3 via USB Hub with ethernet

Mon May 27, 2019 7:57 pm

fruitoftheloom wrote:
Mon May 27, 2019 6:26 pm
You need a Compute Model base board
Also known as a CMIO board as mentioned in the original post.

W. H. Heydt
Posts: 10574
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: Internet on Compute Module 3 via USB Hub with ethernet

Mon May 27, 2019 8:57 pm

You configure config.txt and cmdline.txt the same way you do with any other Pi. They're located in /boot. Use your preferred editor and do the editing as root.

fruitoftheloom
Posts: 20125
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Internet on Compute Module 3 via USB Hub with ethernet

Tue May 28, 2019 6:01 am

rpdom wrote:
Mon May 27, 2019 7:57 pm
fruitoftheloom wrote:
Mon May 27, 2019 6:26 pm
You need a Compute Model base board
Also known as a CMIO board as mentioned in the original post.

The OP wrote CMIO card
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

User avatar
rpdom
Posts: 14701
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Internet on Compute Module 3 via USB Hub with ethernet

Tue May 28, 2019 7:03 am

fruitoftheloom wrote:
Tue May 28, 2019 6:01 am
rpdom wrote:
Mon May 27, 2019 7:57 pm
fruitoftheloom wrote:
Mon May 27, 2019 6:26 pm
You need a Compute Model base board
Also known as a CMIO board as mentioned in the original post.
The OP wrote CMIO card
Semantics. :lol:

ttwr
Posts: 2
Joined: Mon May 27, 2019 4:16 pm

Re: Internet on Compute Module 3 via USB Hub with ethernet

Wed May 29, 2019 4:25 pm

Hi everyone, i'm more advanced than two days before, thanks to all. I still got some issues.

At each reboot, my RPi 3 compute module add one route (that i can see with route -n), with a new IP Adress, i have to change my configuration network in my OSX system preferences and change the router from 192.168.7.0 to 192.168.3.0.

Then i have an internet connexion on RPi, i can ping the web from my Pi, i can connect in ssh from my mac, that's perfect.

But it not stay like this more than a minute, then i lose the connexion on both devices (RPI and macbook), i've to change the router again, it's rework fine, and again i ve the problem.

For information i've tried and succeed to delete the new route, it doesn't change anything, the Pi Compute Module recreate a new one, and i've to switch again, eternally.

Do you know if there is a solution (fix IP adress or something else) to avoid this behavior?

Thanks to all, take care.

Return to “Compute Module”