Frenchy
Posts: 11
Joined: Tue Jan 22, 2013 2:58 pm

Configure Transmission to write on a NAS

Sat May 04, 2019 10:16 pm

Hello,

Long time ago, I suceeded to configure Transmission on raspbian to save downloaded torrent on my NAS...and then my SD card got corrupted and I didn't have a backup :oops:

Today I tried to reconfigure Transmission and nothing works... Everytime Transmission tries to download a file, I get "Permission denied"

Here's how I mount my NAS folder:

Code: Select all

//192.168.1.111/Volume_1/_DLL    /home/pi/DNS323/_DLL             cifs    uid=pi,gid=pi,rw,nounix,user=,password=,vers=1.0      0 0
It works, I can acces my files from raspbian (I only works in ssh)

On the Transmission config file (/etc/init.d/transmission-daemon), I tried to set USER=debian-transmission, pi and even root

I think the problem is to set the write access on the NAS folder. I tried a lot of sudo chgrp and sudo chmod 770 but here are the results on the folders:

Code: Select all

drwxrwx--- 3 root pi 4096 May  1 20:39 DNS323
drwxr-xr-x 2 pi pi 0 May  4 22:05 _DLL
drwxr-xr-x 2 pi pi 0 Feb 25 21:45 Torrents
I try to write on /home/pi/DNS323/_DLL/Torrents

pi user seems to have access...so I don't understand why Transmission can't write :(
Please help-me

Thanks

Frenchy
Posts: 11
Joined: Tue Jan 22, 2013 2:58 pm

Re: Configure Transmission to write on a NAS

Tue May 07, 2019 8:12 pm

Anyone? Or maybe I should post somewhere else?

Thanks

LTolledo
Posts: 1544
Joined: Sat Mar 17, 2018 7:29 am

Re: Configure Transmission to write on a NAS

Tue May 07, 2019 9:07 pm

"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Frenchy
Posts: 11
Joined: Tue Jan 22, 2013 2:58 pm

Re: Configure Transmission to write on a NAS

Wed May 08, 2019 8:56 pm

In my case, It starts to download and I directly get a "Permission denied" as soon as It tries to write.

Thanks for your link but the only solution given is to install deluge. I'd prefer to configure transmission as It worked well before

Return to “Advanced users”