mob-i-l
Posts: 263
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

[SOLVED] Needs to have audio cable connected to screen otherwise black screen

Sun Apr 21, 2019 9:44 pm

I have a strange situation where I need to have a 3.5 mm stereo cable connected between the screen and the Raspberry Pi 3 Model B audio socket in order to have a picture on the screen. If I disconnect the stereo cable in either end the screen immediately becomes black and sleep starts shortly after. I would like to connect the audio connector of the Pi to other speakers, but this is not possible now. Anyone knows the cause of this problem?

The screen is connected to the Pi via an HDMI cable and an HDMI to DVI-D adapter (passive). My screen is not connected to a grounded power jack since I have no such here. Twisting the power cable 180 degrees in the power jack didn't help. The screen is a FUJITSU SIEMENS B17-2 CI:
https://shop.staplesconnect.se/fujitsu- ... c/p1046532
Last edited by mob-i-l on Mon Apr 22, 2019 9:59 am, edited 2 times in total.
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

pfletch101
Posts: 500
Joined: Sat Feb 24, 2018 4:09 am
Location: Illinois, USA

Re: Needs to have audio cable connected to screen otherwise black screen

Sun Apr 21, 2019 10:52 pm

Sounds as if the screen's DVI input is referenced to the Pi's ground only via the audio cable, which seems consistent with the other information you have given us. One approach would simply be to use a standard audio 'Y' cable to connect the Pi both to a cable to the screen (with its audio turned off) and to one to the input side of your speaker setup. Since it is almost certainly only the ground connection that is needed, another solution, would be to make a 'special' 'Y' cable, in which the audio is taken down one arm of the 'Y', going to the speakers, and only the screen/ground connection is made on the other arm, going to the Pi.

mob-i-l
Posts: 263
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

Re: Needs to have audio cable connected to screen otherwise black screen

Mon Apr 22, 2019 1:04 am

pfletch101 wrote:
Sun Apr 21, 2019 10:52 pm
Sounds as if the screen's DVI input is referenced to the Pi's ground only via the audio cable
Thanks! Yes I have tested now with connecting the inner ring of the audio cable in the Pi end to ground on Pi and then the screen works. I think it's very strange that ground on the HDMI to DVI-D adapter or the HDMI cable doesn't work. Is this a common problem?
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

User avatar
HawaiianPi
Posts: 4531
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Needs to have audio cable connected to screen otherwise black screen

Mon Apr 22, 2019 1:54 am

mob-i-l wrote:
Mon Apr 22, 2019 1:04 am
Thanks! Yes I have tested now with connecting the inner ring of the audio cable in the Pi end to ground on Pi and then the screen works. I think it's very strange that ground on the HDMI to DVI-D adapter or the HDMI cable doesn't work. Is this a common problem?
While not common, it's not unheard of. Some cheap HDMI-DVI adapters don't pass the ground through. Either get a better adapter, or get an HDMI-DVI cable.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

mob-i-l
Posts: 263
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

Re: Needs to have audio cable connected to screen otherwise black screen

Mon Apr 22, 2019 9:52 am

HawaiianPi wrote:
Mon Apr 22, 2019 1:54 am
mob-i-l wrote:
Mon Apr 22, 2019 1:04 am
Thanks! Yes I have tested now with connecting the inner ring of the audio cable in the Pi end to ground on Pi and then the screen works. I think it's very strange that ground on the HDMI to DVI-D adapter or the HDMI cable doesn't work. Is this a common problem?
While not common, it's not unheard of. Some cheap HDMI-DVI adapters don't pass the ground through. Either get a better adapter, or get an HDMI-DVI cable.
I switched HDMI to DVI-D adapter to another brand and now I can disconnect the audio cable without the screen turning black.

This HDMI to DVI-D adapter works for me: https://www.electrokit.com/produkt/adapter-hdmi-dvi-d/
Image
Last edited by mob-i-l on Tue Apr 23, 2019 12:24 am, edited 1 time in total.
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

User avatar
HawaiianPi
Posts: 4531
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: [SOLVED] Needs to have audio cable connected to screen otherwise black screen

Mon Apr 22, 2019 11:19 am

Glad you got it working. Image

I have a couple of HDMI-DVI adapters that worked for me. One is a Monster Cable brand that was probably over-priced (don't know what it cost, someone gave it to me), and the other is a generic adapter that looks like this:
HDMI-DVI.jpg
HDMI-DVI.jpg (16.81 KiB) Viewed 177 times
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Return to “Troubleshooting”