Posts: 142
Joined: Thu Dec 12, 2013 10:39 pm
Location: Suffolk, UK
Contact: Website

Rainbow boot fail on Pi1 model B

Tue Mar 26, 2019 9:35 pm

Last night I flashed the November 2018 Raspbian Stretch Lite onto an 8GB SD card using Etcher. I added a

Code: Select all

file and a

Code: Select all

file to the /boot directory with my wifi settings. I then inserted it into a Pi 1 model B. Booted the Pi headless, ssh’ed in ran a

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get upgrade
. I then installed some software such as git, python3-venv. I cloned a bitbucket repository, created a venv and installed RPi.gpio and gpiozero into it. All was working fine. I shut down the Pi at the end of the day.

The following evening i tried to carry on with where I left off, but could not get the Pi to boot. I was getting two quick flashes on the green LED. I plugged the Pi into a monitor and found it was not getting past the rainbow boot screen. I tried the SD card in a Pi Zero v1.3 and got the same issue. I then tried the SD card in. Pi 2 model B v1.1 and it booted fine.

Why does my SD card not work in the older Pi. Does the apt-get upgrade prevent the SD card working in older Pi’s?


Return to “Troubleshooting”