busti
Posts: 3
Joined: Fri Mar 15, 2019 2:03 pm

[PI 3B+]Wlan0 - carrier lost | 5ghz hotspot of phone <-> internal wifi chip wlan0

Fri Mar 15, 2019 3:30 pm

Hello Raspians,

I hope your all doing well.

Before some weeks i did buy my first raspi, and I'm quite happy with it.

As my starter Project, i wanted to create an Accespoint out of it, and after some days reading and learning and killing my wifi drivers over and over again, i finally got it working.

So, it is working now. But not entirely.

This is my setting:
I did configure the raspi on my home router with 5GHz wifi connection.

Wlan 0 is the internal antenna
Wlan 1 is the dongle to share the connection.

( quick question: am i able to increase the power of the antenna? )

So far so good, i did install and configure hostapd,dnsmasq,dhcpcd.conf,rc.local and created an autorun so it is going to be started up after the boot has finished.

Till here it's working

All devices have connection but the maximum i could reach was 85-100 mbit.

( Another quick question: is it possible to increase the speed? I only could do it by overclocking the raspi - but is this realy the only way to achieve more speeds? ).

Now to my problem:

The setup is working, with my router 5GHz.
Now i change the wpa_supplicant to my 5GHz Hotspot of my phone (Samsung S9 with root)

And boom, I can't find the Wifi

Now a big list of troubleshooting did start, from killing my pi by overvolting and rpi-update'ing it, buying a new pi (same problem), change the OS (from raspbian to openplotter), disableing power save, using bash scripts which "scan" automaticly - cause i read about this on the net.
But nothing did solve the problem: I can't find the wifi.

Then, the first positive result, after changing the wifi country code to US in the wpa_supplicant - i found my wifi (im living in germany)

I thought great, i've done it - raspi connected to the wifi and i was happy and tried to run the speedtest-cli.
And now is where the things collapsed again.

I lost the connection to the hotspot (no other device is having such behaviour with my hotspot, only the raspi and also only on the 5GHz network)

After grinding the internet for some informations, i found out that the problem is: carrier lost.
The Dongle on the PI, is able to connect to the same hotspot and does not loose its connection, never.

And everything startet again, searching internet, killing my wifi, restoring another OS, ... repeat, disabling the power saving and doing a hell lot of things.

I'm looking now for a solution for over a week and now I have reached a point where i say - i need help.


Here are some extra informations, because i also tried to aquire informations on a german board, so i can send you some informations they did aquire from me:

Set scan_ssid=1
-> no change - carrier lost

sudo tcpdump -vvveni wlan0 ether proto 0x888e
-> shows the same handshake for 2.4ghz and for 5ghz
https://ibb.co/02SR8Pf

set bgscan=""
--> no change - carrier lost

Use this code:

Code: Select all

ps aux | grep -i [n]et
systemctl list-units --all | grep -i [w]pa
systemctl list-units --all | grep -i [n]et
ps aux | grep -i [w]pa
result 2.4 GHz

Code: Select all

[email protected]:~ $ systemctl list-units --all | grep -i [w]pa
hostapd.service                                                                                      loaded    activating auto-restart Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
raspberrypi-net-mods.service                                                                         loaded    inactive   dead         Copy user wpa_supplicant.conf
wpa_supplicant.service                                                                               loaded    active     running      WPA supplicant
● wpaping.service                                                                                      loaded    failed     failed       WPA Supplicant pinger
[email protected]:~ $ systemctl list-units --all | grep -i [n]et
sys-devices-platform-soc-3f300000.mmc-mmc_host-mmc1-mmc1:0001-mmc1:0001:1-net-wlan0.device           loaded    active     plugged      /sys/devices/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0
sys-devices-platform-soc-3f980000.usb-usb1-1\x2d1-1\x2d1.1-1\x2d1.1.1-1\x2d1.1.1:1.0-net-eth0.device loaded    active     plugged      7800
sys-subsystem-net-devices-eth0.device                                                                loaded    active     plugged      7800
sys-subsystem-net-devices-wlan0.device                                                               loaded    active     plugged      /sys/subsystem/net/devices/wlan0
netfilter-persistent.service                                                                         loaded    active     exited       netfilter persistent configuration
networking.service                                                                                   loaded    active     exited       Raise network interfaces
raspberrypi-net-mods.service                                                                         loaded    inactive   dead         Copy user wpa_supplicant.conf
systemd-timesyncd.service                                                                            loaded    active     running      Network Time Synchronization
network-online.target                                                                                loaded    active     active       Network is Online
network-pre.target                                                                                   loaded    active     active       Network (Pre)
network.target                                                                                       loaded    active     active       Network
nss-lookup.target                                                                                    loaded    active     active       Host and Network Name Lookups
[email protected]:~ $ ps aux | grep -i [w]pa
root       331  0.0  0.4   9988  3936 ?        Ss   09:36   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
root       463  0.0  0.4  10564  4084 ?        Ss   09:36   0:00 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
[email protected]:~ $
result 5 GHz

Code: Select all

[email protected]:~ $ ps aux | grep -i [n]et
root        28  0.0  0.0      0     0 ?        I<   09:36   0:00 [netns]
[email protected]:~ $ systemctl list-units --all | grep -i [w]pa
hostapd.service                                                                                      loaded    activating auto-restart Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
raspberrypi-net-mods.service                                                                         loaded    inactive   dead         Copy user wpa_supplicant.conf
wpa_supplicant.service                                                                               loaded    active     running      WPA supplicant
● wpaping.service                                                                                      loaded    failed     failed       WPA Supplicant pinger
[email protected]:~ $ systemctl list-units --all | grep -i [n]et
sys-devices-platform-soc-3f300000.mmc-mmc_host-mmc1-mmc1:0001-mmc1:0001:1-net-wlan0.device           loaded    active     plugged      /sys/devices/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0
sys-devices-platform-soc-3f980000.usb-usb1-1\x2d1-1\x2d1.1-1\x2d1.1.1-1\x2d1.1.1:1.0-net-eth0.device loaded    active     plugged      7800
sys-subsystem-net-devices-eth0.device                                                                loaded    active     plugged      7800
sys-subsystem-net-devices-wlan0.device                                                               loaded    active     plugged      /sys/subsystem/net/devices/wlan0
netfilter-persistent.service                                                                         loaded    active     exited       netfilter persistent configuration
networking.service                                                                                   loaded    active     exited       Raise network interfaces
raspberrypi-net-mods.service                                                                         loaded    inactive   dead         Copy user wpa_supplicant.conf
systemd-timesyncd.service                                                                            loaded    active     running      Network Time Synchronization
network-online.target                                                                                loaded    active     active       Network is Online
network-pre.target                                                                                   loaded    active     active       Network (Pre)
network.target                                                                                       loaded    active     active       Network
nss-lookup.target                                                                                    loaded    active     active       Host and Network Name Lookups
[email protected]:~ $ ps aux | grep -i [w]pa
root       331  0.0  0.4   9988  3936 ?        Ss   09:36   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
root       463  0.0  0.4  10564  4084 ?        Ss   09:36   0:00 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
[email protected]:~ $ clear
[email protected]:~ $ ps aux | grep -i [n]et
root        28  0.0  0.0      0     0 ?        I<   09:36   0:00 [netns]
[email protected]:~ $ systemctl list-units --all | grep -i [w]pa
hostapd.service                                                                                      loaded    activating auto-restart Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
raspberrypi-net-mods.service                                                                         loaded    inactive   dead         Copy user wpa_supplicant.conf
wpa_supplicant.service                                                                               loaded    active     running      WPA supplicant
● wpaping.service                                                                                      loaded    failed     failed       WPA Supplicant pinger
[email protected]:~ $ systemctl list-units --all | grep -i [n]et
sys-devices-platform-soc-3f300000.mmc-mmc_host-mmc1-mmc1:0001-mmc1:0001:1-net-wlan0.device           loaded    active     plugged      /sys/devices/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0
sys-devices-platform-soc-3f980000.usb-usb1-1\x2d1-1\x2d1.1-1\x2d1.1.1-1\x2d1.1.1:1.0-net-eth0.device loaded    active     plugged      7800
sys-subsystem-net-devices-eth0.device                                                                loaded    active     plugged      7800
sys-subsystem-net-devices-wlan0.device                                                               loaded    active     plugged      /sys/subsystem/net/devices/wlan0
netfilter-persistent.service                                                                         loaded    active     exited       netfilter persistent configuration
networking.service                                                                                   loaded    active     exited       Raise network interfaces
raspberrypi-net-mods.service                                                                         loaded    inactive   dead         Copy user wpa_supplicant.conf
systemd-timesyncd.service                                                                            loaded    active     running      Network Time Synchronization
network-online.target                                                                                loaded    active     active       Network is Online
network-pre.target                                                                                   loaded    active     active       Network (Pre)
network.target                                                                                       loaded    active     active       Network
nss-lookup.target                                                                                    loaded    active     active       Host and Network Name Lookups
[email protected]:~ $ ps aux | grep -i [w]pa
root       331  0.0  0.3   9988  3320 ?        Ss   09:36   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
root       463  0.0  0.3  10564  3452 ?        Ss   09:36   0:00 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
[email protected]:~ $
this is iwconfig in the little seconds i have to pull the command from inside the wifi 5GHz:

Code: Select all

[email protected]:~# iwconfig wlan0
wlan0     IEEE 802.11  ESSID:"1337-h4xX0R"
Mode:Managed  Frequency:5.745 GHz  Access Point: 26:18:1D:EF:1A:5E
Bit Rate=390 Mb/s   Tx-Power=31 dBm
Retry short limit:7   RTS thr:off   Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70  Signal level=-40 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0
iwconfig wlan0 2.4GHz

Code: Select all

[email protected]:~# iwconfig wlan0
wlan0     IEEE 802.11  ESSID:"1337-h4xX0R"
Mode:Managed  Frequency:2.442 GHz  Access Point: 26:18:1D:EF:1A:5E
Bit Rate=65 Mb/s   Tx-Power=31 dBm
Retry short limit:7   RTS thr:off   Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70  Signal level=-39 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0
systemctl cat wpa_supplicant.service
systemctl cat networking.service
result:

Code: Select all

[email protected]:~# systemctl cat wpa_supplicant.service
# /lib/systemd/system/wpa_supplicant.service
[Unit]
Description=WPA supplicant
Before=network.target
After=dbus.service
Wants=network.target
[Service]
Type=dbus
BusName=fi.w1.wpa_supplicant1
ExecStart=/sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
[Install]
WantedBy=multi-user.target
Alias=dbus-fi.w1.wpa_supplicant1.service
[email protected]:~# systemctl cat networking.service
# /lib/systemd/system/networking.service
[Unit]
Description=Raise network interfaces
Documentation=man:interfaces(5)
DefaultDependencies=no
Wants=network.target
After=local-fs.target network-pre.target apparmor.service systemd-sysctl.service systemd-modules-load.service
Before=network.target shutdown.target network-online.target
Conflicts=shutdown.target
[Install]
WantedBy=multi-user.target
WantedBy=network-online.target
[Service]
Type=oneshot
EnvironmentFile=-/etc/default/networking
ExecStartPre=-/bin/sh -c '[ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm settle'
ExecStart=/sbin/ifup -a --read-environment
ExecStop=/sbin/ifdown -a --read-environment --exclude=lo
RemainAfterExit=true
TimeoutStartSec=5min
[email protected]:~# 
journalctl |grep wlan0

Code: Select all

Mar 15 12:14:11 1337pi dhcpcd[318]: wlan0: carrier acquired
Mar 15 12:14:11 1337pi dhcpcd[318]: wlan0: IAID eb:d7:87:71
Mar 15 12:14:11 1337pi dhcpcd[318]: wlan0: adding address fe80::a6c2:e78a:eb40:57
Mar 15 12:14:11 1337pi dhcpcd[318]: wlan0: soliciting an IPv6 router
Mar 15 12:14:12 1337pi dhcpcd[318]: wlan0: rebinding lease of 192.168.43.84
Mar 15 12:14:12 1337pi dhcpcd[318]: wlan0: probing address 192.168.43.84/24
Mar 15 12:14:13 1337pi avahi-daemon[283]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::a6c2:e78a:eb40:57.
Mar 15 12:14:13 1337pi avahi-daemon[283]: New relevant interface wlan0.IPv6 for mDNS.
Mar 15 12:14:13 1337pi avahi-daemon[283]: Registering new address record for fe80::a6c2:e78a:eb40:57 on wlan0.*.
Mar 15 12:14:17 1337pi dhcpcd[318]: wlan0: leased 192.168.43.84 for 3600 seconds
Mar 15 12:14:17 1337pi avahi-daemon[283]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.43.84.
Mar 15 12:14:17 1337pi avahi-daemon[283]: New relevant interface wlan0.IPv4 for mDNS.
Mar 15 12:14:17 1337pi dhcpcd[318]: wlan0: adding route to 192.168.43.0/24
Mar 15 12:14:17 1337pi avahi-daemon[283]: Registering new address record for 192.168.43.84 on wlan0.IPv4.
Mar 15 12:14:17 1337pi dhcpcd[318]: wlan0: adding default route via 192.168.43.1
Mar 15 12:14:18 1337pi dhcpcd[318]: wlan0: carrier lost
Mar 15 12:14:18 1337pi dhcpcd[318]: wlan0: deleting address fe80::a6c2:e78a:eb40:57
Mar 15 12:14:18 1337pi avahi-daemon[283]: Withdrawing address record for fe80::a6c2:e78a:eb40:57 on wlan0.
Mar 15 12:14:18 1337pi avahi-daemon[283]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::a6c2:e78a:eb40:57.
Mar 15 12:14:18 1337pi avahi-daemon[283]: Interface wlan0.IPv6 no longer relevant for mDNS.
Mar 15 12:14:18 1337pi dhcpcd[318]: wlan0: deleting default route via 192.168.43.1
Mar 15 12:14:18 1337pi dhcpcd[318]: wlan0: deleting route to 192.168.43.0/24
Mar 15 12:14:18 1337pi avahi-daemon[283]: Withdrawing address record for 192.168.43.84 on wlan0.
Mar 15 12:14:18 1337pi avahi-daemon[283]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.43.84.
Mar 15 12:14:18 1337pi avahi-daemon[283]: Interface wlan0.IPv4 no longer relevant for mDNS.
Mar 15 12:14:21 1337pi dhcpcd[318]: wlan0: carrier acquired
Mar 15 12:14:21 1337pi dhcpcd[318]: wlan0: IAID eb:d7:87:71
Mar 15 12:14:21 1337pi dhcpcd[318]: wlan0: adding address fe80::a6c2:e78a:eb40:57
Mar 15 12:14:21 1337pi dhcpcd[318]: wlan0: rebinding lease of 192.168.43.84
Mar 15 12:14:21 1337pi dhcpcd[318]: wlan0: soliciting an IPv6 router
Mar 15 12:14:21 1337pi dhcpcd[318]: wlan0: probing address 192.168.43.84/24
Mar 15 12:14:23 1337pi avahi-daemon[283]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::a6c2:e78a:eb40:57.
Mar 15 12:14:23 1337pi avahi-daemon[283]: New relevant interface wlan0.IPv6 for mDNS.
Mar 15 12:14:23 1337pi avahi-daemon[283]: Registering new address record for fe80::a6c2:e78a:eb40:57 on wlan0.*.
Mar 15 12:14:27 1337pi dhcpcd[318]: wlan0: leased 192.168.43.84 for 3600 seconds
Mar 15 12:14:27 1337pi avahi-daemon[283]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.43.84.
Mar 15 12:14:27 1337pi avahi-daemon[283]: New relevant interface wlan0.IPv4 for mDNS.
Mar 15 12:14:27 1337pi dhcpcd[318]: wlan0: adding route to 192.168.43.0/24
Mar 15 12:14:27 1337pi avahi-daemon[283]: Registering new address record for 192.168.43.84 on wlan0.IPv4.
Mar 15 12:14:27 1337pi dhcpcd[318]: wlan0: adding default route via 192.168.43.1
Mar 15 12:14:35 1337pi dhcpcd[318]: wlan0: no IPv6 Routers available
Mar 15 12:15:18 1337pi dhcpcd[318]: wlan0: carrier lost
Mar 15 12:15:18 1337pi dhcpcd[318]: wlan0: deleting address fe80::a6c2:e78a:eb40:57
Mar 15 12:15:18 1337pi avahi-daemon[283]: Withdrawing address record for fe80::a6c2:e78a:eb40:57 on wlan0.
Mar 15 12:15:18 1337pi avahi-daemon[283]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::a6c2:e78a:eb40:57.
Mar 15 12:15:18 1337pi avahi-daemon[283]: Interface wlan0.IPv6 no longer relevant for mDNS.
Mar 15 12:15:18 1337pi dhcpcd[318]: wlan0: deleting default route via 192.168.43.1
Mar 15 12:15:18 1337pi dhcpcd[318]: wlan0: deleting route to 192.168.43.0/24
Mar 15 12:15:18 1337pi avahi-daemon[283]: Withdrawing address record for 192.168.43.84 on wlan0.
Mar 15 12:15:18 1337pi avahi-daemon[283]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.43.84.
Mar 15 12:15:18 1337pi avahi-daemon[283]: Interface wlan0.IPv4 no longer relevant for mDNS.
Mar 15 12:15:21 1337pi dhcpcd[318]: wlan0: carrier acquired
Mar 15 12:15:21 1337pi dhcpcd[318]: wlan0: IAID eb:d7:87:71
Mar 15 12:15:21 1337pi dhcpcd[318]: wlan0: adding address fe80::a6c2:e78a:eb40:57
Mar 15 12:15:21 1337pi dhcpcd[318]: wlan0: rebinding lease of 192.168.43.84
Mar 15 12:15:22 1337pi dhcpcd[318]: wlan0: probing address 192.168.43.84/24
Mar 15 12:15:22 1337pi dhcpcd[318]: wlan0: soliciting an IPv6 router
Mar 15 12:15:23 1337pi avahi-daemon[283]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::a6c2:e78a:eb40:57.
Mar 15 12:15:23 1337pi avahi-daemon[283]: New relevant interface wlan0.IPv6 for mDNS.
Mar 15 12:15:23 1337pi avahi-daemon[283]: Registering new address record for fe80::a6c2:e78a:eb40:57 on wlan0.*.
Mar 15 12:15:27 1337pi dhcpcd[318]: wlan0: leased 192.168.43.84 for 3600 seconds
Mar 15 12:15:27 1337pi avahi-daemon[283]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.43.84.
Mar 15 12:15:27 1337pi avahi-daemon[283]: New relevant interface wlan0.IPv4 for mDNS.
Mar 15 12:15:27 1337pi dhcpcd[318]: wlan0: adding route to 192.168.43.0/24
Mar 15 12:15:27 1337pi avahi-daemon[283]: Registering new address record for 192.168.43.84 on wlan0.IPv4.
Mar 15 12:15:27 1337pi dhcpcd[318]: wlan0: adding default route via 192.168.43.1
Mar 15 12:15:35 1337pi dhcpcd[318]: wlan0: no IPv6 Routers available
Im using OpenPlotter 1.2.0 right now, but the same problem was persistent on every OS i did install.
If you need anything else, please tell my - I'm doing everything so get this working.

Kind regards,
Andreas


Edit:

Quick update:

Did install raspbian lite.
Another os, same problem.

epoch1970
Posts: 2582
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: [PI 3B+]Wlan0 - carrier lost | 5ghz hotspot of phone <-> internal wifi chip wlan0

Sat Mar 16, 2019 3:34 pm

If you're in Germany you should not use US frequencies. Each country regulates with frequencies are allowed for use by the general public. Some frequencies are reserved for public services.

Run wpa_supplicant in the foreground, optionally with extra traces. See "man wpa_supplicant" for the relevant options.
You might see why it disconnects from the traces. I surmise it somehow refuses to use the frequency and disconnects itself.

Your software configuration is not standard. I would advise testing from a fresh, up-to-date version of Raspbian, and once you have identified the necessary wpa_supplicant options, port the fix to your regular system.

You can reduce power, not increase it. Power is regulated as well.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

busti
Posts: 3
Joined: Fri Mar 15, 2019 2:03 pm

Re: [PI 3B+]Wlan0 - carrier lost | 5ghz hotspot of phone <-> internal wifi chip wlan0

Sat Mar 16, 2019 7:51 pm

Hello,

I have no choice than using the US band.
My samsung s9 gives me no option to change the channel of the 5ghz band.
Its always 5.7xxghz.
And my rasp does not detect that band with the country set to DE.

Also, im now using a fresh copy of an updated raspbian lite version.

I also found out (by monitoring the wpa handshake) that the connection also drops on my 5ghz router with country set to DE.

So this is definetly a raspberry-settings issue.

Im always loosing carrier and i tested it on 3 different raspberry and a ton of different OS versions.
Everything else is working, only the 5ghz gets carrier lost and reconnects, every minute and 10-30 seconds.
I found this time also by monitoring the wpa handshakes.

I also did iwconfig wlan0 power off
Still, same results.

If i connect my usb wifi dongle - the dongle is not loosing connection, not a single time.

Thank you for your help.

busti
Posts: 3
Joined: Fri Mar 15, 2019 2:03 pm

Re: [PI 3B+]Wlan0 - carrier lost | 5ghz hotspot of phone <-> internal wifi chip wlan0

Wed Mar 20, 2019 6:18 pm

Hello people.

You can close this thread, i did find the solution.
Thank you anyway.

---

If anybody is facin the same problem, my temporary solution (still looking for an full fix):

If i connect my pi to my hotspot, after about 1 minute and some seconds my hotspot sends a request to the pi, to change his region from US to DE.
My pi switches to DE and because the the DE frequency does not cover 4.745, i get carrier lost, as the pi cant find the spot anymore with region DE.
After loosing the connection, the pi rejects the IE request to set the carrier to DE, as the carrier who askd us to do so is not visible anymore.
Now the pi falls back to US and finds the hotspot again, he connects and after 1 min and 10-15 seconds, the IE request is coming back, carrier lost.
And this is repeating over and over.

The (temporary) solution to this is: monitor "iw event"
As soon as the IE request is visible, set the command iw dev set reg US.
This forces the pi to ignore the request and stay on US.
the result, fast and stable 5ghz wlan without carrier dropping.

Now, the last question, how to deny the IE request from the beginning, without monitoring iw events and forceing my country code?

Return to “Networking and servers”