werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

issue with enter key and screen program

Sat Dec 15, 2018 5:48 pm

hi guys i'm starting with this raspbian thing and trying to learn about it but i encountered this issue when inside an instance of the screen program, i'm trying to test some fona commands but typing the command and when i want to test the command by pressing enter key, it just return the propmt to start and does nothing but that, don't know what could be or if i am doing something wrong, hope you can understand me and can help me, if you guys want me to explain it a bit better i would try to! thanks in advance to those who can help me

User avatar
neilgl
Posts: 1106
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near Aston Martin factory

Re: issue with enter key and screen program

Mon Dec 17, 2018 9:48 am

Yes please explain more. What command do you type in?

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Tue Dec 18, 2018 1:08 pm

neilgl wrote:
Mon Dec 17, 2018 9:48 am
Yes please explain more. What command do you type in?
i opened a screen instance and typed AT, when i press enter key the promp positioned at the beggining of the current line and does nothing, i mean it doesn't send the command i'm typing, i don't know why it's happening that.

pcmanbob
Posts: 7069
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: issue with enter key and screen program

Tue Dec 18, 2018 1:51 pm

i'm trying to test some fona commands

From this statement I assume you are attempting to communicate with a GSM module, if this is in fact what you are doing then sending AT with no other commands will not get any response AT just means "attention" your GSM module will then be expecting a command to follow.

https://www.developershome.com/sms/atCommandsIntro.asp
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Tue Dec 18, 2018 2:09 pm

pcmanbob wrote:
Tue Dec 18, 2018 1:51 pm
i'm trying to test some fona commands

From this statement I assume you are attempting to communicate with a GSM module, if this is in fact what you are doing then sending AT with no other commands will not get any response AT just means "attention" your GSM module will then be expecting a command to follow.

https://www.developershome.com/sms/atCommandsIntro.asp
i tried it already and the first time i followed the tutorial to set up the fona it worked as expected, i typed AT and i got an OK response back, but now every time i open up a terminal, the enter key does nothing but to position the prompt to the beggining of the current line, i already tried with screen and picocom and does exactly the same i change the keyboard config already to test if the keyboard config was messing this up but it didin't work =/

pcmanbob
Posts: 7069
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: issue with enter key and screen program

Tue Dec 18, 2018 3:52 pm

Then I suggest you look at your project and compare it to the tutorial you were following and see what you are doing differently, it might also be worth checking all connections between the pi and your GSM module.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Wed Dec 19, 2018 12:09 am

pcmanbob wrote:
Tue Dec 18, 2018 3:52 pm
Then I suggest you look at your project and compare it to the tutorial you were following and see what you are doing differently, it might also be worth checking all connections between the pi and your GSM module.
already did that like 100 times, is really desperate that things doesn't work as expected to...
i am now try to do it in python, passing the command to the port and then the read method of the port send back the string of the command that i'm sending, as a response instead of the expected response that i'm waiting =/

Image
https://imgur.com/a/NHluYpz

here in this image you can see the command that i am sending and what i am receiving from it

User avatar
DougieLawson
Posts: 36310
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: issue with enter key and screen program

Wed Dec 19, 2018 12:45 am

Have you disabled the serial console in sudo raspi-config or in the preferences GUI?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

pcmanbob
Posts: 7069
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: issue with enter key and screen program

Wed Dec 19, 2018 12:34 pm

i tried it already and the first time i followed the tutorial to set up the fona it worked as expected,
Seeing as you say you had it working the first time you followed the tutorial what are you doing differently this time ?

what hardware or software have you changed between the first time and now ?
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Wed Dec 19, 2018 1:08 pm

pcmanbob wrote:
Wed Dec 19, 2018 12:34 pm
i tried it already and the first time i followed the tutorial to set up the fona it worked as expected,
Seeing as you say you had it working the first time you followed the tutorial what are you doing differently this time ?

what hardware or software have you changed between the first time and now ?
i didn't change anything neither the hardware nor the software, i followed the tutorial just fine over and over again, i formatted the raspbian os to a new one and had a fresh start to see what's happening and if any opf the downloaded software i am installing is the source of the problem and trying everything i'm finding on the web is really frustating =(

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Wed Dec 19, 2018 1:11 pm

DougieLawson wrote:
Wed Dec 19, 2018 12:45 am
Have you disabled the serial console in sudo raspi-config or in the preferences GUI?
i am actually triying that my friend and see how that goes, i'll tell you when i finish testing it ty

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Wed Dec 19, 2018 2:23 pm

look guys in these 2 images i am running the process and i'll show you the active ports in the system for the communication that i need to stablish

https://imgur.com/T1frBtq

https://imgur.com/iTylQz2

i am currently using a SIM808 gsm module

i have few questions that i hope you can answer me guys so:

How do i know if the module is correctly connected?
How do i know which serial port is the module using(or a command to list the serial ports and their guests)?

i suppose that the read method of the serial library is returning the same command as a string and not a real response to the command, because i am connecting to the wrong serial port but i dont really know what can be? hope you guys can help with this

rhubarbdog
Posts: 64
Joined: Mon Dec 11, 2017 9:58 pm

Re: issue with enter key and screen program

Wed Dec 19, 2018 7:30 pm

Unplug your GSM. Wait 1 minute, plug it back in type

Code: Select all

dmesg | tail
that should indicate which device file the modem has connected to

werefol
Posts: 8
Joined: Sat Dec 15, 2018 5:36 pm

Re: issue with enter key and screen program

Wed Dec 19, 2018 9:24 pm

rhubarbdog wrote:
Wed Dec 19, 2018 7:30 pm
Unplug your GSM. Wait 1 minute, plug it back in type

Code: Select all

dmesg | tail
that should indicate which device file the modem has connected to
this is what i got back executing what you suggest

https://imgur.com/ZLjQISn

what should i watch here? it seems like there's only information about internet ports

Return to “Troubleshooting”