Posts: 1
Joined: Sat Dec 08, 2018 1:09 am

USB Camera problem: not detect on boot on Rpi3A+/RpiZW

Sat Dec 08, 2018 1:29 am


I'm experiencing a strange problem:
I have a cheap usb camera (model SQ11

When the camera is connected to a USB port after the RPI board has booted,
it is detected and works well.
But if the camera is already connected when the RPI board is powered on
(or rebooted), the camera is not detected.

I've tested it with RPI-Zero-wireless and RPI3A+.

Strangely, when testing on RPI3B and RPI3B+ it works fine even upon boot.

So I'm assuming it has something finicky with USB initialization
(perhaps because RPIzW/RPI3A+ have less capable USB hardware?).

I've tried adding "boot_delay" and "bootcode_delay" to config.txt,
they didn't solve the issue.

Any ideas? suggestion to try?

I tried to find ways to reset or power-cycle the USB power,
but couldn't find such anything for RPIzW/RPI3A+.

- gordon


lsusb shows:

Code: Select all

$ lsusb
Bus 001 Device 004: ID 1908:3272 GEMBIRD
dmesg shows (when the camera is detected):

Code: Select all

# dmesg
usb 1-1.5: new high-speed USB device number 5 using dwc_otg
usb 1-1.5: config 1 interface 3 has no altsetting 1
usb 1-1.5: New USB device found, idVendor=1908, idProduct=3272
usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1.5: Product: GENERAL - AUDIO
usb 1-1.5: Manufacturer: Generic
usb-storage 1-1.5:1.4: USB Mass Storage device detected
scsi host0: usb-storage 1-1.5:1.4
scsi 0:0:0:0: Direct-Access     Buildwin Media-Player     1.00 PQ: 0 ANSI: 4
sd 0:0:0:0: Attached scsi generic sg0 type 0
sd 0:0:0:0: [sda] Attached SCSI removable disk
(the camera includes a microphone and a microSD card reader, hence the detection of removable disk and audio device).

The power supply is a 5V/2.5A, so not likely an over-current issue.

Posts: 2
Joined: Thu Apr 02, 2020 3:45 pm

Re: USB Camera problem: not detect on boot on Rpi3A+/RpiZW

Thu Apr 02, 2020 3:47 pm


Is there a solution to this problem? Did you?


Return to “HATs and other add-ons”