maksimilian
Posts: 73
Joined: Thu Oct 04, 2018 10:36 am

Installation von Thonny in stretch

Sun Nov 04, 2018 12:03 pm

Hallo Ihr,

ich habe mit sudo apt-get install python3-thonny auf meinem Pi3 mit stretch Thonny installiert. Damit erhalte ich Version 2.1.16 . Wie kann man auf eine aktuellere Version aufrüsten ? Ich möchte z.B. Breakpoints setzen können, was wohl erst ab Version 3.0 unterstützt wird. Aktuell scheint 3.0.5 zu sein, aber möglicherweise nicht für raspbian.

maksimilian

fruitoftheloom
Posts: 20900
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Installation von Thonny in stretch

Sun Nov 04, 2018 1:19 pm

maksimilian wrote:
Sun Nov 04, 2018 12:03 pm
Hallo Ihr,

ich habe mit sudo apt-get install python3-thonny auf meinem Pi3 mit stretch Thonny installiert. Damit erhalte ich Version 2.1.16 . Wie kann man auf eine aktuellere Version aufrüsten ? Ich möchte z.B. Breakpoints setzen können, was wohl erst ab Version 3.0 unterstützt wird. Aktuell scheint 3.0.5 zu sein, aber möglicherweise nicht für raspbian.

maksimilian

Fully update Raspbian Stretch ??

Code: Select all

sudo apt update
sudo apt full-upgrade
Retired disgracefully.....

DirkS
Posts: 9956
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Installation von Thonny in stretch

Sun Nov 04, 2018 2:01 pm

fruitoftheloom wrote:
Sun Nov 04, 2018 1:19 pm
Fully update Raspbian Stretch ??

Code: Select all

sudo apt update
sudo apt full-upgrade
No. Latest version in RPF repo is 2.1.16

Pypi and piwheels have the latest version, so

Code: Select all

sudo pip3 install thonny
should get 3.0.5

maksimilian
Posts: 73
Joined: Thu Oct 04, 2018 10:36 am

Re: Installation von Thonny in stretch

Sun Nov 04, 2018 4:21 pm

Yes, sudo pip3 install thonny installs Thonny 3.0.5. Thank you!!! Thonny doesn't appear in start menu now, but that is not so important.

maksimilian

Return to “Deutsch”