shashank0129
Posts: 34
Joined: Sun Dec 18, 2016 5:03 pm

Dead USB and Ethernet ports

Fri Jul 20, 2018 2:26 pm

Hey,
The USB ports suddenly stopped working while I was installing retropie on my pi 3b....
The Ethernet too doesn't work....
I read a few posts and checked the voltage between PP3 and PP27 and didn't get 5v(almost 0)...
BTW I was using a 5v 2A power supply and it had worked for about a year pretty well....

So is my board fried? Is there any way to ssh into the pi without the Ethernet port(I have WiFi but don't know how to set it up without a mouse and keyboard)

Any help is appreciated, thanks!

User avatar
The Traveler
Posts: 363
Joined: Sat Oct 21, 2017 3:48 pm

Re: Dead USB and Ethernet ports

Fri Jul 20, 2018 2:32 pm

The USB ports suddenly stopped working while I was installing retropie on my pi 3b....
https://retropie.org.uk/forum/
Retired IT professional, C programmer and "beardie weirdie".
RPi interests: Developing an Infinite Improbability Drive
“Thinking outside of the box allows you to get rewards outside of your reach.” Matshona Dhliwayo

DirkS
Posts: 10130
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Dead USB and Ethernet ports

Fri Jul 20, 2018 3:05 pm

shashank0129 wrote:
Fri Jul 20, 2018 2:26 pm
So is my board fried?
Get a new SD card and try installing Raspbian Desktop or Lite from https://www.raspberrypi.org/downloads/raspbian/

shashank0129
Posts: 34
Joined: Sun Dec 18, 2016 5:03 pm

Re: Dead USB and Ethernet ports

Fri Jul 20, 2018 4:58 pm

DirkS wrote:
Fri Jul 20, 2018 3:05 pm
shashank0129 wrote:
Fri Jul 20, 2018 2:26 pm
So is my board fried?
Get a new SD card and try installing Raspbian Desktop or Lite from https://www.raspberrypi.org/downloads/raspbian/
Already tried.... :cry:

shashank0129
Posts: 34
Joined: Sun Dec 18, 2016 5:03 pm

Re: Dead USB and Ethernet ports

Fri Jul 20, 2018 4:59 pm

The Traveler wrote:
Fri Jul 20, 2018 2:32 pm
The USB ports suddenly stopped working while I was installing retropie on my pi 3b....
https://retropie.org.uk/forum/
Well I was installing emulation station on top of raspbian stretch so I thought it was appropriate to post here..

jbudd
Posts: 1081
Joined: Mon Dec 16, 2013 10:23 am

Re: Dead USB and Ethernet ports

Fri Jul 20, 2018 11:29 pm

Is there any way to ssh into the pi without the Ethernet port(I have WiFi but don't know how to set it up without a mouse and keyboard)
viewtopic.php?f=28&t=217153&p=1335479#p1335479


If there was still no ethernet when you burned a new SD card and booted it, things look bad for your Pi.
But just possibly the two USB ports furthest from the ethernet socket might still work, they have a different controller chip (or something, they work seperately from the othertwo and ethernet port).

fruitoftheloom
Posts: 21633
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Dead USB and Ethernet ports

Sat Jul 21, 2018 6:55 am

jbudd wrote:
Fri Jul 20, 2018 11:29 pm
Is there any way to ssh into the pi without the Ethernet port(I have WiFi but don't know how to set it up without a mouse and keyboard)
viewtopic.php?f=28&t=217153&p=1335479#p1335479


If there was still no ethernet when you burned a new SD card and booted it, things look bad for your Pi.
But just possibly the two USB ports furthest from the ethernet socket might still work, they have a different controller chip (or something, they work seperately from the othertwo and ethernet port).

Incorrect info, on RPis which have more than one USB Port as well as an Ethernet Port, they are all connected to a single USB2.0 Chipset, pre 3B+ it was a LAN9512/14:

https://www.microchip.com/wwwproducts/en/LAN9514
Retired disgracefully.....
......to a more gentile life !

User avatar
rpdom
Posts: 16107
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Dead USB and Ethernet ports

Sat Jul 21, 2018 7:08 am

fruitoftheloom wrote:
Sat Jul 21, 2018 6:55 am
Incorrect info, on RPis which have more than one USB Port as well as an Ethernet Port, they are all connected to a single USB2.0 Chipset, pre 3B+ it was a LAN9512/14:
Is this a 3B+? If so, there are two USB hubs in the onboard chip. It looks like one pair of sockets and the second hub are connected to the first hub. The other pair of sockets and the Ethernet are connected to the second hub. So a second hub internal failure could result in no ethernet and the loss of two USB ports.

Not saying this is the case here, just that it might be a possibility.

fruitoftheloom
Posts: 21633
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Dead USB and Ethernet ports

Sat Jul 21, 2018 7:26 am

rpdom wrote:
Sat Jul 21, 2018 7:08 am
fruitoftheloom wrote:
Sat Jul 21, 2018 6:55 am
Incorrect info, on RPis which have more than one USB Port as well as an Ethernet Port, they are all connected to a single USB2.0 Chipset, pre 3B+ it was a LAN9512/14:
Is this a 3B+? If so, there are two USB hubs in the onboard chip. It looks like one pair of sockets and the second hub are connected to the first hub. The other pair of sockets and the Ethernet are connected to the second hub. So a second hub internal failure could result in no ethernet and the loss of two USB ports.

Not saying this is the case here, just that it might be a possibility.

The OP talked about using for over a year in his initial post, hence why stated pre 3B+ :D
Retired disgracefully.....
......to a more gentile life !

Return to “Troubleshooting”