shubhamnath2
Posts: 3
Joined: Tue Jul 03, 2018 5:35 am

Raspberry Pi not working, red light only

Tue Jul 03, 2018 7:25 am

I bought a Raspberry Pi 3 Model B+ 2 weeks back, and did a small project related to weather monitoring. After that I wanted to check the led blinking with the Raspberry, and tried the connection. I want to check whether the led was working or not, so i put the led pins with 5v pin and gnd pin (for checking purpose) and suddenly, the system went off and not even booting. I suspect some hardware problem.
Can anyone help me please??

texy
Forum Moderator
Forum Moderator
Posts: 5155
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 9:00 am

If you suspect you have blown the pi hardware then there is not a lot you can do. Just in case the SD went pop, have you tried another?
Also are you getting 5V on the Pi GPIO port still?
Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

drgeoff
Posts: 9745
Joined: Wed Jan 25, 2012 6:39 pm

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 9:13 am

shubhamnath2 wrote:
Tue Jul 03, 2018 7:25 am
I bought a Raspberry Pi 3 Model B+ 2 weeks back, and did a small project related to weather monitoring. After that I wanted to check the led blinking with the Raspberry, and tried the connection. I want to check whether the led was working or not, so i put the led pins with 5v pin and gnd pin (for checking purpose) and suddenly, the system went off and not even booting. I suspect some hardware problem.
Can anyone help me please??
Did you put only the LED between 5 volts and ground or did you also have a suitable series resistor? Never do the former. If you did, the RPi's polyfuse may have "blown". Try leaving the RPi unpowered for a day.

In the same vein, never connect a LED without a resistor (external or internal) to a GPIO output. That can kill the GPIO and ultimately the whole RPi.
Last edited by drgeoff on Tue Jul 03, 2018 9:17 am, edited 1 time in total.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12124
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 9:15 am

You might have violated rule #1 of using the RPI's GPIO's, never put more than (about) 4Volt on a GPIO, as that will cause latch-up in the GPIO logic which burns up the silicon chip inside the SoC.

THE PI's GPIO's are NOT 5V tolerant!.

When that happens the PI is quite literally toasted, and its a defect that cannot be repaired.

drgeoff
Posts: 9745
Joined: Wed Jan 25, 2012 6:39 pm

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 9:20 am

mahjongg wrote:
Tue Jul 03, 2018 9:15 am
You might have violated rule #1 of using the RPI's GPIO's, never put more than (about) 4Volt on a GPIO, as that will cause latch-up in the GPIO logic which burns up the silicon chip inside the SoC.

THE PI's GPIO's are NOT 5V tolerant!.

When that happens the PI is quite literally toasted, and its a defect that cannot be repaired.
While that warning is aposite, there is no indication in the original post that rule #1 was violated.

shubhamnath2
Posts: 3
Joined: Tue Jul 03, 2018 5:35 am

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 9:36 am

Definitely I violated that rule because I didn't use the resistor (of 1K OHM) because I didn't have one right now. I did use a potentiometer as a replacement of color code resistor (CCR) but there was no proper explanation in google/youtube (and topmost googled sites).I watched the video with CCR one and tried using a potentiometer but it was not lighting up. After testing that one without resistor and BOOM!! System went off.

drgeoff
Posts: 9745
Joined: Wed Jan 25, 2012 6:39 pm

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 11:27 am

mahjongg's rule #1 is about applying voltages outside the range 0 to 3.3 to a GPIO. Not all pins on the 40 pin header are GPIOs. The 5 volt, 3.3 and ground pins are not GPIOs.

Another rule is not to put into, or take from, a GPIO more than 16 mA. You are likely to do that is you connect a red, green or yellow LED without a resistor. That can kill the GPIO and cause internal damage which spreads within the Broadcom chip. Usual symptom is that it starts to get very hot to the touch within seconds of powering on. No cure for that.

As I said above if your only sin was connecting the LED between 5 volts and ground then you may have killed the LED and tripped the protective polyfuse in the RPi. That should self-heal if the RPi is left unpowered,

shubhamnath2
Posts: 3
Joined: Tue Jul 03, 2018 5:35 am

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 11:44 am

For another test, I actually connected a lcd display in a 4 bit mode via jumper cables , breadboard, 2 potentiometer, and the damaged Pi
LINK: http://www.circuitbasics.com/raspberry- ... in-python/
After completing the connection, LCD display light up, backlight brightness and character contrast are varied using potentiometer.

What does it mean?

Another Ques: (Childish yet crucial one)
During the weather monitoring, I (once) accidentally put 5V female cable to -ve side of breadboard which is already grounded to raspi's gnd and the system reboots.

What does it mean?

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12124
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 12:14 pm

drgeoff wrote:
Tue Jul 03, 2018 9:20 am
mahjongg wrote:
Tue Jul 03, 2018 9:15 am
You might have violated rule #1 of using the RPI's GPIO's, never put more than (about) 4Volt on a GPIO, as that will cause latch-up in the GPIO logic which burns up the silicon chip inside the SoC.

THE PI's GPIO's are NOT 5V tolerant!.

When that happens the PI is quite literally toasted, and its a defect that cannot be repaired.
While that warning is aposite, there is no indication in the original post that rule #1 was violated.
As it was impossible to determine exactly what the OP had done, I just listed the #1 reason for a blown up RPI chip, and said that that MIGHT have happened. only the OP knows if this applies to him.

Heater
Posts: 13109
Joined: Tue Jul 17, 2012 3:02 pm

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 12:33 pm

Conveniently the Pi has two GPIO pins adjacent to 5v supply pins on the GPIO connector.

Thus making it super easy to accidentally connect 5v to 3.3v GPIO pins when dicking around hooking things up.

drgeoff
Posts: 9745
Joined: Wed Jan 25, 2012 6:39 pm

Re: Raspberry Pi not working, red light only

Tue Jul 03, 2018 1:02 pm

shubhamnath2 wrote:
Tue Jul 03, 2018 11:44 am
For another test, I actually connected a lcd display in a 4 bit mode via jumper cables , breadboard, 2 potentiometer, and the damaged Pi
LINK: http://www.circuitbasics.com/raspberry- ... in-python/
After completing the connection, LCD display light up, backlight brightness and character contrast are varied using potentiometer.

What does it mean?

Another Ques: (Childish yet crucial one)
During the weather monitoring, I (once) accidentally put 5V female cable to -ve side of breadboard which is already grounded to raspi's gnd and the system reboots.

What does it mean?
The two potentiometers control the LCD display directly. Tells you nothing about the state of the RPi.

Have you left the RPi unpowered for some hours to give the polyfuse time to recover?

Does the green ACT LED flash at all when you power up the RPi?

Return to “General discussion”