douglas5962
Posts: 28
Joined: Thu Mar 29, 2018 2:22 pm

PiGen tool no longer working

Tue Apr 24, 2018 3:38 pm

Hi everyone,

Over the last week or so I've been facing issues with the Pi Gen tool not successfully completing. The tool is running through all 5 stages and will start the export process but never completes successfully. It looks like the script is failing somewhere in the export process just after stopping the HW clock. Below is what I am seeing right at the point it dumps back to the command prompt. I do not see a deploy folder like I would have expected.

I did open an issue ticket on Github but haven't heard anything there yet. I am using the latest version of Raspbian inside a VM. I have tried both the master branch on Github plus the last 3 releases. It seems like something change on Github or the RPi mirror because copies of the tool that worked 2 weeks ago are now failing.


Code: Select all

[02:54:42] End /home/pi/Desktop/pi-gen-nov/export-image/01-set-sources/01-run.sh
[02:54:42] End /home/pi/Desktop/pi-gen-nov/export-image/01-set-sources
[02:54:42] Begin /home/pi/Desktop/pi-gen-nov/export-image/02-network
[02:54:42] Begin /home/pi/Desktop/pi-gen-nov/export-image/02-network/01-run.sh
[02:54:42] End /home/pi/Desktop/pi-gen-nov/export-image/02-network/01-run.sh
[02:54:42] End /home/pi/Desktop/pi-gen-nov/export-image/02-network
[02:54:42] Begin /home/pi/Desktop/pi-gen-nov/export-image/03-set-partuuid
[02:54:42] Begin /home/pi/Desktop/pi-gen-nov/export-image/03-set-partuuid/00-run.sh
[02:54:42] End /home/pi/Desktop/pi-gen-nov/export-image/03-set-partuuid/00-run.sh
[02:54:42] End /home/pi/Desktop/pi-gen-nov/export-image/03-set-partuuid
[02:54:42] Begin /home/pi/Desktop/pi-gen-nov/export-image/04-finalise
[02:54:42] Begin /home/pi/Desktop/pi-gen-nov/export-image/04-finalise/01-run.sh
Stopping fake hwclock: saving system time.
Mode:     real
Files:    2279
Linked:   405 files
Compared: 0 xattrs
Compared: 625 files
Saved:    14.34 MiB
Duration: 0.10 seconds
fatal: Not a git repository (or any of the parent directories): .git
[email protected]:~/Desktop/pi-gen-nov $ 

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6086
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: PiGen tool no longer working

Tue Apr 24, 2018 3:41 pm

Could you please link the issue you opened?

douglas5962
Posts: 28
Joined: Thu Mar 29, 2018 2:22 pm

Re: PiGen tool no longer working

Tue Apr 24, 2018 3:53 pm

Sorry, that was an oversight on my part.

https://github.com/RPi-Distro/pi-gen/issues/180

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6086
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: PiGen tool no longer working

Tue Apr 24, 2018 3:58 pm

Thanks. Replied there.

douglas5962
Posts: 28
Joined: Thu Mar 29, 2018 2:22 pm

Re: PiGen tool no longer working

Tue Apr 24, 2018 4:08 pm

Cool, Thanks!

Return to “Raspbian”