User avatar
DougieLawson
Posts: 36813
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Use Wifi in latest raspbian lite stretch in headless mode

Wed Mar 21, 2018 10:05 pm

liamkennedy wrote:
Tue Mar 20, 2018 11:59 pm
UPDATE: SOLVED. on the 3+ 2018-03-13 Stretch or NOOBS 2.7 versions YOU MUST configure the country= setting
FTFY, you're welcome.

There was a sudo apt update; sudo apt -y dist upgrade on the latest Raspbian that added a new rfkill process.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
liamkennedy
Posts: 62
Joined: Thu Dec 19, 2013 10:12 am
Contact: Website Facebook Twitter

Re: Use Wifi in latest raspbian lite stretch in headless mode

Wed Mar 21, 2018 10:53 pm

HawaiianPi wrote:
Wed Mar 21, 2018 7:25 pm
I don't know why people are always trying to cut corners with the wpa_supplicant.conf file. If you use a properly configured wpa_supplicant.conf, it just works. The procedure I outlined in my reply back in November works on the new 3B+, it works on the Pi Zero W and 3B, and it works on all other models with a Raspbian compatible USB WiFi dongle.
I know.. what a life.. sorry we all ignored your sage advice.

For me.. I fell in to this trap because for the past four+ years it was not REQUIRED (the country= bit). And until this release I saw nothing to confirm that it was. It's STILL not required if you have anything other than the Pi3+ (at the time I tested it.. of course maybe that will be changed in the future).

The release notes on the latest version of Stretch clears up what is going on perfectly. Having THAT official note from the Raspberry Pi Foundation is the nugget of information that was missing.

From now on.. country= will be there in everything I do.

Mystery solved.

User avatar
liamkennedy
Posts: 62
Joined: Thu Dec 19, 2013 10:12 am
Contact: Website Facebook Twitter

Re: Use Wifi in latest raspbian lite stretch in headless mode

Wed Mar 21, 2018 11:21 pm

DougieLawson wrote:
Wed Mar 21, 2018 10:05 pm
liamkennedy wrote:
Tue Mar 20, 2018 11:59 pm
UPDATE: SOLVED. on the 3+ 2018-03-13 Stretch or NOOBS 2.7 versions YOU MUST configure the country= setting
FTFY, you're welcome.

There was a sudo apt update; sudo apt -y dist upgrade on the latest Raspbian that added a new rfkill process.
Just want to be clear.. that's NOT my quote. You edited it (added the strikeout for the 3+ in particular).. with some likely very helpful additional information.. but I want to make sure it's understood that's NOT from me (as it has MY name of course on it)

HAVE YOU verified that this new update now requires you have country= setting for all PRIOR version of the Raspberry Pi if you do a dist upgrade?

In my testing yesterday Stretch 2018-03-13 Image running in a Pi 3 2 or B+ or B then no country= is needed. Wifi just works

Put the image in a 3+ then country= is required. No wifi unless you do that (as per the release notes).

For me.. going forward I'll include it on my images.. so it's a moot point. Just curious however if you noticed the new updates also REQUIRES the country= setting when you run that in an older pi?

User avatar
DougieLawson
Posts: 36813
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Use Wifi in latest raspbian lite stretch in headless mode

Thu Mar 22, 2018 12:50 am

Go and Google "FTFY".
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
HawaiianPi
Posts: 5071
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Use Wifi in latest raspbian lite stretch in headless mode

Thu Mar 22, 2018 8:13 am

liamkennedy wrote:
Wed Mar 21, 2018 10:53 pm
For me.. I fell in to this trap because for the past four+ years it was not REQUIRED (the country= bit).
Yup, but those lines are there for a reason. Or do you think the Raspbian developers just added them because they thought they looked pretty? If the seemingly superfluous lines aren't being used now, then they have plans for them later. This is how the whole mess from Jessie to Stretch happened, and there were loads of non-functional guides out there as a result (and many confused Pi owners).
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

User avatar
liamkennedy
Posts: 62
Joined: Thu Dec 19, 2013 10:12 am
Contact: Website Facebook Twitter

Re: Use Wifi in latest raspbian lite stretch in headless mode

Fri Mar 23, 2018 5:06 am

DougieLawson wrote:
Thu Mar 22, 2018 12:50 am
Go and Google "FTFY".
Yes..Thank you for pointing that out.

AND.. I don't think you read my reply fully. Did you verify with 100% certainty that you MUST put the country= line when you use Stretch in anything other than the 3+ (as per the release notes from the foundation)? You specifically indicated a strikethrough on that part of my quote. So.. for the FTFY comment to be valid you surely MUST have confirmed THAT right?

It's a tiny change.. and...no trouble REALLY.. just you seem to be making a technical point which I think may be inaccurate. Even though.. yes.. we all know the GOLDEN rule from now on is to include the country= settings in all our wpa_supplicant.conf files going forward.
Last edited by liamkennedy on Fri Mar 23, 2018 5:08 am, edited 1 time in total.

User avatar
liamkennedy
Posts: 62
Joined: Thu Dec 19, 2013 10:12 am
Contact: Website Facebook Twitter

Re: Use Wifi in latest raspbian lite stretch in headless mode

Fri Mar 23, 2018 5:08 am

HawaiianPi wrote:
Thu Mar 22, 2018 8:13 am
Yup, but those lines are there for a reason. Or do you think the Raspbian developers just added them because they thought they looked pretty? If the seemingly superfluous lines aren't being used now, then they have plans for them later. This is how the whole mess from Jessie to Stretch happened, and there were loads of non-functional guides out there as a result (and many confused Pi owners).
No fear. I will forever follow your sage advice from this point forward. Thank you so much.

jbudd
Posts: 1054
Joined: Mon Dec 16, 2013 10:23 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Fri Mar 23, 2018 10:35 am

FTFY
Acronym for "fixed that for you."

Often used sarcastically - not to fix an honest mistake, but to sarcastically disagree with someone.
TGFUD!

JRS_RPi
Posts: 2
Joined: Tue Oct 24, 2017 4:49 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Sat Mar 24, 2018 9:08 pm

Hi all,

I also struggled with the wifi configuration on a RPI3+ with lastest updated Stretch ... until I read on the Internet that if the Access Point is hidding its ssid, then the following line needs to be added : scan_ssid=1

then the network definition looks like :

network={
ssid="SSID"
scan_ssid=1
psk="password"
key_mgmt=WPA-PSK
}

My two cents

User avatar
HawaiianPi
Posts: 5071
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Use Wifi in latest raspbian lite stretch in headless mode

Sat Mar 24, 2018 10:31 pm

JRS_RPi wrote:
Sat Mar 24, 2018 9:08 pm
Hi all,

I also struggled with the wifi configuration on a RPI3+ with lastest updated Stretch ... until I read on the Internet that if the Access Point is hidding its ssid, then the following line needs to be added : scan_ssid=1
A simpler solution is not to hide your SSID. It doesn't make your network more secure, and in fact it can actually make it less secure, on top of creating unnecessary connection headaches. Just don't do it, it's pointless.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

User avatar
MartyMacGyver
Posts: 32
Joined: Sat Jan 26, 2013 1:37 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Mon Mar 26, 2018 8:35 am

This should be simple but unlike previous Pi's, I cannot get my shiny new Pi 3B+ to come up headlessly. My old Pi 3B is working fine on the same network (using Jessie still there). Power supply is 2.5A and power doesn't appear to be dropping out or anything like that. Router allows IPv6. SD card is fine.

I installed `2018-03-13-raspbian-stretch` via Etcher, added an empty `ssh` file to /boot, and added `wpa_supplicant.conf` to /boot as so:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="<hidden>"
	scan_ssid=1
	psk="<hidden>"
	key_mgmt=WPA-PSK
}
I made sure this was a Unix format file. My ssid is not actually hidden and adding/removing `scan_ssid` had no extra effect. psk is definitely correct.

I boot, wait a while, and the Pi never appears on the network (watching from the router and network scans).

The syslog pulled off the /var/logs folder has this interesting section each time it gets booted:

Code: Select all

Mar 13 23:17:04 raspberrypi systemd[1]: Started Light Display Manager.
Mar 13 23:17:05 raspberrypi dhcpcd[383]: eth0: waiting for carrier
Mar 13 23:17:05 raspberrypi dhcpcd[383]: wlan0: if_up: Operation not possible due to RF-kill
Mar 13 23:17:05 raspberrypi dhcpcd[383]: wlan0: waiting for carrier
Mar 13 23:17:05 raspberrypi dhcpcd[383]: eth0: carrier acquired
Mar 13 23:17:05 raspberrypi kernel: [    6.946403] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Mar 13 23:17:05 raspberrypi dhcpcd[383]: DUID 00:01:00:<deleted>
Mar 13 23:17:05 raspberrypi dhcpcd[383]: eth0: IAID eb:<deleted>
Mar 13 23:17:05 raspberrypi dhcpcd[383]: eth0: adding address fe80::<deleted>
Mar 13 23:17:05 raspberrypi dhcpcd[383]: eth0: carrier lost
Mar 13 23:17:05 raspberrypi dhcpcd[383]: eth0: deleting address fe80::<deleted>
Any thoughts on what might be going on here? I've followed all the headless steps here faithfully (and have re-flashed twice now though I doubt that had any additional effect).

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6091
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Use Wifi in latest raspbian lite stretch in headless mode

Mon Mar 26, 2018 8:45 am

I think you're running into a race condition between the service which copies wpa_supplicant.conf and the one that checks whether the wifi country is set. Unfortunately the image doesn't have the fix in it yet.

Does it start working if you delete /var/lib/systemd/rfkill/* off the card after first boot?

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: Use Wifi in latest raspbian lite stretch in headless mode

Mon Mar 26, 2018 8:52 am

ShiftPlusOne wrote:
Mon Mar 26, 2018 8:45 am
Unfortunately the image doesn't have the fix in it yet.
sorry to jump in,
could that mean that boot it in a RPI3B would work, make a update upgrade there and then
boot it in a RPI3B+
pls confirm

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6091
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Use Wifi in latest raspbian lite stretch in headless mode

Mon Mar 26, 2018 8:58 am

KLL wrote:
Mon Mar 26, 2018 8:52 am
ShiftPlusOne wrote:
Mon Mar 26, 2018 8:45 am
Unfortunately the image doesn't have the fix in it yet.
sorry to jump in,
could that mean that boot it in a RPI3B would work, make a update upgrade there and then
boot it in a RPI3B+
pls confirm
You're exactly right, if the issue is what I suspect it is.

User avatar
MartyMacGyver
Posts: 32
Joined: Sat Jan 26, 2013 1:37 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 1:33 am

ShiftPlusOne wrote:
Mon Mar 26, 2018 8:45 am
I think you're running into a race condition between the service which copies wpa_supplicant.conf and the one that checks whether the wifi country is set. Unfortunately the image doesn't have the fix in it yet.

Does it start working if you delete /var/lib/systemd/rfkill/* off the card after first boot?
(I assume this reply is to my post...)

I've been doing this via Windows 7 and have so far only mounted the Linux partition read-only. Will give that a try first if I can manage to get it mounted (a Linux VM should do the trick). As for booting in a Pi 3B, I have one I can try that with, but hopefully I can avoid that. I'll let you know how it all goes.

That said, I have two questions about the issue itself: where can I track the progress of it (e.g., a link to the issue) and when might it be in an official build (if nothing else, how often do those get released)? I doubt I'm the only person dealing with this so it'd be handy info to have should the question arise.

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 1:45 am

MartyMacGyver wrote:
Tue Mar 27, 2018 1:33 am
As for booting in a Pi 3B, I have one I can try that with, but hopefully I can avoid that. I'll let you know how it all goes.

That said, I have two questions about the issue itself: where can I track the progress of it (e.g., a link to the issue) and when might it be in an official build (if nothing else, how often do those get released)? I doubt I'm the only person dealing with this so it'd be handy info to have should the question arise.
i mentioned the RPI3B because i read that you have one!
pls note that it might also work with the RPI3B+
just using a ethernet cable?

problems for headless wifi "setupers" might not be reason enough to make a release.
anyhow check here for newer release and changes

User avatar
MartyMacGyver
Posts: 32
Joined: Sat Jan 26, 2013 1:37 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 2:14 am

KLL wrote:
Tue Mar 27, 2018 1:45 am
i mentioned the RPI3B because i read that you have one!
pls note that it might also work with the RPI3B+
just using a ethernet cable?

problems for headless wifi "setupers" might not be reason enough to make a release.
anyhow check here for newer release and changes
It looks like releases are either sporadic or clustered. Hopefully there will be one sooner than later to address the things the Pi 3B+ is likely to have shaken out on wide release.

I wanted to do a nice, clean setup without booting with a different board, and preferably without hard-wiring it, but failing everything else it's one way to get up and running.

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 2:19 am

understand, i also use headless only.
but somehow you mix releases and fixes

User avatar
MartyMacGyver
Posts: 32
Joined: Sat Jan 26, 2013 1:37 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 2:34 am

MartyMacGyver wrote:
Tue Mar 27, 2018 1:33 am
ShiftPlusOne wrote:
Mon Mar 26, 2018 8:45 am
I think you're running into a race condition between the service which copies wpa_supplicant.conf and the one that checks whether the wifi country is set. Unfortunately the image doesn't have the fix in it yet.

Does it start working if you delete /var/lib/systemd/rfkill/* off the card after first boot?
(I assume this reply is to my post...)

I've been doing this via Windows 7 and have so far only mounted the Linux partition read-only. Will give that a try first if I can manage to get it mounted (a Linux VM should do the trick). As for booting in a Pi 3B, I have one I can try that with, but hopefully I can avoid that. I'll let you know how it all goes.

That said, I have two questions about the issue itself: where can I track the progress of it (e.g., a link to the issue) and when might it be in an official build (if nothing else, how often do those get released)? I doubt I'm the only person dealing with this so it'd be handy info to have should the question arise.
Deleting those files in `rfkill` didn't work, but that advice helped me find the solution (with help from this issue: https://github.com/RPi-Distro/raspberry ... -355072018)!

Assuming `wpa_supplicant.conf` is correct (especially the `country` parameter) and you have a similar situation, try the following:

Mount the SD card's Linux ext4 partition read/write (Paragon ExtFS is handy for Windows though it takes three reboots to install and fully update it)

Locate the file `/var/lib/systemd/rfkill/platform-3f300000.mmc:wlan` (Paragon manages to give it a usable name - that `:` would otherwise be problematic in Windows)

Edit `platform-3f300000.mmc:wlan` and replace 1 with 0

(You could use `sudo bash -c "echo '0' > /var/lib/systemd/rfkill/platform-3f300000.mmc:wlan"` in Linux to equal effect)

Unmount the Linux partition and then unmount the SD card.

Boot the Pi 3B+ with the SD card and if that was the problem, it should work now!

(Note: the `platform-soc:bluetooth` file seemed to be correct already.)

So, thanks for the very helpful suggestion! As a bonus, the `raspberrypi.local` addressing worked great too - not sure how new of a feature that is but if not for this little hitch I'd never needed to even watch the router or scan for it - super-handy! :D

User avatar
MartyMacGyver
Posts: 32
Joined: Sat Jan 26, 2013 1:37 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 2:40 am

KLL wrote:
Tue Mar 27, 2018 2:19 am
understand, i also use headless only.
but somehow you mix releases and fixes
I was referring to the release changelog you linked to - on average there's been a release every 8 weeks or so, but some are clustered (only a week or two apart), and some are far apart (about 15-16 weeks between the last two). New products and big releases tend to lead to a flurry of fixes, which is why I think it might be sooner than later for whatever other new-release issues are being found with this board.

Most importantly, I know how to fix the problem now (see my longer post) so I'm happy.

User avatar
HawaiianPi
Posts: 5071
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 2:58 am

MartyMacGyver wrote:
Tue Mar 27, 2018 1:33 am
That said, I have two questions about the issue itself: where can I track the progress of it (e.g., a link to the issue) and when might it be in an official build (if nothing else, how often do those get released)? I doubt I'm the only person dealing with this so it'd be handy info to have should the question arise.
Is this really an issue?

I'm not dealing with it. My new 3B+ connected to my network first try. I followed the same procedure I've been using since Jessie. I even just double checked by testing both the Desktop and Lite versions of Raspbian Stretch 2018-03013, and I had no trouble pre-configuring a card for headless boot with SSH and wireless network.

In the days since I received by new 3B+ I have written new 2018-03-13 Raspbian Stretch images to several SD cards, and even an SSD drive with no trouble. With a properly configured wpa_supplicant.conf file and an ssh file, my 3B+ booted up and connected to my network each time (with SSH enabled).

It's always a bit puzzling when this kind of stuff happens to a few, while it works as intended for others.

I did notice that MartyMacGyver said he put the files in /boot, which is wrong. The ssh and wpa_supplicant.conf files should be on the tiny FAT32 partition of the Raspbian imaged SD card in the main directory (not in any folder).
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

User avatar
MartyMacGyver
Posts: 32
Joined: Sat Jan 26, 2013 1:37 am

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 3:47 am

HawaiianPi wrote:
Tue Mar 27, 2018 2:58 am
MartyMacGyver wrote:
Tue Mar 27, 2018 1:33 am
That said, I have two questions about the issue itself: where can I track the progress of it (e.g., a link to the issue) and when might it be in an official build (if nothing else, how often do those get released)? I doubt I'm the only person dealing with this so it'd be handy info to have should the question arise.
Is this really an issue?

I'm not dealing with it. My new 3B+ connected to my network first try. I followed the same procedure I've been using since Jessie. I even just double checked by testing both the Desktop and Lite versions of Raspbian Stretch 2018-03013, and I had no trouble pre-configuring a card for headless boot with SSH and wireless network.

In the days since I received by new 3B+ I have written new 2018-03-13 Raspbian Stretch images to several SD cards, and even an SSD drive with no trouble. With a properly configured wpa_supplicant.conf file and an ssh file, my 3B+ booted up and connected to my network each time (with SSH enabled).

It's always a bit puzzling when this kind of stuff happens to a few, while it works as intended for others.

I did notice that MartyMacGyver said he put the files in /boot, which is wrong. The ssh and wpa_supplicant.conf files should be on the tiny FAT32 partition of the Raspbian imaged SD card in the main directory (not in any folder).
Yes, it's an issue and I've seen your other posts on the topic. I put the files in /boot which from the perspective of a flash drive in windows is the root of the FAT partition. Furthermore those files were being correctly detected and parsed, with the proper configuration ending up in `/etc/wpa_supplicant/wpa_supplicant.conf`.

While it's not clear why `rfkill` isn't getting properly configured for some people, the one-bit fix fully resolved the problem. (Because in the end that's all that really changes between ascii '1' and '0'). I personally wonder if it's IPv6-related as that's still somewhat uncommon for routers by default, but whatever it is I'm not the first person to encounter it. I've yet to find a bug that matches this so I'm thinking I'll file it shortly here. Edit: actually, I'll wait a bit til I hear from @ShiftPlusOne here, as this appears to be a known bug that was already resolved, perhaps on the 4.14 branch.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6091
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 1:02 pm

It's not a kernel issue, but that the order in which two services start isn't explicitly specified, so they run at the same time. Depending on which one finishes first, it may or may not work, so it's not surprising that it's fine for some people, but an issue for others.

It would be 'nice' to find a few more issues to fix before releasing a new image.

User avatar
HawaiianPi
Posts: 5071
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 5:26 pm

ShiftPlusOne wrote:
Tue Mar 27, 2018 1:02 pm
It's not a kernel issue, but that the order in which two services start isn't explicitly specified, so they run at the same time. Depending on which one finishes first, it may or may not work, so it's not surprising that it's fine for some people, but an issue for others.

It would be 'nice' to find a few more issues to fix before releasing a new image.
If that was the case, wouldn't everyone experience it randomly? Or is there some other factor (like SD card speed, or PSU voltage) that makes it work reliably for some, but not for others?
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6091
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Use Wifi in latest raspbian lite stretch in headless mode

Tue Mar 27, 2018 6:11 pm

HawaiianPi wrote:
Tue Mar 27, 2018 5:26 pm
ShiftPlusOne wrote:
Tue Mar 27, 2018 1:02 pm
It's not a kernel issue, but that the order in which two services start isn't explicitly specified, so they run at the same time. Depending on which one finishes first, it may or may not work, so it's not surprising that it's fine for some people, but an issue for others.

It would be 'nice' to find a few more issues to fix before releasing a new image.
If that was the case, wouldn't everyone experience it randomly? Or is there some other factor (like SD card speed, or PSU voltage) that makes it work reliably for some, but not for others?
I don't know exactly what factors might affect which service finishes first. It's possible that some factors may make it fail more reliably. Or maybe the whole thing is a red herring.

Return to “Beginners”